Bug 1789 - Rebuild bluez to use /sbin/ instead of /us/sbin
: Rebuild bluez to use /sbin/ instead of /us/sbin
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-18 11:39 MSK by Denis Silakov
Modified: 2013-10-08 17:10 MSD (History)
1 user (show)

See Also:
RPM Package: bluez
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2013-03-18 11:39:13 MSK
Currently /lib/systemd/system/bluetooth.service file invokes /usr/sbin/bluetoothd, which is a symlink to /sbin/bluetoothd. It is more correct to exec /sbin/bluetoothd directly, and there is no obstacles for this.

One more thing is that users report that bluez rebuild with modern build environment is more stable (e.g., mouse and loudspeakers work simultaneously for a long time on systems where they expected problems/conflicts in the past). I can't say why is it so, maybe this is just a new build environment, since we haven't updated sources and the only new patch is the one that switches /usr/sbin to /sbin.

So it would be nice to check that at least there are no regressions with the new package.
Comment 1 Denis Silakov 2013-03-18 11:39:58 MSK
Advisory:

Rebuild bluez to exec bluetoothd from /sbin instead of /usr/sbin

Build lists:
https://abf.rosalinux.ru/build_lists/1021734
https://abf.rosalinux.ru/build_lists/1021735
Comment 2 Vladimir Potapov 2013-03-20 16:39:59 MSK
*************
The bluetooth tray icon hide after sleep-wakeup (close-open notebook lid). It's show only after bluetooth service restart.
*************
QA Denied
Comment 3 Denis Silakov 2013-03-20 17:42:19 MSK
Hm, did the previous version work?
Comment 4 Vladimir Potapov 2013-03-21 08:53:26 MSK
Previous version work ok. The error present both x686 and x64.
Comment 5 Denis Silakov 2013-10-08 17:09:37 MSD
Bluez has been updated since this bug was initially filed, so the stability question is not relevant. As for "/usr/sbin" vs "/sbin" question, this is currently just a cosmetic issue (unless we decide to join these two folders).
Comment 6 Denis Silakov 2013-10-08 17:10:11 MSD
Brr, wrong resolution.