Bug 1779 - service courier-imapd fails to start due to missing library links
: service courier-imapd fails to start due to missing library links
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: High major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-14 17:16 MSK by mayavimmer
Modified: 2013-03-15 13:40 MSK (History)
1 user (show)

See Also:
RPM Package: courier-imap-4.11.0-1-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mayavimmer 2013-03-14 17:16:05 MSK
Description of problem:

I installed courier-imap with urpmi. The service fails to start with a missing library message.

The missing libraries are:

[root@localhost ~]# ldd /usr/sbin/imaplogin
        linux-vdso.so.1 =>  (0x00007fff435ff000)
        libcourierauth.so => not found
        libcourierauthsasl.so => not found
        libc.so.6 => /lib64/libc.so.6 (0x00007f5002bc6000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f5002f98000)

Version-Release number of selected component (if applicable):

courier-imap-4.11.0-1-rosa2012.1.x86_64
courier-authlib-0.65.0-1-rosa2012.1.x86_64

How reproducible:

Whenever I try to start the service.

Steps to Reproduce:
1. service courier-imapd start
2. see error message about missing libs

Workaround:

ln -s /usr/lib64/courier-authlib/libcourierauth.so /lib64/
ln -s /usr/lib64/courier-authlib/libcourierauthsasl.so /lib64/

Derived from forum discussion at:

http://forum.rosalab.ru/viewtopic.php?f=33&t=1850&p=14453#p14453
Comment 1 Denis Silakov 2013-03-15 13:40:36 MSK
Should be fixed with updated courier-authlib, it should appear on mirrors during the day.