Bug 1777 - HP Color LaserJet CP 2025 and HP Color Laser Jet 2600 could not print several pages from LibreOffice and browsers
: HP Color LaserJet CP 2025 and HP Color Laser Jet 2600 could not print severa...
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-14 09:58 MSK by FirstLevel
Modified: 2013-08-26 15:06 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
diagnostic information (2.59 KB, text/plain)
2013-03-14 09:58 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-03-14 09:58:18 MSK
Created attachment 1261 [details]
diagnostic information

Description of problem:
I have a problem with printers. In the company I have a HP Color LaserJet CP 2025, the OS recognizes it and installs it, but when I send to print multiple sheets from libreoffice only prints one, and I must be printing of 1 to 1, then this stops me to install this OS in other business machines. I hope to see this error,  I tested with HP Color Laser Jet 2600 and was the same problem

I have attached cat /etc/cups/printers.conf and lsusb output

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Silakov 2013-03-14 10:36:59 MSK
It's interesting if the problem lies in drivers or in libreoffice.
Do you able to print from other programs (e.g., same the problematic file as PDF in libreoffice, open it using okular and try to print from there)?

Another question is what driver is used? Go to printer settings in KDE CC, click on your printer, click the 'Change...' button near the 'Make and Model', choose 'HP' and click Forward, and in the 'Choose driver' dialog you may have several options for drivers; if you really have more that one option, you may experiment with choosing different drivers.

For the printers in question, you may try to use either hplip drivers from HP or foo2zjs drivers (install hplip and cups-drivers-foo2zjs packages correspondingly).
You can also try tha latest foo2zjs from its official site - http://foo2hp.rkkda.com/
Comment 2 Denis Silakov 2013-08-26 15:06:38 MSD
Closing this one since there was no response for a long time.

If somebody still experience this issue - try to experiment with different drivers as described in the comment above.