Bug 1772 - [UPDATE REQUEST] nvidia-current 313.26
: [UPDATE REQUEST] nvidia-current 313.26
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-13 09:11 MSK by Aleksandr Kazantcev
Modified: 2013-05-15 10:29 MSD (History)
7 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2013-03-13 09:11:12 MSK
New version proprietary driver
Comment 1 Aleksandr Kazantcev 2013-03-13 09:14:43 MSK
https://abf.rosalinux.ru/build_lists/1017356
https://abf.rosalinux.ru/build_lists/1017357

Advisory: New version of propritary driver nvidia-current (for NVIDIA chipset 8xxx and upper). This version provide some usefull changes:
- Added support for the following GPUs: GeForce GTX TITAN
- Added support for the following GPUs: GeForce GTX 680MX, Tesla K20Xm
- Added support in NV-CONTROL and in nvidia-settings for changing the Double - - - Precision performance boost mode on supported GPUs.
- Fixed a bug in nvidia-settings that allowed unavailable features to be selected in some drop-down menus.
- Fixed several OpenGL driver bugs related to stencil-only framebuffer objects.
- Updated the NVIDIA X driver to reprobe displays when VT-switching to X, to allow reporting of hotplug events when displays are connected or disconnected while VT-switched away from X.
- Added unofficial GLX protocol support (i.e for GLX indirect rendering) for the following extension and core commands: GL_ARB_vertex_array_object; OpenGL 3.0 commands ClearBufferfi, ClearBufferfv, ClearBufferiv, ClearBufferuiv and GetStringi.
- Fixed a bug that caused the cursor shadow to be clipped to 32x32 pixels, even on Kepler GPUs that support a 256x256 cursor image.
- Fixed a bug that prevented some cursor image updates from taking effect on displays with rotation or other transformations applied.
- Fixed cursor alpha blending artifacts on displays with rotation or other transformations applied.
- Added support for the GLX_EXT_buffer_age extension.
- Improved the performance of glDrawPixels() by up to 450% when the pixel data is of type GL_BYTE.
- Fixed a bug when enabling framelock between displays connected to the same GPU as other displays with different refresh rates.
- Updated the reporting of HDMI 3D framerates and pixel clocks to be more consistent with how they are reported by HDMI 3D displays.
- Fixed a bug that sometimes prevented rotation controls in the nvidia-settings control panel from working after changing resolutions.
- Fixed a bug that could cause applications using GL_NV_vdpau_interop to crash during modeswitches.
- Fixed a regression that could cause OpenGL applications to crash while compiling shaders.
- Added a kernel module parameter, "NVreg_EnablePCIeGen3", which can be used to enable PCIe gen 3 when possible.
- Fixed a VDPAU bug that could cause the X server to hang when decoding some corrupted video streams.
- Renamed VGX products to GRID products in the "Supported NVIDIA GPU Products" list.
- Added support for X.org xserver ABI 14 (xorg-server 1.14).
- Fixed a bug in nvidia-settings that could cause the wrong resolution to be set in basic mode for setups based on one display per X screen.
- Fixed libnvidia-encode.so library dependency by linking it with libnvcuvid.so.1 instead of libnvcuvid.so while creating it.
- Improved performance of OpenGL framebuffer object binds with Xinerama enabled by 2000-3000% when the application's windows do not span screen boundaries.
- Fix performance issues when using some versions of HyperMesh with Quadro GPUs.
Comment 3 Aleksandr Kazantcev 2013-03-13 09:21:06 MSK
Please fix this driver with this xserver for font corruption in FF and Chromium

https://abf.rosalinux.ru/build_lists/1017265
https://abf.rosalinux.ru/build_lists/1017266
Comment 4 Denis Silakov 2013-03-13 09:23:46 MSK
*** Bug 1539 has been marked as a duplicate of this bug. ***
Comment 5 Vladimir Potapov 2013-03-14 15:02:02 MSK
I can't setup nvidia-current-cuda-opencl package.

Не удаётся установить запрошенный пакет:
nvidia-current-cuda-opencl-313.26-2-rosa2012.1.i586 (из-за неудовлетворённости libnvcuvid.so.1)

For the old version there is a similar bug
Comment 6 Aleksandr Kazantcev 2013-03-14 15:17:34 MSK
This is known bug. I try resolve it, but solution is not trivial - this bug relate to autoreq RPM part. Please add bug to bugzilla related to nvidia-current package

Also please test blob with new kernel 3.7.x from Request.
Comment 9 Vladimir Potapov 2013-03-14 18:14:50 MSK
OK, last update normally installed under both kernels. 
The package route to extended testing.
Comment 10 Postnikov Dmitry 2013-03-27 20:18:06 MSK
****************************
Extended testing report
****************************
Test card 7600GT
When updating nvidia-current already installed 310 version, everything works.
When installing 313 version on a clean system, during the installation of the sudden reboot, X would not start up.
Comment 11 Aleksandr Kazantcev 2013-03-27 20:38:17 MSK
nvidia-current NOT WORK on cards < 8xxx
Comment 12 Postnikov Dmitry 2013-03-27 20:59:27 MSK
(In reply to comment #11)
> nvidia-current NOT WORK on cards < 8xxx

Yes, I know it. But me was asked to check it is on card 7600GT.
Comment 13 Vladimir Potapov 2013-03-28 16:38:02 MSK
**************
When installing 313 version on a clean system, during the installation of the sudden reboot, X would not start up.
**************
QA Denied
Comment 14 Aleksandr Kazantcev 2013-04-11 01:39:22 MSD
https://abf.rosalinux.ru/build_lists/1052921
https://abf.rosalinux.ru/build_lists/1052922

Advisory: see upper
Comment 15 Vladimir Potapov 2013-04-11 12:03:34 MSD
The package route to extended testing
Comment 16 Postnikov Dmitry 2013-04-23 18:52:21 MSD
************************
Extended testing report
************************

GTX 480.
Installed a Fresh 2012 i586 completely updated system.
Added the repository from the current 313-26, have run the urpmi --auto-update, which reported that update nothing. Went to the XFdrake, chose the current, installation started. In the middle of all gone out, on the screen began to show pixels. Here ATTENTION:
1)if you press the key combination alt+ctrl+del, the screen is covered with green pixels and after the reboot die periphery;
2) if you simply restart the computer manually (click the reboot), then the system is loaded and the periphery of the works, but the resolution is still low and the nvidia driver is not used. Go again to the XFdrake, choose the same driver, this all is well, reboot - resolution normal. driver - nvidia.

GeForce GTX 480.
Installed a Fresh x64, completely updated system.
Permission is small, the nvidia driver is not used. When trying to choose nvidia-long-lived he tries to install the driver and in the middle of the installation of all the falls, on the screen of pixels of different colors. Reboot and try to install the nvidia-current - same result, all falls after a phase of the clean area on the stage of depmod...
After the reset is not working, no keyboard, no mouse. With it in the BIOS all devices are visible and working. and in the system itself is not. If after that, log in to Windows, there also does not work peripherals. If demolish the system and put again, the problem is solved.

Plugged the repository with the version of the current 313.26 - same result.
Comment 17 Aleksandr Kazantcev 2013-04-23 18:59:00 MSD
If system gone to blinking color pixel - it has broken videocard. Because you did not complete install procedure you has this error. All install driver will be get some result i think. 

You need install only in CLI - go to console, login as root and go to init 3 mode

 init 3

than run XFdrake.
Comment 18 Yura Yurochko 2013-04-24 15:47:52 MSD
I installed current 313.26 from virtual console. I went into it by ctrl+alt+f2 and pressed "init 3". After login as root and pressed "XFdrake". I choosed nvidia-current and installed it.  After rebooting it works, installing finished completely without error.

(In reply to comment #17)
> If system gone to blinking color pixel - it has broken videocard. Because
> you did not complete install procedure you has this error. All install
> driver will be get some result i think. 
> 
> You need install only in CLI - go to console, login as root and go to init 3
> mode
> 
>  init 3
> 
> than run XFdrake.
Comment 19 Vladimir Potapov 2013-04-25 16:31:27 MSD
x11-driver-video-nvidia-current-313.26-5-rosa2012.1
********************** Advisory ***********************
New version of propritary driver nvidia-current (for NVIDIA chipset 8xxx and upper)
********************** Changelog **********************
- Added support for the following GPUs: GeForce GTX TITAN
- Added support for the following GPUs: GeForce GTX 680MX, Tesla K20Xm
- Added support in NV-CONTROL and in nvidia-settings for changing the Double - - - Precision performance boost mode on supported GPUs.
- Fixed a bug in nvidia-settings that allowed unavailable features to be selected in some drop-down menus.
- Fixed several OpenGL driver bugs related to stencil-only framebuffer objects.
- Updated the NVIDIA X driver to reprobe displays when VT-switching to X, to allow reporting of hotplug events when displays are connected or disconnected while VT-switched away from X.
- Added unofficial GLX protocol support (i.e for GLX indirect rendering) for the following extension and core commands: GL_ARB_vertex_array_object; OpenGL 3.0 commands ClearBufferfi, ClearBufferfv, ClearBufferiv, ClearBufferuiv and GetStringi.
- Fixed a bug that caused the cursor shadow to be clipped to 32x32 pixels, even on Kepler GPUs that support a 256x256 cursor image.
- Fixed a bug that prevented some cursor image updates from taking effect on displays with rotation or other transformations applied.
- Fixed cursor alpha blending artifacts on displays with rotation or other transformations applied.
- Added support for the GLX_EXT_buffer_age extension.
- Improved the performance of glDrawPixels() by up to 450% when the pixel data is of type GL_BYTE.
- Fixed a bug when enabling framelock between displays connected to the same GPU as other displays with different refresh rates.
- Updated the reporting of HDMI 3D framerates and pixel clocks to be more consistent with how they are reported by HDMI 3D displays.
- Fixed a bug that sometimes prevented rotation controls in the nvidia-settings control panel from working after changing resolutions.
- Fixed a bug that could cause applications using GL_NV_vdpau_interop to crash during modeswitches.
- Fixed a regression that could cause OpenGL applications to crash while compiling shaders.
- Added a kernel module parameter, "NVreg_EnablePCIeGen3", which can be used to enable PCIe gen 3 when possible.
- Fixed a VDPAU bug that could cause the X server to hang when decoding some corrupted video streams.
- Renamed VGX products to GRID products in the "Supported NVIDIA GPU Products" list.
- Added support for X.org xserver ABI 14 (xorg-server 1.14).
- Fixed a bug in nvidia-settings that could cause the wrong resolution to be set in basic mode for setups based on one display per X screen.
- Fixed libnvidia-encode.so library dependency by linking it with libnvcuvid.so.1 instead of libnvcuvid.so while creating it.
- Improved performance of OpenGL framebuffer object binds with Xinerama enabled by 2000-3000% when the application's windows do not span screen boundaries.
- Fix performance issues when using some versions of HyperMesh with Quadro GPUs.
**********************************************************
QA Verified
Comment 20 Alexander Petryakov 2013-05-15 10:23:29 MSD
X11 not startted after update
Hardware:  
 NVIDIA Corporation G96 [GeForce 9500 GT] (rev a1)

Error message in log: 
 kernel: [    9.823830] NVRM: API mismatch: the client has the version 313.26, but
 kernel: [    9.823830] NVRM: this kernel module has the version 310.19.  Please
 kernel: [    9.823830] NVRM: make sure that this kernel module and all NVIDIA  driver
 kernel: [    9.823830] NVRM: components have the same version.

System: 
 ROSA Desktop.Fresh release 2012.1 (Desktop) for x86_64

rpm -aq | grep nvidia:
 dkms-nvidia-current-313.26-5-rosa2012.1.x86_64
 x11-driver-video-nvidia-current-313.26-5-rosa2012.1.x86_64
 nvidia-current-doc-html-313.26-5-rosa2012.1.x86_64
Comment 21 Aleksandr Kazantcev 2013-05-15 10:29:49 MSD
On some machines package failed with dkms error - dkms compile new module but not replace it with new. I don't know, why this error appear - for some machine update proceeded properly.

Please check this package: http://bugs.rosalinux.ru/show_bug.cgi?id=2001