Bug 1764 - RPM cuts off some fields in info page when specspo is installed
: RPM cuts off some fields in info page when specspo is installed
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Low minor
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-11 19:01 MSK by Denis Koryavov
Modified: 2015-04-15 18:51 MSD (History)
2 users (show)

See Also:
RPM Package: rpm-5.4.10-7-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Koryavov 2013-03-11 19:01:17 MSK
Description of problem:

RPM cuts off some fields in info page when specspo is installed. For example, there is a 'rpm -qi' for bash:

rpm -qi bash | grep Group
Group       : Командные проце Source RPM: bash-4.2-11.2.src.rpm

Expected result (something like this):
Expected result: Командные процессоры         Source RPM: bash-4.2-11.2.src.rpm

Version-Release number of selected component (if applicable):
rpm-5.4.10-7-rosa2012.1.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install specspo. 
2. Run 'rpm -qi bash'
Comment 1 Vladimir Testov 2013-03-13 11:21:27 MSK
There is a problem with counting string's length if there are UTF-8 symbols in the string. So rpm thinks that length of the string "Командные проце" is more than shown. And rpm -qi have limitation of the string length. Something like that.

I will take a look at the source code.
Comment 2 Stanislav Fomin 2015-04-15 18:32:23 MSD
Надо перетестировать под RED, и либо
* закрыть, если не воспроизводится
* либо приложить свежие свидетельства, будем разбираться.
Comment 3 Denis Silakov 2015-04-15 18:39:11 MSD
The issue is still valid.