Bug 1761 - urpmi does not use full terminal width
: urpmi does not use full terminal width
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-11 13:41 MSK by Konstantin Vlasov
Modified: 2014-02-11 17:17 MSK (History)
2 users (show)

See Also:
RPM Package: urpmi-6.71-3
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2013-03-11 13:41:00 MSK
When I run urpmi for installing or updating some packages the preliminary information is displayed with the list of the packages to be installed. The problem is, this list is too narrow and some names and versions are simply cut off. For example, it may look like follows:

To satisfy dependencies, the following packages are going to be installed:
 Package                        Version      Release       Dist  DEpoch Arch
(medium "kernels_38x")
 kernel-nrjQL-desktop-3.8.1-69> 1            1             rosa  2012.1 x86_64
 kernel-nrjQL-desktop-devel-3.> 1            1             rosa  2012.1 x86_64
 kernel-nrjQL-desktop-devel-la> 3.8.1        69            rosa  2012.1 x86_64
 kernel-nrjQL-desktop-latest    3.8.1        69            rosa  2012.1 x86_64

But I'm doing all this in a maximized Konsole window, and nearly half the screen to the right of the quoted text remains empty. urpmi could use this space to display more information, but it doesn't.
Comment 1 Postnikov Dmitry 2013-03-11 14:43:51 MSK
+10
Comment 2 Denis Silakov 2013-05-23 13:14:10 MSD
Feel free to try these builds:

(32bit)
https://abf.rosalinux.ru/build_lists/1108384

(64bit)
https://abf.rosalinux.ru/build_lists/1108385

not sending to qa yet, I guess they are busy with more important updates.
Comment 3 Konstantin Vlasov 2013-05-23 17:03:16 MSD
After installing this update (x86_64), mdkapplet starts crashing with the following message:


The "mdkapplet" program has crashed with the following error:

  Undefined subroutine &main::SYS_uname called at /usr/lib/perl5/vendor_perl/5.14.2/MDK/Common/System.pm line 303.
  Compilation failed in require at /usr/lib/libDrakX/modules.pm line 9.
  BEGIN failed--compilation aborted at /usr/lib/libDrakX/modules.pm line 9.
  Compilation failed in require at /usr/lib/libDrakX/detect_devices.pm line 15.
  BEGIN failed--compilation aborted at /usr/lib/libDrakX/detect_devices.pm line 15.
  Compilation failed in require at /usr/lib/libDrakX/any.pm line 10.
  BEGIN failed--compilation aborted at /usr/lib/libDrakX/any.pm line 10.
  Compilation failed in require at /usr/lib/libDrakX/network/tools.pm line 270.
  Perl's trace:
  standalone::bug_handler() called from /usr/bin/mdkapplet:306

Used theme: rosa-elementary

To submit a bug report, click on the report button.  
This will open a web browser window on Bugzilla where you'll find a form to fill in.  The information displayed above will be transferred to that server
It would be very useful to attach to your report the output of the following command: 'lspcidrake -v'.
Comment 4 Denis Silakov 2013-10-31 14:13:21 MSK
One more attempt.

Can you try these packages:

(32bit)
https://abf.rosalinux.ru/build_lists/1376294

(64bit)
https://abf.rosalinux.ru/build_lists/1376295

They seem to work fine for me, both 32 and 64bit.
Comment 5 Denis Silakov 2014-02-11 14:53:50 MSK
This fix was merged together with other updates in last urpmi updates.
Comment 6 Konstantin Vlasov 2014-02-11 17:17:47 MSK
Confirm the fix.