Bug 1760 - kernel was updated to 3.7.10 [UPDATE REQUEST]
: kernel was updated to 3.7.10 [UPDATE REQUEST]
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-07 12:40 MSK by Alexander Burmashev
Modified: 2013-04-03 16:11 MSD (History)
2 users (show)

See Also:
RPM Package: kernel-3.7.10
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-
alex.burmashev: published-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Burmashev 2013-03-07 12:40:44 MSK
kernel was updated to 3.7.10
Comment 1 Alexander Burmashev 2013-03-07 12:43:12 MSK
Description:
Kernel was updated to 3.7.10. 3.7.10 is EOL, that means there will be no updates in the 3.7 branch anymore, this is the last one.

Advisory:
kernel was updated to 3.7.10 version

buildlists:
x86_64
https://abf.rosalinux.ru/build_lists/1014259
https://abf.rosalinux.ru/build_lists/1014263

i586
https://abf.rosalinux.ru/build_lists/1014258
https://abf.rosalinux.ru/build_lists/1014262
Comment 2 Vladimir Potapov 2013-03-11 19:07:57 MSK
I have problem with this update. My wireless card is rtl8723.
It's work with driver http://dl.dropbox.com/u/57056576/DRIVERS/REALTEK/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012.tar.gz
on Marathon and Fresh. But after the update, this driver don't setup.

make -C /lib/modules/3.7.10-nrj-desktop-1rosa/build M=/media/root_GNOME/1/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012 modules
make[1]: Вход в каталог `/usr/src/linux-3.7.10-nrj-desktop-1rosa'
  CC [M]  /media/root_GNOME/1/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.o
/media/root_GNOME/1/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c: В функции «rtl_send_smps_action»:
/media/root_GNOME/1/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:1432:16: ошибка: «struct <anonymous>» не содержит элемента с именем «sta»
make[2]: *** [/media/root_GNOME/1/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.o] Ошибка 1
make[1]: *** [_module_/media/root_GNOME/1/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012] Ошибка 2
make[1]: Выход из каталога `/usr/src/linux-3.7.10-nrj-desktop-1rosa'
make: *** [all] Ошибка 2
Comment 3 Vladimir Potapov 2013-03-12 14:13:44 MSK
The update route to extended testing
Comment 4 Alexander Burmashev 2013-03-13 12:17:32 MSK
I spent some time investigatin the problem with rtl8723 driver.
Seems that it is really not building on 3.7 kernel, but was integrated into 3.8 kernel. As we do not yet want to publish 3.8 to the main repo, can you please try compat drivers from it ?
Here is the link, please note, that it includes not only your wifi drivers, but
  * Ethernet
  * Wireless
  * Bluetooth
  * GPU
subsystem drivers.
Generally it is even better, because it contains a fresher ( and better ) drivers.

So here is the link
http://dl.dropbox.com/u/67020729/compat-drivers-2012-12-19-u.tar.bz2
Comment 5 Vladimir Potapov 2013-03-15 13:54:02 MSK
(In reply to comment #4)
> 
> So here is the link
> http://dl.dropbox.com/u/67020729/compat-drivers-2012-12-19-u.tar.bz2
This driver work with all kernels.
Comment 6 Postnikov Dmitry 2013-03-21 00:25:31 MSK
http://cdn.2safe.com/530732033559/Postnikov-all(kernel3710).odt

****************************
Extended testing report
****************************
Comment 7 Alexander Burmashev 2013-03-21 00:50:23 MSK
Thx for the report, looking at it and taking in consideration that 3.7 is actually much worse then the 3.8 in terms of hardware support it is beter to reject the update.
I noticed the BFQ part and took it in consideration. Thx.
Please set this bug as denied by QA.

BTW, expect 3.8.4 kernel soon )
Comment 8 Vladimir Potapov 2013-03-21 09:01:01 MSK
************
Regress with copy operations
************
QA Denied