Bug 1750 - [UPDATE REQUEST] usermode and related package
: [UPDATE REQUEST] usermode and related package
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-04 13:26 MSK by Aleksandr Kazantcev
Modified: 2013-04-03 16:21 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-
alex.burmashev: published+


Attachments
source manager run's error (159.91 KB, image/png)
2013-03-06 15:10 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2013-03-04 13:26:50 MSK
Update usermode, needing for future update
Comment 2 Vladimir Potapov 2013-03-04 16:31:12 MSK
> drakx-net
> https://abf.rosalinux.ru/build_lists/981114
> https://abf.rosalinux.ru/build_lists/981114
Please, fix the bad links
Comment 4 Vladimir Potapov 2013-03-05 10:59:38 MSK
The update route to extended testing
Comment 5 Postnikov Dmitry 2013-03-05 11:13:14 MSK
(In reply to comment #4)
> The update route to extended testing

Will test after the 8th March. Now others tasks.
Comment 6 Vladimir Potapov 2013-03-06 15:10:08 MSK
Created attachment 1251 [details]
source manager run's error

After update, on my x64 test system source manager don't run.
This is bug of this update (after rollback with urpm-reposync everything becomes all right)
Comment 7 Alexander Burmashev 2013-03-06 15:15:56 MSK
Did you reboot after the update ?
Comment 8 Aleksandr Kazantcev 2013-03-06 15:31:17 MSK
If drakrpm-edit-media run properly?
Comment 9 Vladimir Potapov 2013-03-06 15:46:03 MSK
1) Yes, I reboot test system after all updates
2) drakrpm-edit-media run correctly
3) On x86 system the error present too.
Comment 10 Aleksandr Kazantcev 2013-03-06 18:33:30 MSK
Please test all KDE part... May be we need rules for it too
Comment 11 Postnikov Dmitry 2013-03-07 14:57:49 MSK
Took on the advanced testing...
Comment 12 Postnikov Dmitry 2013-03-11 11:03:23 MSK
http://cdn.2safe.com/490943033559/Postnikov(usermode).odt

*************************
Extended testing report
*************************
Comment 13 Aleksandr Kazantcev 2013-03-11 11:48:15 MSK
All error is about obsoletes part. This not error anymore - obsolete utilites still not deleted becouse some user wants use it, but they need run it from root.
Comment 14 Aleksandr Kazantcev 2013-03-11 11:51:52 MSK
And ALL programm from /usr/sbin user (not root) will not be able running anymore - this also not error. Drakconf is Obsoletes too and it's not work - this not error too. Only kcm part need be fixed.
Comment 15 Postnikov Dmitry 2013-03-11 11:57:26 MSK
As i understand, now "user" from the /usr/sbin you cannot run utility, only from the root ? And for "user" only kcm modules to run?
Comment 16 Aleksandr Kazantcev 2013-03-11 11:58:32 MSK
draksec will be fixed after PAM update. keyboarddrake and mousedrake not got error.
Comment 17 Aleksandr Kazantcev 2013-03-11 12:04:52 MSK
Please test work only kcm part and update system (mdkonline applet) - drakx utilites will be changed after this update (we will drop Obsoletes and fix some utilites), but without PAM update we has many problem for future system stability.



Also please run from user:

gurpmi2 (will request root password)
gurpmi.addmedia (run without password)
urpmi (need root password)
urpme (need root password)
urpmi.update -a (without root password)
XFdrake (without root password)
Comment 18 Postnikov Dmitry 2013-03-11 12:16:08 MSK
(In reply to comment #17)
> Please test work only kcm part and update system (mdkonline applet) - drakx
> utilites will be changed after this update (we will drop Obsoletes and fix
> some utilites), but without PAM update we has many problem for future system
> stability.

How to update mdkoline-applet? I'm all of the above links added and updated.


> 
> Also please run from user:
> 
> gurpmi2 (will request root password)
> gurpmi.addmedia (run without password)
> urpmi (need root password)
> urpme (need root password)
> urpmi.update -a (without root password)
> XFdrake (without root password)

From User konsole:

gurpmi2 (will request root password) = Work
gurpmi.addmedia (run without password) = NOT work (error: "Unknown error")
urpmi (need root password) = work
urpme (need root password) = work
urpmi.update -a (without root password) = work
XFdrake (without root password) = work
Comment 19 Alexander Burmashev 2013-04-03 15:34:45 MSD
We ( Alex Kazancev and Alex Burmashev ) took a collective decision to publish this usermode related packages.
We are awaiting bug reports related to this update :)