Bug 1749 - Could not use Microsoft MCE Remote for control XBMC. Lirc could not start
: Could not use Microsoft MCE Remote for control XBMC. Lirc could not start
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-04 10:58 MSK by FirstLevel
Modified: 2013-06-11 11:49 MSD (History)
2 users (show)

See Also:
RPM Package: lirc-0.9.0-6-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
lsusb (948 bytes, text/plain)
2013-03-04 10:58 MSK, FirstLevel
Details
lirc start error (5.22 KB, text/plain)
2013-03-04 10:59 MSK, FirstLevel
Details
lircd.conf (292 bytes, text/plain)
2013-03-04 11:00 MSK, FirstLevel
Details
device config (10.10 KB, text/plain)
2013-03-04 11:01 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-03-04 10:58:27 MSK
Created attachment 1245 [details]
lsusb

Description of problem:
I have installed ROSA 2012.1 Fresh and had such device Microsoft MCE Remote 
I have tried to configure my device as descrived here http://mtaalamu.ru/blog/874.html but after customization lirc daemon could not start

I have attached  lirc config, log of starting lirc and Microsoft MCE Remote  configuration file

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-03-04 10:59:11 MSK
Created attachment 1246 [details]
lirc start error
Comment 2 FirstLevel 2013-03-04 11:00:15 MSK
Created attachment 1247 [details]
lircd.conf
Comment 3 FirstLevel 2013-03-04 11:01:25 MSK
Created attachment 1248 [details]
device config
Comment 4 FirstLevel 2013-03-04 11:02:00 MSK
btw I have not foud lirc-remotes package in Fresh repositories
Comment 5 Denis Silakov 2013-03-27 14:46:30 MSK
I've built lirc-remotes package for contrib, but this is not the reason of the problem - user uses config file from the site he mentioned, and that's ok.

Please try to launch lircd using systemctl:

# systemctl start lircd

and then show output of journalctl.

I have also tried to launched lirc with config from that site and got no errors. Though I don't have a real device to try ifit works or not.
Comment 6 Denis Silakov 2013-06-11 11:49:03 MSD
For now, I am closing this bug, since we don't have a reproducer. But feel free to reopen if the bug appears again. 

Note that lirc still uses the old-way init scripts, so it is possible that you will need to run

/etc/init.d/lircd start

to start it for sure.