Bug 1740 - rpmdrake incorrectly shows updates
: rpmdrake incorrectly shows updates
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-01 16:40 MSK by Vladimir Testov
Modified: 2015-04-03 17:31 MSD (History)
2 users (show)

See Also:
RPM Package: rpmdrake-5.26.12-8-rosa2012.1.noarch.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
two entities of ffmpeg (121.62 KB, image/png)
2013-03-01 16:40 MSK, Vladimir Testov
Details
can't use "Select All" on updates (146.96 KB, image/png)
2013-03-01 16:40 MSK, Vladimir Testov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Testov 2013-03-01 16:40:29 MSK
Created attachment 1234 [details]
two entities of ffmpeg

Description of problem:
rpmdrake does not show updates correctly. it there are two packages, both of them is update to an existing package (e.g. ffmpeg, contained in both main/updates and resctricted/updates with similar versions but different releases and dist-suffixes. So you can't select all updates by pressing "Select All".

Version-Release number of selected component (if applicable):
rpmdrake-5.26.12-8-rosa2012.1.noarch.rpm 

How reproducible:
always

Steps to Reproduce:
0. on fresh (not updated) installation of ROSA fresh 2012
1. connect media - main/updates and restricted/updates
2. start rpmdrake
3. select "View" -> "All packages, by update availability"
4. select "All" and "All" in two upper fields.
5. select "Upgradable"
6. scroll the main frame and you will see two ffmpeg

7. the problem is that you can't select all updates by pressing "Select All"
Comment 1 Vladimir Testov 2013-03-01 16:40:57 MSK
Created attachment 1235 [details]
can't use "Select All" on updates
Comment 2 FirstLevel 2014-06-09 11:24:33 MSD
Is Your case actual for Fresh R3 release?
Comment 3 Denis Silakov 2014-06-10 01:07:47 MSD
The issue is still valid. Though this is not a real bug, but a strange logic of rpmdrake creators who didn't thought that users would perform any actions except clicking on "Update" and "Ok" buttons.
Comment 4 FirstLevel 2014-10-08 21:54:36 MSD
Please could You check the problem for new release 2014.1
Comment 5 Denis Silakov 2014-11-23 00:28:10 MSK
The issue is still valid, nothing was changed in rpmdrake.
Comment 6 Denis Silakov 2015-04-03 17:31:02 MSD
Should be fixed after recent rpmdrake update. Now we show only the latest available package.