Bug 1693 - Apache could not start
: Apache could not start
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-19 12:56 MSK by FirstLevel
Modified: 2013-03-27 17:32 MSK (History)
2 users (show)

See Also:
RPM Package: apache-mpm-prefork-2.4.2-0.2-rosa2012.1.i586.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
journalctl output (82.62 KB, application/octet-stream)
2013-02-19 12:56 MSK, FirstLevel
Details
journalctl -a.txt (2.50 MB, text/plain)
2013-02-27 09:26 MSK, FirstLevel
Details
rpm -qa output (83.45 KB, text/plain)
2013-03-22 15:45 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-02-19 12:56:54 MSK
Created attachment 1213 [details]
journalctl output

Description of problem:
I have installed apache on my ROSA 2012.1 Fresh but it could not start
[root@bigcomp antichrist]# systemctl start httpd.service
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl' for details.
or 
[root@bigcomp antichrist]# service httpd start
Redirecting to /bin/systemctl start httpd.service
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl' for details.

I have reinstalled apache-mpm-prefork-2.4.2-0.2-rosa2012.1.i586.rpm - it does not help.
I have attached  journalctl output

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-02-19 12:57:54 MSK
I (firstlevel) could not reproduce this bug
Comment 2 Denis Silakov 2013-02-25 18:50:50 MSK
The error is likely caused by application with a wrong config file (not suitable for apache 2.4 used in Desktop Fresh - like phpadmin which I'll fix soon).

Unfortunately, the attached log is truncated at 80th column:

Feb 17 19:54:25 bigcomp.localdomain httpd[22862]: AH00526: Syntax error on li...
Feb 17 19:54:25 bigcomp.localdomain httpd[22862]: Either all Options must sta...
Feb 17 19:54:25 bigcomp.localdomain systemd[1]: httpd.service: control proce...1
Feb 17 19:54:25 bigcomp.localdomain systemd[1]: Failed to start The Apache H....
Feb 17 19:54:25 bigcomp.localdomain systemd[1]: Unit httpd.service entered f....

could you please run it with "-a" option when saving output to file:

# journalctl -a >myfile
Comment 3 FirstLevel 2013-02-27 09:26:37 MSK
Created attachment 1231 [details]
journalctl -a.txt
Comment 4 FirstLevel 2013-02-27 09:27:05 MSK
(In reply to comment #2)
> The error is likely caused by application with a wrong config file (not
> suitable for apache 2.4 used in Desktop Fresh - like phpadmin which I'll fix
> soon).
> 
> Unfortunately, the attached log is truncated at 80th column:
> 
> Feb 17 19:54:25 bigcomp.localdomain httpd[22862]: AH00526: Syntax error on
> li...
> Feb 17 19:54:25 bigcomp.localdomain httpd[22862]: Either all Options must
> sta...
> Feb 17 19:54:25 bigcomp.localdomain systemd[1]: httpd.service: control
> proce...1
> Feb 17 19:54:25 bigcomp.localdomain systemd[1]: Failed to start The Apache
> H....
> Feb 17 19:54:25 bigcomp.localdomain systemd[1]: Unit httpd.service entered
> f....
> 
> could you please run it with "-a" option when saving output to file:
> 
> # journalctl -a >myfile

I have attached output of command journalctl -a
Comment 5 Denis Silakov 2013-02-27 09:51:50 MSK
Hm, but the new attachment doesn't contain httpd errors.

On should try to start httpd, see that it fails, and provide output of 'journalctl -a' just after that.
Comment 6 Denis Silakov 2013-03-20 15:47:16 MSK
One more problematic package was fixed - apache-mod_perl (bug #1799; currently waiting for QA).

Maybe this issue was also caused by mod_perl? This is quite popular module which is automatically installed if user installs task-lamp.
Comment 7 FirstLevel 2013-03-22 09:56:04 MSK
(In reply to comment #6)
> One more problematic package was fixed - apache-mod_perl (bug #1799;
> currently waiting for QA).
> 
> Maybe this issue was also caused by mod_perl? This is quite popular module
> which is automatically installed if user installs task-lamp.

User's answer:
[root@bigcomp antichrist]# systemctl start httpd.service
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl' for details.
Comment 8 Denis Silakov 2013-03-22 10:10:01 MSK
Well, give me at least output of 'rpm -qa' and 'ls /etc/httpd/conf.d'
Comment 9 FirstLevel 2013-03-22 15:45:26 MSK
Created attachment 1272 [details]
rpm -qa output
Comment 10 FirstLevel 2013-03-22 15:45:58 MSK
(In reply to comment #8)
> Well, give me at least output of 'rpm -qa' and 'ls /etc/httpd/conf.d'

ls /etc/httpd/conf.d has empty output
Comment 11 Denis Silakov 2013-03-22 16:26:22 MSK
User should update php-eaccelerator and php-eaccelerator packages. This should help, I've fixed them not long ago to work with modern apache.
Comment 12 Denis Silakov 2013-03-22 16:26:42 MSK
Brr, "php-eaccelerator and php-eaccelerator-admin"
Comment 13 FirstLevel 2013-03-27 17:32:04 MSK
(In reply to comment #12)
> Brr, "php-eaccelerator and php-eaccelerator-admin"

Yes it works