Bug 1664 - [Solved] Suddenly high CPU usage and high CPU temperature working with any program, but reduce on idle
: [Solved] Suddenly high CPU usage and high CPU temperature working with any pr...
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-15 12:38 MSK by Serdar Ateş
Modified: 2013-02-25 00:46 MSK (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Top (4.64 KB, text/plain)
2013-02-15 12:38 MSK, Serdar Ateş
Details
Journalctl (3.18 KB, text/plain)
2013-02-15 12:39 MSK, Serdar Ateş
Details
cat /proc/cpuinfo (2.31 KB, text/plain)
2013-02-15 21:54 MSK, Serdar Ateş
Details
cpupower frequency-info (668 bytes, text/plain)
2013-02-15 21:56 MSK, Serdar Ateş
Details
sensors-detect (3.39 KB, text/plain)
2013-02-15 21:58 MSK, Serdar Ateş
Details
Cat (2.46 KB, text/plain)
2013-02-15 22:21 MSK, Serdar Ateş
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Serdar Ateş 2013-02-15 12:38:27 MSK
Created attachment 1196 [details]
Top

Description of problem: When I start 1 or 2 programs, CPU's sound change suddenly and increase high numbers and on the right bottom corner a dialogue box appear and give 
Message from syslogd@cowboy at Feb 15 10:10:20 ...
 kernel:[ 2577.396217] thermal_sys: Critical temperature reached (101 C), shutting down
such a kind of informations and CPU's sound comes like a burning engine,

Version-Release number of selected component (if applicable):


How reproducible:
Every time I attempt to start, minimize or maximize a programs.

Steps to Reproduce:
1.
2.
3.
Comment 1 Serdar Ateş 2013-02-15 12:39:22 MSK
Created attachment 1197 [details]
Journalctl
Comment 2 Aleksandr Kazantcev 2013-02-15 13:35:10 MSK
Please provide output of this command

  cat /proc/cpuinfo 

and

  cpupower frequency-info


Than try run (from root) 

  sensors-detect 

and say Yes for all questions after end of setup process provide output for

  sensors
Comment 3 Alexander Burmashev 2013-02-15 13:37:46 MSK
Looking at the top output it seems that plugin-container causes very high CPU load.


1) Try running firefox/TB in safe mode

2) Try disabling ALL of the themes/extensions/plugins, absolutely all
Comment 4 Alexander Burmashev 2013-02-15 13:40:53 MSK
(In reply to comment #3)
> Looking at the top output it seems that plugin-container causes very high
> CPU load.
> 
> 
> 1) Try running firefox/TB in safe mode
> 
> 2) Try disabling ALL of the themes/extensions/plugins, absolutely all

Sorry for not being accurate enough

2) Try disabling ALL of the themes/extensions/plugins, absolutely all - in Firefox or/and Thunderbird
Comment 5 Postnikov Dmitry 2013-02-15 14:20:26 MSK
(In reply to comment #3)
> Looking at the top output it seems that plugin-container causes very high
> CPU load.
> 
> 
I tried to simulate the situation. Plugin-container - a flash page in browser. Plus works Amarok, plus works ROMP. Large load on the system. Given fact that 2Gb memory yet. I could bring up to 96% of my CPU.
But... in such a situation, i guess you need something off of media programs.
Comment 6 Postnikov Dmitry 2013-02-15 14:28:36 MSK
(In reply to comment #5)
> (In reply to comment #3)
> > Looking at the top output it seems that plugin-container causes very high
> > CPU load.
> > 
> > 
> I tried to simulate the situation. Plugin-container - a flash page in
> browser. Plus works Amarok, plus works ROMP. Large load on the system. Given
> fact that 2Gb memory yet. I could bring up to 96% of my CPU.
> But... in such a situation, i guess you need something off of media programs.

Wow! I reached 143% processor load. :) If it is in the same situation open 3-4 page on Youtube in FF.
Comment 7 Serdar Ateş 2013-02-15 16:47:08 MSK
Okay maybe FF cause high CPU usage and its increase temperature, but it's happen when firefox closed, for example if I work with just Amarok CPU suddenly reach high frequency, temperature. This is only happen ROSA Fresh 2012, I work with ROSA  Marathon 2012 before, there is no similar thing happen, it's runing good.

I will try suggestions and give feedback I'm busy at now
Comment 8 Alexander Burmashev 2013-02-15 16:47:59 MSK
Does it happen when FF is closed ?
Can you provide the top output when FF is closed AND you have  high CPU load ?
Comment 9 Denis Koryavov 2013-02-15 16:53:32 MSK
modprobe acpi-cpufreq 

?
Comment 10 Serdar Ateş 2013-02-15 21:54:11 MSK
Created attachment 1201 [details]
cat /proc/cpuinfo
Comment 11 Serdar Ateş 2013-02-15 21:56:20 MSK
Created attachment 1202 [details]
cpupower frequency-info
Comment 12 Serdar Ateş 2013-02-15 21:58:58 MSK
Created attachment 1203 [details]
sensors-detect
Comment 13 Serdar Ateş 2013-02-15 22:12:08 MSK
Yes it happen when FF is closed, shortly before I try to install a application from CC it's reach 97 centigrade, I cannot use the system with these if I just listen music or watch movie it's ok, but if running 2-3 apps it's reach high temperature. I add attachments below.
Comment 14 Serdar Ateş 2013-02-15 22:21:05 MSK
Created attachment 1204 [details]
Cat

Here is the outputs no Plugin-container or FF, just running Amarok, Media player and try to install a application, CPU usage 89, and temperature reach 93 centigrade.
Comment 15 Aleksandr Kazantcev 2013-02-15 22:32:48 MSK
CPU freq part work OK, but CPU is overheat. Do fan in CPU work?
Comment 16 Aleksandr Kazantcev 2013-02-15 22:33:05 MSK
CPU freq part work OK, but CPU is overheat. Do fan in CPU work?
Comment 17 Serdar Ateş 2013-02-15 23:41:51 MSK
yes it work regular, when CPU work high fan's sound dramaticly change try to cool, CPU is okay in other Linux distro or ROSA Marathon 2012 but it's change in ROSA Fresh.
Comment 18 Aleksandr Kazantcev 2013-02-17 20:38:54 MSK
Try work in performance mode:

Uncomment in /etc/sysconfig/cpupower options and set this file like

# See 'cpupower help' and cpupower(1) for more info
CPUPOWER_START_OPTS="frequency-set -g performance"
CPUPOWER_STOP_OPTS="frequency-set -g ondemand"

then reboot

Will this do any change in CPU work?
Comment 19 Serdar Ateş 2013-02-18 17:48:44 MSK
Okay I did it, what happen now? it's pass to performance mode? because dialogues are appear and CPU same high working with high temperature there is no changing...
Comment 20 Aleksandr Kazantcev 2013-02-18 18:04:20 MSK
Now try use in this file ondemand in both... If not happen, reason not in CPU freq part and we need investigate next...
Comment 21 Serdar Ateş 2013-02-18 18:45:12 MSK
I tried in both but same... I install LXDE now, it's look ok I open 6-7 Youtube page in FF, Clementine, in ROSA media player 1080p video, etc. nothing happen it's running good, CPU during all these running process reach just %60 stable, maybe KDE Workspace cause that problem, and I like KDE, I don't want to change Desktop environment...
Comment 22 Serdar Ateş 2013-02-24 19:45:46 MSK
I want to give some information about my Laptop; no battery, no power supply, power cable directly connected to motherboard; because power supply broke down and I connect the power cable directly on board, maybe this cause some problems because some other distributions are shut down when they are reach high CPU usage but for example PC Linux OS or Mageia dialogue box appear and which says something going wrong, and immediately shut down, there is no chance to use them, but in the ROSA Fresh this is not happen, dialogue box say system going to shut down but nothing happen it's continue to run again and again, in the other hand Mandriva 2011 and ROSA Marathon works perfect without any problem, (but they little bit old) according to my observation after power supply broke down these problems (High CPU usage and temperature) emerged.
Comment 23 Serdar Ateş 2013-02-25 00:07:55 MSK
I solve the problem thank you for everything Alex, Alexander. I add the acpi=off end of the line which is in the grub screen, and now everything works perfect, I open 6-7 youtube page, update computer, Amarok, ROSA Player full hd video but CPU's sound like the sleeping, temperature good, everything ok now... See you, 

Best regards, Serdar Ateş...
Comment 24 Aleksandr Kazantcev 2013-02-25 00:29:22 MSK
Thanks for you. Added to ERRATA:

http://wiki.rosalab.ru/en/index.php/Errata_ROSA_Desktop_2012#High_CPU_usage_for_some_machines_in_KDE4
Comment 25 Serdar Ateş 2013-02-25 00:46:07 MSK
Glad to see that...