Bug 1654 - kdenlive fails with MLT SDL module error
: kdenlive fails with MLT SDL module error
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-12 22:50 MSK by Sylvainsjc
Modified: 2013-03-06 03:19 MSK (History)
3 users (show)

See Also:
RPM Package: kdenlive-0.8-3-rosa.lts2012.0.x86_64
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvainsjc 2013-02-12 22:50:50 MSK
Description of problem:

Can't start Kdenlive with Marathon X86_64. It fail at startup with this error :

    Fatal Error
    MLT's SDL module not found. Please check your MLT
    install. Kdenlive will not work until this issue is fixed.

Same behavior with another user
Same behavior with VirtualBox image of Marathon LTS


Version-Release number of selected component (if applicable):
[root@rosa2012lts ~]# rpm -qa kdenlive mlt lib64mlt* dvgrab lib64avc*
lib64mlt4-0.7.0-2-rosa.lts2012.0.x86_64
lib64avc1394_0-0.5.3-8-rosa.lts2012.0.x86_64
dvgrab-3.5-5-rosa.lts2012.0.x86_64
lib64mlt5-0.8.8-1-rosa.lts2012.0.x86_64
lib64mlt++3-0.8.8-1-rosa.lts2012.0.x86_64
mlt-0.8.8-1-rosa.lts2012.0.x86_64
kdenlive-0.8-3-rosa.lts2012.0.x86_64
Comment 1 Denis Silakov 2013-02-13 14:30:11 MSK
Please try the updated kdenlive:

http://abf.rosalinux.ru/downloads/rosa2012lts/container/944984/x86_64/main/release/

http://abf.rosalinux.ru/downloads/rosa2012lts/container/944983/i586/main/release/

The update solved the issue for me. If it works for you, too, I'll push the packages to QA procedure.
Comment 2 Sylvainsjc 2013-02-13 21:25:42 MSK
Yes it works on X86_64.

Great thanks ;)
Comment 3 Denis Silakov 2013-02-14 10:01:51 MSK
Advisory:

Updated kdenlive to 0.9.4 (backported from Desktop Fresh) to work correctly with modern MLT.

Build lists:
https://abf.rosalinux.ru/build_lists/944984
https://abf.rosalinux.ru/build_lists/944983
Comment 4 Vladimir Potapov 2013-02-14 10:47:02 MSK
I can't reproduce this error... old KDEnlive work correct on my marathon x64.
Comment 5 Denis Silakov 2013-02-14 10:48:30 MSK
I had the same situation and was able to reproduce the error only after installing kdenlive in clean VM...
Comment 6 Vladimir Potapov 2013-02-14 12:00:50 MSK
New version KDEnlive don't require RecordMyDesktop, but current package set up it. http://www.opennet.ru/opennews/art.shtml?num=35978
Comment 7 Denis Silakov 2013-02-14 12:09:10 MSK
Thanks for the note, I'll rebuild without recordmydesktop requirement...
Comment 9 Vladimir Potapov 2013-02-14 15:39:38 MSK
If I code the video to DVD, the resulting video without sound. (In fresh all ok)
Comment 10 Denis Silakov 2013-02-14 17:41:43 MSK
Did the previous kdenlive version work correctly in this situation?
Comment 11 Vladimir Potapov 2013-02-14 18:10:21 MSK
I reproduce the bug :-)
(urpme --auto-orphans)
I can't run old version kdenlive...
Comment 12 Vladimir Potapov 2013-02-14 18:39:14 MSK
I found it! KDEnlive work (sound-ok) only prevision version of MLT.
New KDEnlive with new MLT save vob-files without sound (save mp4 - ok, sound present)
Comment 13 Denis Silakov 2013-02-28 12:23:01 MSK
Unfortunately, we still can't find time to investigate the issue deeper. I would suggest to publish kdenlive in its current state (since it is definitely better than non-working kdenlive which is currently in repos) and file a separate bug about error with vob files
Comment 14 Vladimir Potapov 2013-02-28 16:05:20 MSK
kdenlive-0.9.4-3-rosa.lts2012.0
******************* Advisory ******************
Updated kdenlive to 0.9.4 (backported from Desktop Fresh) to work correctly with modern MLT.
***********************************************
QA Verified