Bug 1649 - freenx does not work or works incorrectly
: freenx does not work or works incorrectly
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-12 10:13 MSK by FirstLevel
Modified: 2013-03-29 15:08 MSK (History)
3 users (show)

See Also:
RPM Package: freenx-0.7.3-10-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-02-12 10:13:00 MSK
Description of problem:
I have installed freenx on ROSA 2012.1 Fresh. I have tried to connect from ROSA 2012 LTS by client remmina to ROSA 2012.1 Fresh and could not do it.
Preinstalled key is not accepted because I see the message that key or user is invalid.
Preinstalled key has size 672 bytes, but if I generate new key with nxkeygen I see that new key has size 668  bytes. If I import and use new key I could not log on again.
From ROSA 2012 LTS I could communicate with other freenx servers in my network.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Sergey Zhemoitel 2013-02-14 21:10:14 MSK
Необходимы ли еще какие-то дополнительные сведения по данной проблеме? 
Так как проблема актуальна и действует на всех машинах с установленной ROSA Fresh.
Comment 2 FirstLevel 2013-03-29 09:19:05 MSK
The problem is solved by user.
There is file  authorized_keys2 in folder /var/lib/nxserver/nxhome/.ssh/.
After renaming it to authorized_keys or making symling with name  authorized_keys all works well.
Please correct the package with this solution
Comment 3 Denis Silakov 2013-03-29 12:06:38 MSK
New version has been built - 0.7.3-11. Please try, I hope we've got completely rid of authorized_keys2 now in favor of authorized_keys.
Comment 4 Sergey Zhemoitel 2013-03-29 15:07:02 MSK
Если укажите ссылку откуда взять обновленный пакет, то можно будет проверить. 

Please, uri link from new package 


(In reply to comment #3)
> New version has been built - 0.7.3-11. Please try, I hope we've got
> completely rid of authorized_keys2 now in favor of authorized_keys.