Bug 1622 - recordmydesktop crop recording video
: recordmydesktop crop recording video
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-08 14:21 MSK by FirstLevel
Modified: 2013-02-28 14:49 MSK (History)
2 users (show)

See Also:
RPM Package: recordmydesktop-0.3.8.1-7-rosa2012.1.i586
ISO-related:
Bad POT generating:
Upstream: wontfix


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-02-08 14:21:41 MSK
Description of problem:
If I use qt-recordmydesktop with screen resolution 1680x1050 I see that recording video has resolution 1680x1040
I think that is because output of recordmydesktop is 

[bash@Home-PC ~]$ recordmydesktop
Initial recording window is set to:
X:0   Y:0    Width:1680    Height:1050
Adjusted recording window is set to:
X:0   Y:4    Width:1680    Height:1040
Your window manager appears to be KWin


Is there any possibility to make recording video with same resolution as my screen?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Silakov 2013-02-28 14:49:37 MSK
This is upstream restrictions that are unlikely to be fixed.

Let me quote appropriate Debian bug (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=549262):

"RecordMyDesktop enforces both coordinates of the offset of the recorded area
to be divisible by 2, and of its size to be divisible by 16. These restrictions are not documented. According to comments in the code, they come from MIT-SHM constraints."