Bug 1590 - colord start error
: colord start error
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-05 15:10 MSK by Vladimir Potapov
Modified: 2013-04-26 12:30 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2013-02-05 15:10:43 MSK
Description of problem:

[root@Fresh64 keleg]# systemctl status colord.service
colord.service - Manage, Install and Generate Color Profiles
          Loaded: loaded (/lib/systemd/system/colord.service; static)
          Active: failed (Result: exit-code) since Tue, 05 Feb 2013 20:04:05 +0900; 4min 42s ago
         Process: 6239 ExecStart=/usr/lib64/colord (code=exited, status=127)
          CGroup: name=systemd:/system/colord.service

Feb 05 20:04:05 Fresh64.rosa colord[6239]: /usr/lib64/colord: error while loading shared libraries: liblcms2.so.2: cannot open shared object file: No such file or directory
Feb 05 20:04:05 Fresh64.rosa systemd[1]: Failed to start Manage, Install and Generate Color Profiles.
Comment 1 Alexander Burmashev 2013-02-05 15:16:22 MSK
Do you have lib64lcms2_2 installed ?
Comment 2 Vladimir Potapov 2013-02-05 15:28:32 MSK
It's not installed.
After manual installation of this package everything is OK.
Comment 3 Alexander Burmashev 2013-02-05 16:09:44 MSK
that is rather strange, i see liblcms2.so.2()(64bit) in the package requires.
Comment 4 Vladimir Potapov 2013-02-05 16:35:43 MSK
urpme lib64lcms2_2
удаляется lib64lcms2_2-2.4-1-rosa2012.1.x86_64
Подготовка...                    ###################################################
удаляется пакет lib64lcms2_2-2.4-1.x86_64
writing /var/lib/rpm/installed-through-deps.list
Comment 5 Denis Silakov 2013-02-12 11:16:30 MSK
I think the reason is that our LibreOffice provides liblcms2.so.2. So it's libreoffice that should be fixed.
Comment 6 Denis Silakov 2013-04-22 15:30:04 MSD
Hm, even if we fix libreoffice not to provide liblcms2.so.2 (and this is actually fixed in git), we still have old libreoffice in main/release that provides it. So I think it's better add explicit require on liblcms2_2 package (lib64lcms2_2 in 64bit system)

Advisory:

colord - added explicit require on liblcms2 package to avoid mess with libreoffice

Build lists:
https://abf.rosalinux.ru/build_lists/1073969
https://abf.rosalinux.ru/build_lists/1073970
Comment 7 Vladimir Potapov 2013-04-25 15:20:32 MSD
colord-0.1.23-3-rosa2012.1
******************** Advisory ********************
colord - added explicit require on liblcms2 package to avoid mess with libreoffice
***************************************************
QA Verified