Bug 1586 - [UPDATE REQUEST]: rosapanel-1.6.0
: [UPDATE REQUEST]: rosapanel-1.6.0
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-05 12:28 MSK by Dmitry
Modified: 2013-02-14 15:45 MSK (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
Example (45.06 KB, image/png)
2013-02-13 11:30 MSK, Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2013-02-05 12:28:05 MSK
Please, update RocketBar to 1.6.0 version.
Comment 1 Dmitry 2013-02-05 12:31:25 MSK
Advisory:
- Default configuration of panel has been changed
- New applet "Expo" (effect Desktop Grid) has been added

Build lists:
- https://abf.rosalinux.ru/build_lists/941614
- https://abf.rosalinux.ru/build_lists/941615
Comment 2 Dmitry 2013-02-05 12:34:07 MSK
Extended testing is required.
Comment 3 Vladimir Potapov 2013-02-07 12:33:29 MSK
(In reply to comment #1)
> Advisory:
> - Default configuration of panel has been changed
> - New applet "Expo" (effect Desktop Grid) has been added
Please, describe the changes in more detail. What has changed?
Comment 4 Dmitry 2013-02-07 15:32:45 MSK
New applet "Expo" has been added. If user clicks on it, the kwin effect "Desktop grid" will be activated. This applet is placed in a right part of panel. You should add new RocketBar to desktop to see new applet or add it manually to panel from widget explorer.
Some icons were moved to another place on panel for its default configuration. Icons for systemsettings has been moved to right part of panel and one of stackfolders has been removed.
Comment 5 Vladimir Potapov 2013-02-07 16:52:33 MSK
The package route to the extended testing.
Comment 6 Dmitry 2013-02-07 16:56:06 MSK
Yes. This is due to removing a lot of unused code. But this is invisible to users.
Comment 7 Postnikov Dmitry 2013-02-12 18:22:13 MSK
(In reply to comment #4)
> New applet "Expo" has been added. If user clicks on it, the kwin effect
> "Desktop grid" will be activated. This applet is placed in a right part of
> panel. You should add new RocketBar to desktop to see new applet or add it
> manually to panel from widget explorer.
> Some icons were moved to another place on panel for its default
> configuration. Icons for systemsettings has been moved to right part of
> panel and one of stackfolders has been removed.

Where can i find the widget "Expo"? I have already searched the panel and widgets, switch panels, etc. No nowhere "Expo". Hmmm... i can't find it.
Please attach screenshot with "Expo" or send me via email.
Comment 8 Dmitry 2013-02-13 11:30:07 MSK
Created attachment 1190 [details]
Example

I have done next steps:
1) installed rosapanel-1.6 rpm package
2) exited KDE session and started new one (relogined), this is required to restart plasma-desktop application
3) removed old panel
4) added new RocketBar
Comment 9 Dmitry 2013-02-13 11:31:19 MSK
New:
1) systemsettings at right part of panel
2) new expo applet (icon)
3) removed one of stackfolders
Comment 10 Postnikov Dmitry 2013-02-13 13:07:33 MSK
(In reply to comment #8)
> Created attachment 1190 [details]
> Example
> 
> I have done next steps:
> 1) installed rosapanel-1.6 rpm package
> 2) exited KDE session and started new one (relogined), this is required to
> restart plasma-desktop application
> 3) removed old panel
> 4) added new RocketBar

Aaa... I understood. Just changed the name "Switch desktops" at the "Expo"? But after all, and had this applet. What's the difference between "Switch desktops" from "Expo"? Visually - one and the same.

Do can my small opinion? It seems to me, it was necessary to do OPPOSITE. All icons in left part of panel, and all of system icons in right to leave. And it would be very nice. To left part of panel not "dump" of icons, "SF" and "Settings" could be divided. Make a new separator. 
And now, in right side of different icons in height, size, style. All in a heap. For me - even worse was look. (To be honest). :)
Comment 11 Postnikov Dmitry 2013-02-13 14:32:18 MSK
Plasma crash... when i do settings of "System tray" (WITH mdkapplet)
http://cdn.2safe.com/234191033048/screen-rp16.mov

Plasma crash... when i do settings of "System tray" (WITHOUT mdkapplet)
http://cdn.2safe.com/272728033560/screen-rp18.mov
Comment 12 Vladimir Potapov 2013-02-13 15:52:59 MSK
(In reply to comment #11)
> Plasma crash... when i do settings of "System tray" (WITH mdkapplet)
> http://cdn.2safe.com/234191033048/screen-rp16.mov
> 
> Plasma crash... when i do settings of "System tray" (WITHOUT mdkapplet)
> http://cdn.2safe.com/272728033560/screen-rp18.mov

I can't reproduce this bug (both i586 and x64, intel video)
Comment 13 Postnikov Dmitry 2013-02-13 16:00:46 MSK
(In reply to comment #12)
> (In reply to comment #11)
> > Plasma crash... when i do settings of "System tray" (WITH mdkapplet)
> > http://cdn.2safe.com/234191033048/screen-rp16.mov
> > 
> > Plasma crash... when i do settings of "System tray" (WITHOUT mdkapplet)
> > http://cdn.2safe.com/272728033560/screen-rp18.mov
> 
> I can't reproduce this bug (both i586 and x64, intel video)

I have ATI card and driver radeon. Engine Xreder.
Comment 14 Dmitry 2013-02-13 16:15:21 MSK
> Do can my small opinion? It seems to me, it was necessary to do OPPOSITE. All icons in left part of panel, and all of system icons in right to leave. And it would be very nice. To left part of panel not "dump" of icons, "SF" and "Settings" could be divided. Make a new separator. 
> And now, in right side of different icons in height, size, style. All in a heap. For me - even worse was look. (To be honest). :)

All UI related questions please send to Denis. There is concept proposed by designers.

In Fresh and Marathon System tray is KDE default system tray, and it has several problems with X11 tasks. These problems are difficult to reproduce. Could you reproduce problem in Marathon?
Comment 15 Postnikov Dmitry 2013-02-13 16:51:40 MSK
(In reply to comment #14)

> In Fresh and Marathon System tray is KDE default system tray, and it has
> several problems with X11 tasks. These problems are difficult to reproduce.
> Could you reproduce problem in Marathon?


For Marathon is new package? Where? Then i will try.
Comment 16 Dmitry 2013-02-13 17:35:31 MSK
System tray is unchanged. For Marathon there is no new RocketBar.
Comment 17 Postnikov Dmitry 2013-02-13 17:38:32 MSK
(In reply to comment #16)
> System tray is unchanged. For Marathon there is no new RocketBar.

I then on old panel in Marathon to try reproduce bug?
Comment 18 Dmitry 2013-02-13 17:39:37 MSK
Yes, you can.
Comment 19 Postnikov Dmitry 2013-02-13 19:26:55 MSK
In Marathon RP1 and Marathon RP1 + update = nothing is shown. All normal.
http://cdn.2safe.com/301407033047/screen-mar1.mov

In Fresh without update (with old panel) is a Plasma crash...
http://cdn.2safe.com/341048033559/screen-fresh-old1.mov
Comment 20 Dmitry 2013-02-13 21:06:31 MSK
If I understand right, the behaviour is untouched by new RocketBar? So, it is an upstream bug.
Comment 21 Postnikov Dmitry 2013-02-14 00:20:54 MSK
(In reply to comment #20)
> If I understand right, the behaviour is untouched by new RocketBar? So, it
> is an upstream bug.

Yes, behaviour untouched by new RB.
Comment 22 Vladimir Potapov 2013-02-14 06:02:52 MSK
Please, file a new bug for this error (I can't reproduce it).
Comment 23 Vladimir Potapov 2013-02-14 06:04:22 MSK
rosapanel-1.6.0-1-rosa2012.1
*************** Advisory *****************
- Default configuration of panel has been changed
- New applet "Expo" (effect Desktop Grid) has been added
******************************************
QA Verified
Comment 24 Postnikov Dmitry 2013-02-14 13:16:17 MSK
(In reply to comment #11)
> Plasma crash... when i do settings of "System tray" (WITH mdkapplet)
> http://cdn.2safe.com/234191033048/screen-rp16.mov
> 
> Plasma crash... when i do settings of "System tray" (WITHOUT mdkapplet)
> http://cdn.2safe.com/272728033560/screen-rp18.mov

1. Still on the same computer also crash Plasma.
2. On other computer when you add a new panel, panel is added about 1 minute. In this case, system freeze without opportunity to work.
3. On another computer if you drag panel to right or to left - crash Plasma.
4. On another computer StackFolder open immediately on all desktops.
5. If panel move to right or to left. Run 5-6 applications, in "Tasks" can be seen only 4 small icons applications, and rest are not visible.
6. To call the "Battery indicator" can be unsuccessfully to click on it with mouse, and only when you click on icon it will start.
7. Widget "yaWp" not stability works.
8. Widgets "yaWp" and "Weather" when ignition is turned OpenGL is not possible to turn on and turn off in "System tray".
9. With increase of panel, icons with left side of increase and overlay icons "System tray".
Comment 25 Denis Koryavov 2013-02-14 15:41:04 MSK
Some bugs related with RocketBar, some bugs not. Please create new bugs for RocketBar if they related with it (as far as I can see these bugs are not related with this update).
Comment 26 Vladimir Potapov 2013-02-14 15:45:28 MSK
As it turns out, there is one regression associated with the collapse of the plasma. But I do not see anything critical, regression on some configurations and under certain conditions.