Bug 156 - release notes in installer don`t present
: release notes in installer don`t present
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: Konstantin Vlasov
: ROSA Linux Bugs
:
Depends on: 507
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 07:08 MSD by Vladimir Potapov
Modified: 2012-08-16 18:42 MSD (History)
4 users (show)

See Also:
RPM Package: drakxtools, mandriva-release
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
screenshot (224.97 KB, image/png)
2012-07-03 16:35 MSD, Vladimir Potapov
Details
Error text encoding (154.77 KB, image/png)
2012-07-09 18:22 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2012-04-30 07:08:41 MSD
Description of problem:
In installer I press button "release notes", opening blank window, no text!

Version-Release number of selected component (if applicable):
ROSA 2012EE rc, x64
Comment 1 Vladimir Potapov 2012-06-14 13:28:44 MSD
In i586 LTS release, release notes in english (I select russian locale)
Comment 2 Aleksandr Kazantcev 2012-06-14 13:30:00 MSD
It will be in English - in draklive-install not possibility use different notes.
Comment 3 Vladimir Potapov 2012-06-14 13:58:16 MSD
It`s a ugly :-(
Comment 4 Vladimir Potapov 2012-06-14 14:05:40 MSD
May be delete this buggy feature from installer?
In firefox`s first start a user show full actually information in wiki.
Comment 5 Aleksandr Kazantcev 2012-06-14 14:07:09 MSD
99% user not find it in installer.
Comment 6 Vladimir Potapov 2012-06-14 14:08:04 MSD
Another argument to remove them from there.
Comment 7 Denis Koryavov 2012-06-14 17:04:13 MSD
> Another argument to remove them from there.

Well, it is a interesting idea. We can discuss it. :)
Comment 8 Denis Silakov 2012-06-27 11:35:40 MSD
Is it really hard to display release notes in proper language? It seems we already do this for license agreement.
Comment 9 Konstantin Vlasov 2012-06-29 15:48:08 MSD
Since decision about removing the button is not yet taken, in the mean time I fixed the bug and added support for displaying Release Notes in Russian (if Russian locale is selected) and English language (otherwise). Two packages are involved:

drakxtools (for code displaying the correct contents):
https://abf.rosalinux.ru/build_lists/620087
https://abf.rosalinux.ru/build_lists/620086

mandriva-release (for release-notes files themselves):
https://abf.rosalinux.ru/build_lists/620088
https://abf.rosalinux.ru/build_lists/620089

Advisory: Added displaying Release Notes in Russian.
Comment 10 Vladimir Potapov 2012-07-03 16:35:34 MSD
Created attachment 322 [details]
screenshot
Comment 11 Vladimir Potapov 2012-07-03 16:46:01 MSD
1) Notes on the package is not localized. If possible, can it?
2) The text of the release notes there are many inaccuracies. I corrected them in the wiki version. http://wiki.rosalab.ru/ru/index.php/%D0%9F%D1%80%D0%B8%D0%BC%D0%B5%D1%87%D0%B0%D0%BD%D0%B8%D1%8F_%D0%BA_%D0%B2%D1%8B%D0%BF%D1%83%D1%81%D0%BA%D1%83_(release_notes)_ROSA_Marathon_2012
Comment 12 Konstantin Vlasov 2012-07-03 17:00:56 MSD
(In reply to comment #11)
> 1) Notes on the package is not localized. If possible, can it?

Unfortunately I don't know how mechanism for displaying these notes works. According to the screenshot, the notes are taken from the file README.urpmi, but I don't know whether it's possible to create a Russian duplicate of it so that the updater took its contents if the current locale is Russian. However, I can append Russian translation into the same file so that it would display both English AND Russian notes together, is that acceptable? If yes, which order is preferrable: English-Russian or Russian-English?

> 2) The text of the release notes there are many inaccuracies. I corrected
> them in the wiki version.
> http://wiki.rosalab.ru/ru/index.php/
> %D0%9F%D1%80%D0%B8%D0%BC%D0%B5%D1%87%D0%B0%D0%BD%D0%B8%D1%8F_%D0%BA_%D0%B2%D1
> %8B%D0%BF%D1%83%D1%81%D0%BA%D1%83_(release_notes)_ROSA_Marathon_2012

OK, I will update the release notes files according to your changes.
Comment 13 Vladimir Potapov 2012-07-04 12:42:47 MSD
(In reply to comment #12)

> However, I can append Russian translation into the same file so that it
> would display both English AND Russian notes together, is that acceptable?
> If yes, which order is preferrable: English-Russian or Russian-English?
Well, English-Russian version will be enough.
Comment 14 Konstantin Vlasov 2012-07-04 14:00:01 MSD
OK, fixes are pushed and rebuilt. Build-lists are:

drakxtools (unchanged):
https://abf.rosalinux.ru/build_lists/620087
https://abf.rosalinux.ru/build_lists/620086

mandriva-release:
https://abf.rosalinux.ru/build_lists/620741
https://abf.rosalinux.ru/build_lists/620742

Advisory: Added displaying Release Notes in Russian.
Comment 15 Vladimir Potapov 2012-07-09 17:13:07 MSD
How can I test the installation? I can not install draklive-installer...
Comment 16 Konstantin Vlasov 2012-07-09 17:44:48 MSD
(In reply to comment #15)
> How can I test the installation? I can not install draklive-installer...

I don't see why you cannot install draklive-install, it's a usual package like any other, it just comes from a different project and therefore is not present in my builds. But in any case, you don't need to install it, Release Notes are shown not by draklive-install but by finish-install which is launched at the very first stage (yes, its name might be a little misleading in this respect).
Comment 17 Vladimir Potapov 2012-07-09 18:22:46 MSD
Created attachment 362 [details]
Error text encoding
Comment 18 Konstantin Vlasov 2012-07-09 19:31:22 MSD
(In reply to comment #17)
> Error text encoding

There is a problem in rpmdrake, it expects the ANSI encoding and fails to display UTF-8 contents. I can fix this but my primary concern is, whether it would break displaying information for other packages. If until now all such notes were English-only then such change will go without any problem, but if there were notes containing characters outside of lower ASCII part they all will become invalid.

Unfortunately, the simple solution of translating the problematic file from UTF-8 into ANSI will not help, because rpmdrake (it seems) uses the current system's language as ANSI codepage, and therefore if the current interface is English all Russian characters will become unreadable (they will be displayed using wrong codepage).

Any ideas what we should do in this situation?
Comment 19 Aleksandr Kazantcev 2012-07-09 19:33:54 MSD
Some simple solution - drop release notes button/links - users needing it will open wiki page in first Firefox running.
Comment 20 Denis Silakov 2012-07-10 00:11:15 MSD
If the encoding bug affects rpmdrake only (and not draklive-install), let's create a separate bug for it (not to create a mess here).
Comment 21 Vladimir Potapov 2012-07-10 04:52:02 MSD
The easiest way to remove the Russian double of rpm notes :-(
But the mechanism of the show national symbols have to do normal.
Comment 22 Konstantin Vlasov 2012-07-10 17:24:29 MSD
(In reply to comment #20)
> If the encoding bug affects rpmdrake only (and not draklive-install), let's
> create a separate bug for it (not to create a mess here).

Agree, but first it had to be decided whether we considered it a bug at all.


(In reply to comment #21)
> The easiest way to remove the Russian double of rpm notes :-(
> But the mechanism of the show national symbols have to do normal.

I investigated the matter and found that in our repositories there are just 3 readme files (used by rpmdrake) containing non-ANSI characters, and all these files are already UTF-8. So I suppose converting rpmdrake "Upgrade Information" dialog into UTF-8 is the right thing to do. I'll create a separate bug for it and prepare the fix.
Comment 23 Vladimir Potapov 2012-07-11 15:38:37 MSD
drakxtools-13.61-14-rosa.lts2012.0
mandriva-release-common-2012.0-8-rosa.lts2012.0
***************** Advisory **********************
+ Fix bug with displaying Release Notes in Russian 
*************************************************
QA Verified
Comment 24 Alexander Burmashev 2012-07-24 11:09:19 MSD
Drakxtools buildlists seem to be unaccessible - rebuild please.