Bug 1553 - YUM doesn't work in ROSA 2012.1 Fresh
: YUM doesn't work in ROSA 2012.1 Fresh
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-31 14:09 MSK by FirstLevel
Modified: 2013-01-31 14:24 MSK (History)
2 users (show)

See Also:
RPM Package: yum-3.2.29-1-rosa2012.1.noarch
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-01-31 14:09:58 MSK
Description of problem:
I have installed yum in ROSA 2012.1 Fresh but it doesn't.
For example, such command causes an error:
# yum search mesa
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 262, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 88, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 228, in getOptionsConfig
    self.conf
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 863, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 295, in _getConfig
    startupconf = config.readStartupConfig(fn, root)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 872, in readStartupConfig
    startupconf.releasever = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1002, in _getsysver
    ts = rpmUtils.transaction.initReadOnlyTransaction(root=installroot)
  File "/usr/lib/python2.7/site-packages/rpmUtils/transaction.py", line 180, in initReadOnlyTransaction
    read_ts.pushVSFlags((rpm._RPMVSF_NOSIGNATURES|rpm._RPMVSF_NODIGESTS))
AttributeError: 'module' object has no attribute '_RPMVSF_NOSIGNATURES'



What should I do to get working version of yum?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Alexander Burmashev 2013-01-31 14:24:44 MSK
yum is not supported by ROSA currently. Parts of yum-utils are used in some of our projects, but we do not ship it in any working state. That is one the reasons it is in contrib.