Bug 1552 - Could not change default record in grub
: Could not change default record in grub
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-31 09:37 MSK by FirstLevel
Modified: 2014-04-29 15:42 MSD (History)
4 users (show)

See Also:
RPM Package: kcm-grub2-0.5.8-2-rosa2012.1.i586
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
alex.burmashev: published+


Attachments
GRUB2 - default.png (93.28 KB, image/png)
2013-01-31 09:37 MSK, FirstLevel
Details
GRUB2 - default 2.png (101.54 KB, image/png)
2013-01-31 09:38 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-01-31 09:37:56 MSK
Created attachment 1116 [details]
GRUB2 - default.png

Description of problem:
I have installed ROSA 2012.1 Fresh with several kernels. 
I open kcm-grub and try to change default record for booting by modifying field "Запись по умолчанию".
But I see that always is booting first record from the list of kernels.
For example, I have such boot list:
1. ROSA Desktop.Fresh 2012
2. Advanced options for ROSA Desktop.Fresh 2012
2.1. ROSA Desktop.Fresh 2012, with Linux 3.6.10-nrj-desktop-pae-1rosa
2.2. ROSA Desktop.Fresh 2012, with Linux 3.6.10-nrj-desktop-1rosa
2.3. ROSA Desktop.Fresh 2012, with Linux 3.6.10-desktop-1rosa

If I choose "ROSA Desktop.Fresh 2012, with Linux 3.6.10-desktop-1rosa" in kcm-grub for default record (see attach GRUB2 - default.png) my computer boot with kernel "ROSA Desktop.Fresh 2012, with Linux 3.6.10-nrj-desktop-pae-1rosa". And after openning kcm-grub I see that default boot record is "ROSA Desktop.Fresh 2012, with Linux 3.6.10-desktop-1rosa". See attach "GRUB2 - default 2.png"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-01-31 09:38:08 MSK
Created attachment 1117 [details]
GRUB2 - default 2.png
Comment 2 Vladimir Testov 2013-03-05 13:01:15 MSK
In progress. I'm writing patch to fix this problem. (Problem exists due to changes in GRUB2 ver 2.00, while kcm-grub2 was written for ver 1.99). The patch will be sent to the upstream.
Comment 3 Vladimir Testov 2013-03-06 15:17:21 MSK
Advisory:
Fixed changing of default entry via kcm-grub2.

Buildlists:
https://abf.rosalinux.ru/build_lists/1014278
https://abf.rosalinux.ru/build_lists/1014277
Comment 4 Alexander Petryakov 2013-03-07 01:40:27 MSK
kcm-grub2-0.5.8-4
************** Advisory **************
Fixed changing of default entry via kcm-grub2.
**************************************
QA Verified