Bug 1548 - [UPDATE REQUEST] x11-driver-video-ati-7.1.0
: [UPDATE REQUEST] x11-driver-video-ati-7.1.0
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 21:42 MSK by Aleksandr Kazantcev
Modified: 2013-02-12 12:05 MSK (History)
4 users (show)

See Also:
RPM Package: x11-driver-video-ati-7.1.0
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2013-01-30 21:42:59 MSK
New version of free AMD/ATI driver
Comment 1 Aleksandr Kazantcev 2013-01-30 21:59:06 MSK
https://abf.rosalinux.ru/build_lists/938026
https://abf.rosalinux.ru/build_lists/938027

Advisory: This new version of free AMD/ATI videocard driver fix some bugs and provide improverments:
- bump verion post release
- radeon: add new SI pci id
- radeon: fix ring count in R300PrepareTexturedVideo
- exa/Xv: fix coordinate limits on AVIVO IGPs
- radeon/r200: program RE_WIDTH_HEIGHT properly
- radeon: fix damage reporting for slave pixmaps
- video: add option to include disabled CRTCs in best CRTC search
- DRI2: change signature of radeon_dri2_drawable_crtc
- DRI2: limit the swap rate when CRTC is in DPMS-off state
- radeon: avoid segfault when pixmap exceed GPU capabilities
- radeon: avoid copying over itself ddx fb
- radeon: bump version for release
- Remove dead code flagged by gcc -Wunused-but-set-variable.
- Remove unused local variable 'path'.
- Remove local variables total_size_bytes.
- Remove dead option definitions.
- glamor: Release the drawable after passing to glamor_push_pixels
- glamor: Enable full 2D acceleration for SI as well.
- Drop support for X servers older than 1.7.
- DRI2: Properly use buffer depth passed in by client.
- DRI2/r[345]xx: 16 bit depth buffers use square micro tiling.
- Make CRTC shadow pixmaps usable by glamor.
- Make radeon_glamor_create_textured_pixmap() return TRUE without USE_GLAMOR.
Comment 2 Vladimir Potapov 2013-02-04 17:37:38 MSK
Please create a container. QA don't have rights to create it.
Comment 3 Denis Silakov 2013-02-05 13:02:14 MSK
Containers created.
Comment 4 Vladimir Potapov 2013-02-07 11:27:47 MSK
The update is forwarded for additional testing
Comment 5 Postnikov Dmitry 2013-02-12 01:10:37 MSK
Tested on 3 computers with ATI card, NO regressions. One moment, never corrected bug with displaying fonts in LO.
Comment 6 Aleksandr Kazantcev 2013-02-12 07:35:33 MSK
Bug with LO is upstream bug and it's related to other components, like pixman, cairo, etc. We has only workaround. 

But we will not fix it via package, because we setup all x11-driver-video package and this workaround broke other videocards.

In future we need rewrite video subsystem for possibility adding some conf related current system configuration.
Comment 7 Vladimir Potapov 2013-02-12 08:42:56 MSK
x11-driver-video-ati-7.1.0-1-rosa2012.1
**************** Advisory *******************
This new version of free AMD/ATI videocard driver fix some bugs and provide improverments
*********************************************
QA Verfified