Bug 1543 - Kernel was updated to 3.6.11 [UPDATE REQUEST]
: Kernel was updated to 3.6.11 [UPDATE REQUEST]
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 14:36 MSK by Alexander Burmashev
Modified: 2013-02-12 11:18 MSK (History)
2 users (show)

See Also:
RPM Package: kernel-3.6.11
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-


Attachments
Report (rus) (1.73 MB, application/vnd.oasis.opendocument.text)
2013-02-11 14:48 MSK, Vladimir Potapov
Details
grub config (21.22 KB, application/octet-stream)
2013-02-11 18:30 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Burmashev 2013-01-30 14:36:05 MSK
kernel was updated
Comment 1 Alexander Burmashev 2013-01-30 14:39:11 MSK
Advisory:
Kernel was updated to 3.6.11 version.
Among all the patches there are i915.CADLinopregion.patch that fixes backlight/FN keys for some notebook devices and 
08-18-brcmsmac-Add-support-for-writing-debug-messages-to-the-trace-buffer.patch
that fixed brcmsmac driver behaviour http://bugs.rosalinux.ru/show_bug.cgi?id=1397

buildlists:

i586 
https://abf.rosalinux.ru/build_lists/898418
https://abf.rosalinux.ru/build_lists/937822


x86_64
https://abf.rosalinux.ru/build_lists/898418
https://abf.rosalinux.ru/build_lists/937823
Comment 2 Vladimir Potapov 2013-01-31 17:39:17 MSK
(In reply to comment #1)

> 
> i586 
> https://abf.rosalinux.ru/build_lists/898418

> x86_64
> https://abf.rosalinux.ru/build_lists/898418

One number for two?
Comment 3 Alexander Burmashev 2013-02-05 11:18:26 MSK
Advisory:
Kernel was updated to 3.6.11 version.
Among all the patches there are i915.CADLinopregion.patch that fixes backlight/FN keys for some notebook devices and 
08-18-brcmsmac-Add-support-for-writing-debug-messages-to-the-trace-buffer.patch
that fixed brcmsmac driver behaviour http://bugs.rosalinux.ru/show_bug.cgi?id=1397

buildlists:

i586 
https://abf.rosalinux.ru/build_lists/898418
https://abf.rosalinux.ru/build_lists/937822


x86_64
https://abf.rosalinux.ru/build_lists/898419
https://abf.rosalinux.ru/build_lists/937823


P.S. fixed the path
Comment 4 Vladimir Potapov 2013-02-05 12:40:43 MSK
(In reply to comment #3)
> Advisory:
> Kernel was updated to 3.6.11 version.
> Among all the patches there are i915.CADLinopregion.patch that fixes
> backlight/FN keys for some notebook devices and 
> 08-18-brcmsmac-Add-support-for-writing-debug-messages-to-the-trace-buffer.
> patch
> that fixed brcmsmac driver behaviour
> http://bugs.rosalinux.ru/show_bug.cgi?id=1397
> 
> i586 
> https://abf.rosalinux.ru/build_lists/898418

> x86_64
> https://abf.rosalinux.ru/build_lists/898419
These containers are empty...
Comment 5 Alexander Burmashev 2013-02-06 12:54:34 MSK
One more time :)
Advisory:
Kernel was updated to 3.6.11 version.
Among all the patches there are i915.CADLinopregion.patch that fixes backlight/FN keys for some notebook devices and 
08-18-brcmsmac-Add-support-for-writing-debug-messages-to-the-trace-buffer.patch
that fixed brcmsmac driver behaviour http://bugs.rosalinux.ru/show_bug.cgi?id=1397

buildlists:

i586 
https://abf.rosalinux.ru/build_lists/941636
https://abf.rosalinux.ru/build_lists/937822


x86_64
https://abf.rosalinux.ru/build_lists/941637
https://abf.rosalinux.ru/build_lists/937823
Comment 6 Vladimir Potapov 2013-02-07 10:39:06 MSK
I updated the two systems, they are on the same disk. 64 refreshed normal, and in the i586 a new kernel is not set by default.
Was it tested a case in which an updated distribution is not the first in the list?
Comment 7 Vladimir Potapov 2013-02-07 11:27:27 MSK
The update is forwarded for additional testing
Comment 8 Vladimir Potapov 2013-02-11 14:48:11 MSK
Created attachment 1181 [details]
Report (rus)

This update rejected
The main reasons of the decision:
1) After the updates it is impossible to boot the system with the old kernel.
2) The error appeared when working with the printer Samsung SCX-3407
3) ACPI Errors in log
Comment 9 Alexander Burmashev 2013-02-11 16:39:48 MSK
I was not  able to reproduce the problem with not bootable old kernel.
Pleae attach the boot/grub2/grub.cfg file.
Comment 10 Vladimir Potapov 2013-02-11 18:30:04 MSK
Created attachment 1182 [details]
grub config
Comment 11 Alexander Burmashev 2013-02-11 18:39:33 MSK
Ok, seems that config is ok.
How does the problem with the unbootable kernel show itself ?
Comment 12 Postnikov Dmitry 2013-02-11 18:47:30 MSK
(In reply to comment #11)
> Ok, seems that config is ok.
> How does the problem with the unbootable kernel show itself ?

Not show old kernel in Grub2 menu. Only new kernel.
Comment 13 Alexander Burmashev 2013-02-11 18:48:15 MSK
it is shown in additional parameters...
Comment 14 Vladimir Potapov 2013-02-11 18:49:31 MSK
I not confirm the bug with old kernel from Dmitry report.
But on my x86 system the kernel not setup to grub.
Comment 15 Alexander Burmashev 2013-02-11 18:50:28 MSK
Is it shown in additional parameters ? According to the attached config it should be there.
Comment 16 Postnikov Dmitry 2013-02-11 18:51:20 MSK
(In reply to comment #13)
> it is shown in additional parameters...

hmm... but no links in Menu for additional parameters.
Comment 17 Postnikov Dmitry 2013-02-11 19:12:57 MSK
Pardon! But... i try in my second laptop, and only after second reboot show additional parameter with old kernel. And first computer without old kernel.
Comment 18 Postnikov Dmitry 2013-02-11 19:41:21 MSK
Now, it was discovered. Some "ping" site not show. Tcpdump not show when running ping.
kernel-nrg-desktop-3.6.11
avahi-0.6.31-6
Comment 19 Alexander Burmashev 2013-02-11 19:45:56 MSK
I am sure that avahi problems and site discovery problems are not kernel related
Comment 20 Postnikov Dmitry 2013-02-11 19:55:00 MSK
(In reply to comment #19)
> I am sure that avahi problems and site discovery problems are not kernel
> related

I remember there was such a problem before. Bugs 46, 45
Comment 21 Alexander Burmashev 2013-02-11 19:55:35 MSK
and all that bugs are not kernel related
Comment 22 Postnikov Dmitry 2013-02-11 19:57:36 MSK
...and bug 47
Comment 23 Postnikov Dmitry 2013-02-11 19:58:27 MSK
(In reply to comment #21)
> and all that bugs are not kernel related

hm... but it appeared after upgrading the kernel.
Comment 24 Alexander Burmashev 2013-02-11 20:00:21 MSK
47 is also not kernel related.
The cause of this bug is avahi.
Comment 25 Alexander Burmashev 2013-02-11 20:35:47 MSK
BTW, to fix avahi issue apply the updated package from the corresponding update request.
Comment 26 Postnikov Dmitry 2013-02-11 20:44:57 MSK
(In reply to comment #25)
> BTW, to fix avahi issue apply the updated package from the corresponding
> update request.

Yes, i read. We will testing now new avahi...
Comment 27 Postnikov Dmitry 2013-02-12 11:18:33 MSK
With new avahi-0.6.31-7 and this kernel = all work OK.
Comment 28 Postnikov Dmitry 2013-02-12 11:18:37 MSK
With new avahi-0.6.31-7 and this kernel = all work OK.