Bug 1520 - [UPDATE REQUEST] 4.1.1 to ktorrent-4.3.1
: [UPDATE REQUEST] 4.1.1 to ktorrent-4.3.1
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-28 23:04 MSK by symbianflo
Modified: 2013-01-31 15:34 MSK (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
dmitry.romashkin: secteam_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description symbianflo 2013-01-28 23:04:56 MSK
Description of problem:
[UPDATE REQUEST] 4.1.1 to ktorrent-4.3.1

Bugfix update of libktorrent-1.3.1/ktorrent-4.3.1 ( first bugfix release from the 4.3 series of ktorrent)
More: 
http://ktorrent.org/?q=node/59

NB:
For testing the new ktorrent-4.3.1  build against the new libktorrent-1.3.1
I've prepare on my_personal media all the packages , since ktorrent can not be build  without having first libktorrent:
http://abf.rosalinux.ru/downloads/symbianflo_personal/repository/
Comment 1 symbianflo 2013-01-28 23:06:25 MSK
Advisory: New bugfix release

[UPDATE REQUEST] ktorrent-4.1.1 to ktorrent-4.3.1

Rosa2012lts:
https://abf.rosalinux.ru/build_lists/915062
https://abf.rosalinux.ru/build_lists/915063
Comment 2 Vladimir Potapov 2013-01-29 14:40:58 MSK
For this application program please, add to advisory a detailed list of changes.
All positions of changelist must be reproducible in the rosa linux.
All of the list of changes are checked at QA.

KTorrent is a program the default set for distribution with long-term support. For such programs updated subject to additional terms and conditions - sorry, but it is necessary.

Vladimir Potapov
QA Team
Comment 3 Vladimir Potapov 2013-01-29 16:40:36 MSK
http://bugs.rosalinux.ru/show_bug.cgi?id=84
Fixed?
Comment 4 symbianflo 2013-01-29 21:20:46 MSK
(In reply to comment #3)
> http://bugs.rosalinux.ru/show_bug.cgi?id=84
> Fixed?

I've tried to reproduce this bug but I can't  DHT works  perfect and enable by default to me ..I'm sorry.
Comment 5 symbianflo 2013-01-29 21:25:34 MSK
(In reply to comment #2)
> For this application program please, add to advisory a detailed list of
> changes.
> All positions of changelist must be reproducible in the rosa linux.
> All of the list of changes are checked at QA.
> 
> KTorrent is a program the default set for distribution with long-term
> support. For such programs updated subject to additional terms and
> conditions - sorry, but it is necessary.
> 
> Vladimir Potapov
> QA Team

I understand  and agree with you 
So here you are  everithing that I'm able to compare: 

FIXED BUGS FROM 4.1.1 ( DEFAULT IN lts)
- Fix new custom groups not appearing in add to group submenu (307230)
- Fix crash when right clicking on some locations in the GroupView due to 0 pointer (307160)
- Force KDirWatch to use polling when watching NFS filesystems (301381)
- Fix crash due to bus error in ip filter plugin (307854)
- First check for missing files then for unmounted storage (308638)
- Use extended selection mode in syndication plugin so ctrl key works as expected (308672)
- Fix crash in GroupViewModel when dragging torrents over groups (308733)
- Sort by total leechers and seeders, if connected seeders and leechers is equal (311470)
- Add support for magnet links in the syndication plugin
- Add search line to download order dialog
- Add move top and bottom option to download order dialog (295341)
- Make sure that move up and move down in the download order dialog work with multiple items (295341)
- Also update file priorities when normal priority file completes downloading in download order plugin (296576)
- Add automatic sorting options to download order plugin (name, seasons and episodes, album track number) (295341)
- Make float comparison factor smaller in ViewModel when checking if share ratio has changed (297931)
- Show torrent count next to group in GroupView (176173)
- Add new GroupSwitcher widget
- Add edit group policy button to GroupSwitcher
- Remove html tooltips from ui files
- Tracker grouping script now uses the domain name of the tracker (227430)
- Catch SIGINT and SIGTERM and do a clean shutdown (296835)
- Add bytes left to download column in View (152070)
- Add new add trackers dialog with url completion (269563)
- Delete key now also works in the MagnetView (295173)
- Fix sorting of time left column (298542)
- Add support for removable storage (286120)
- Fix typos in several strings (300969, 300781, 300782)
- Fix suspended overlay not shown on tray icon when ktorrent is started up suspended (301042)
- Make sure default size of main window, tracker column in tracker view and filename column in file view are sensible (300057)
- Fix crash in syndication plugin (301117)
- Fix close search tab button not getting disabled when only one is left after closing another one (302896)
- Fix crash when looking up country for IP address (303340)
- Fix size after download calculation in FileSelectDlg when file already exists (304595)
- Use default browser instead of application associated to test/html when clicking on a links in the comments field of the status tab (305005)
- Fix IP filter widget list not getting registered at startup (281245)
- Fix Queue Manager widget getting the priorities wrong (296536)
- Add new group switcher combobox in toolbar (290888)
- Make kio-magnet optional
- Improve handing magnet uris in search plugin
- Fix bug causing kio-magnet to deselect all files
- Close current scan widget when a new one is started for a torrent (292001)
- Fix syndication plugin not handling relative urls properly
- Fix magnet uri's not being handled properly in load torrent feature of webinterface
- Make it possible to check individual files of a torrent
- Data checks for multiple torrents can now get started at the same time (265611)
- Make links clickable in the status tab comments field (266089)
- Revamp UPnP plugin (266397)
- Fix bug making it possible to add conflicting items to the schedule (268879)
- Make it possible for schedule items to span multiple days (225939)
- Include disk usage of existing files when calculating bytes left after download in FileSelectDlg (267220)
- Disable scripts in GUI, if no interpreter could be found for the script (270226)
- Show shutdown plugin's config dialog when no rules are present and the enable button is pressed (271311)
- Make it possible to wait for several events before activating the shutdown action
- Fix wrong required diskspace calculation in some rare circumstances (271097)
- Revamp scanfolder plugin (263813, 271657)
- Revamp GUI of mediaplayer plugin
- Make properties extender a dialog (274356)
- Fix bug causing scripts not to be selectable in scripting plugin
- Show info hash in status tab
- Improve video streaming support
- Add Open With option to FileView context menu (279386)
- Fix bug causing views to not get properly restored when the application language changes (279588)
- Check if new trackers have a supported protocol
- Remove usage of several deprecated KDE3 networking classes
- Remove obsolete config options of datacheck during upload feature
- Improve error display of syndication plugin errors (280814)
- Remove multiple views support (281675)
- Relabel Change Tracker button into Switch Tracker to avoid user confusion (282951)
- Revamp IP filter widget (281245)
- Fix scanfolder moving to loaded directory causing a flurry of popups about the torrent already being loaded (283508)
- Only enable the infowidget plugin by default (278283)
- Add force start option (213504)
- Add torrent search bar for view (269279)
- Make it possible to hide uploads, downloads and not queued torrents in the queue manager (253779, 251861, 210064)
- Merge status and name column into one column and use icons to show the status (272160, 228564)
- Highlight in bold and scroll to newly added torrents (145028)
- Show torrent names in remove torrent and data confirmation dialog (284728)
- Enable select new location button when all non excluded files are missing instead of when all files are missing
- Hide chunkbar when download of stream is complete (259788)
- Suspend/resume queue when middle clicking on tray icon (210027)
- Use dbus to show ktorrent window from plasma applet (287309)
- Fix crash due to dangling pointer (281196)
- Always make already loaded message of a torrent a passive popup (288201)
- Make torrent properties dialog modal (288448)
- Allow i2p addresses as a custom ip in tracker announces
- Fix bug causing homepage of search plugin not the render properly
- Fix statusbar hiding and showing not working (281674)
- Fix missing items in tray menu (282304)
- Fix move on completion location not being set when open all torrents silently is enabled (279582)
- Fix crash when duplicate trackers are added (274413)
- Fix bug causing quit action not be shown in system tray when not using KDE
- Fix edit script not working in scripting plugin
- Make log output suspension work again
- Fix crash when shutdown_rules files becomes corrupted (277602)
- Fix file rename leading to file being placed in the toplevel directory (279926)
##############################
Changes  in the system are minimal ( few new localisations and magnet links in the syndication plugin  ), 
the most of the changes are in the code (see above):

┌─[ symbianflo @ symbianflo ] - [ Mandrivausers.ro ] 
└─[ MRB:aint-no-shit $]: diff <(rpm -qlp ktorrent-4.1.1-3-rosa.lts2012.0.x86_64.rpm) <(rpm -qlp ktorrent-4.3.1-1-rosa.lts2012.0.x86_64.rpm)
4d3
< /usr/lib64/kde4/kio_magnet.so
125d123
< /usr/share/config.kcfg/magnetsettings.kcfg
245a244
> /usr/share/locale/bs/LC_MESSAGES/ktorrent.mo
268a268
> /usr/share/locale/ku/LC_MESSAGES/ktorrent.mo
286a287
> /usr/share/locale/sq/LC_MESSAGES/ktorrent.mo
292a294
> /usr/share/locale/ug/LC_MESSAGES/ktorrent.mo

and ktcore:
┌─[ symbianflo @ symbianflo ] - [ Mandrivausers.ro ] 
└─[ MRB:aint-no-shit $]: diff <(rpm -qlp lib64ktcore12-4.1.1-3-rosa.lts2012.0.x86_64.rpm) <(rpm -qlp lib64ktcore15-4.3.1-1-rosa.lts2012.0.x86_64.rpm)
1,2c1,2
< /usr/lib64/libktcore.so.12
< /usr/lib64/libktcore.so.12.0.1
---
> /usr/lib64/libktcore.so.15
> /usr/lib64/libktcore.so.15.0.0

If you need mor infos please let me know.

Greetings
Comment 6 Alexander Petryakov 2013-01-31 02:26:14 MSK
i got error at start ktorrent
"File or directory http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz not exists."
Comment 7 Alexander Petryakov 2013-01-31 02:31:57 MSK
https://bugs.kde.org/show_bug.cgi?id=236055
Comment 8 Alexander Petryakov 2013-01-31 02:59:43 MSK
I think, problem was on server side. Sorry

ktorrent-4.3.1-1
************** Advisory **************
New bugfix release

[UPDATE REQUEST] ktorrent-4.1.1 to ktorrent-4.3.1
**************************************
QA Verified
Comment 9 symbianflo 2013-01-31 15:34:44 MSK
A BIG THANK YOU GENTS.