Bug 151 - /mnt/install records in mtab after installation
: /mnt/install records in mtab after installation
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on: 27
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 23:46 MSD by Mikhail Kompaniets
Modified: 2012-05-14 12:18 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Kompaniets 2012-04-28 23:46:18 MSD
Description of problem:

after system install there are some records with /mnt in mtab

[root@rosa2012lts256 ~]# cat /etc/mtab |grep mnt
/dev/sda1 /mnt/install ext4 rw,relatime,acl 0 0
none /mnt/install/proc proc rw 0 0
none /mnt/install/sys sysfs rw 0 0
none /mnt/install/proc/bus/usb usbfs rw 0 0
[root@rosa2012lts256 ~]# 


Version-Release number of selected component (if applicable):
ROSA.2012.MARATHON.EE.i586 build 256

How reproducible:


Steps to Reproduce:
1. install system
2. login and run "cat /etc/mtab |grep mnt"
3.
Comment 1 Alexander Burmashev 2012-04-28 23:52:21 MSD
Actually the source of the problem is the same as the flash-drive-in-etc-fstab bug, i believe we should force clean mtab at the end of the setup.
Comment 2 Pavel Shved 2012-05-02 11:20:15 MSD
(In reply to comment #1)
> Actually the source of the problem is the same as the
> flash-drive-in-etc-fstab bug, i believe we should force clean mtab at the
> end of the setup.

I recall we fixed these mtab "install" records before, didn't we?
Comment 3 Aleksandr Kazantcev 2012-05-02 11:30:58 MSD
Actually this patch (not copy mtab) is a reason our problem above 250 ISO.

Now i'm drop it and add new workaround (such remove copied mtab from chroot in last stage before unmount).

Try 268 ISO for test puroses.
Comment 4 Postnikov Dmitry 2012-05-02 11:36:43 MSD
(In reply to comment #3)
> Now i'm drop it and add new workaround (such remove copied mtab from chroot
> in last stage before unmount).
> 
> Try 268 ISO for test puroses.

No problem in 268th.
My mtab after installation:
-----------------
[root@mindlife2 dima]# cat /etc/mtab
/dev/sda2 / ext4 rw,commit=0 0 0
mqueue /dev/mqueue mqueue rw 0 0
hugetlbfs /dev/hugepages hugetlbfs rw 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
mqueue /dev/mqueue mqueue rw 0 0
hugetlbfs /dev/hugepages hugetlbfs rw 0 0
tmpfs /media tmpfs rw,noexec,nosuid,nodev,mode=755 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
[root@mindlife2 dima]#
-----------------