Bug 1508 - NEW FEATURE: select language for GRUB2 menu
: NEW FEATURE: select language for GRUB2 menu
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-25 23:01 MSK by Vladimir Testov
Modified: 2013-02-08 10:53 MSK (History)
6 users (show)

See Also:
RPM Package: kcm-grub2
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
alex.burmashev: published+


Attachments
Error (172.72 KB, image/png)
2013-01-30 16:28 MSK, Vladimir Potapov
Details
xsession-errors after falure (98.07 KB, application/octet-stream)
2013-02-06 14:29 MSK, Vladimir Potapov
Details
grub config (425 bytes, application/octet-stream)
2013-02-06 14:33 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Testov 2013-01-25 23:01:44 MSK
New feauture. Please test.

1. Download and install new version of the package.
2. Start "Configure your desktop", select "startup", then "Bootloader" to start kcm-grub2.
3. Select the second tab (smth like appearance or may be I'm wrong)
4. The first combo-box should be "Language"
5. Select Russian or English (for example) and GRUB2 menu will be translated to that language. Or select "System language" and GRUB2 menu will be the same as your current system language. Language selection remains - means update-grub2 script will be affected too.

P.S. kcm-grub2 haven't got any ability to work with locales at all. Config files for GRUB2, generated with this utility were always in English before.
Comment 1 Vladimir Testov 2013-01-25 23:02:53 MSK
Advisory: new option in kcm-grub2: select bootloader language
https://abf.rosalinux.ru/build_lists/901397
https://abf.rosalinux.ru/build_lists/901396
Comment 2 Vladimir Potapov 2013-01-30 16:28:16 MSK
Created attachment 1113 [details]
Error

I try set english language... and show error
Comment 3 Vladimir Testov 2013-02-01 13:23:21 MSK
Strange. Works fine for me on Desktop Fresh 2012 (updated from repository). Please try to set some other options in kcm-grub. Which system do you use?
Comment 4 Alexander Burmashev 2013-02-01 14:10:14 MSK
Well, i  also tested on the Fresh system with all latest updates and no special changes.
Changed language from system to English and everything is ok.
booted and changed from English to Russian and once again it worked as expected.
No special tweaks were done.

The only thing that may be different - i restarted X after package update
Comment 5 Vladimir Testov 2013-02-01 14:11:40 MSK
Advisory: new option in kcm-grub2: select bootloader language
https://abf.rosalinux.ru/build_lists/901397
https://abf.rosalinux.ru/build_lists/901396
Comment 6 Vladimir Potapov 2013-02-02 10:32:03 MSK
I checked again.
The bug present on both test systems  - x586 and x64.
Reboot after the package installation is included in all our test plans.
May be the problem is that in my grub2 there are 6 rosa systems?
Any choice (even the system language) leads to error.
Comment 7 Vladimir Testov 2013-02-03 15:48:12 MSK
According to your screenshot, you have some problems with d-bus on your testing system. As far as I understand, it has nothing to do with kcm-grub2 update... Could you please try to do new installation of Rosa Fresh 2012 (not beta, alpha of marathon and check again?) I saw some troubles with d-bus on system that was updated from alpha-version. That troubles can be fixed with deletion of ~/.kde4/share/config/plasma-desktop-appletsrc or simply removing of entire ~/.kde4

Again, it has nothing to do with kcm-grub2 update.

Still do not see any reason why this update hasn't been approved.

Again, it looks like there is something wrong with your testing system.
Comment 8 Eugene Budanov 2013-02-04 13:08:11 MSK
I just tested last kcm-grub attached to this task. working good. GRUB Language was changed without problems.
Comment 9 Vladimir Testov 2013-02-04 13:21:30 MSK
Advisory: new option in kcm-grub2: select bootloader language
https://abf.rosalinux.ru/build_lists/901397
https://abf.rosalinux.ru/build_lists/901396
Comment 10 Vladimir Potapov 2013-02-04 13:24:34 MSK
For QA testes used only officially released images (not updated alpha) updated to last version of packages from repo (used urpm-reposync for control)

I check again (new created user) but the error is present again :-(

Maybe the problem is that I had first installed two marathon for grub, and then two rosa-fresh and updated grub to grub2. Can also be a problem in the fact that I had originally installed Russian version. But all of these settings are absolutely standard, and the update should work in such conditions.

If you need some files for reproduce situation on your computer, then I can send them.
Comment 11 Anton Kirilenko 2013-02-04 13:49:28 MSK
Works for me. 
Up-to-date Fresh with a bunch of manually installed packages. I followed steps from the first comment and everything is OK: no errors, language has been changed.
Comment 12 Denis Silakov 2013-02-04 13:54:25 MSK
I would suggest to really find out - what reason can lead to the error mentioned by QA instead of giving voices 'works for me'.
Comment 13 Vladimir Potapov 2013-02-05 08:06:48 MSK
Please repeat your request to the QA after the appearance of new information about this issue.
Comment 14 Alexander Burmashev 2013-02-05 10:53:20 MSK
(In reply to comment #12)
> I would suggest to really find out - what reason can lead to the error
> mentioned by QA instead of giving voices 'works for me'.

I guess that update may be blocked by a different issue and it should be reported as a separate bug
Comment 15 Vladimir Testov 2013-02-06 00:39:17 MSK
Vladimir, could you please give me "Step to reproduce" for the bug you had described?

I can't fix something which I don't know how to reproduce. (Also I don't sure that it has something to do with the update to kcm-grub2)

Did you try to use kcm-grub2 in previous state? Do other changes work all right? Do other changes work in updated state?
Comment 16 Vladimir Testov 2013-02-06 00:40:19 MSK
Advisory: new option in kcm-grub2: select bootloader language
https://abf.rosalinux.ru/build_lists/901397
https://abf.rosalinux.ru/build_lists/901396

As asked, request to the QA. For getting additional information.
Comment 17 Vladimir Potapov 2013-02-06 03:05:47 MSK
The test system is fully working, tested 3-8 packets in a day and has been largely successful.

Step-by-step?
1) I upgrade system
2) I set language to english (see screenshot). or russian, or system.
3) I see error message. 

I can send you the configuration files of my boot loader. Tell me what you need to reproduce the situation.

	
Have you tried to test the package with a updated from marathon boot loader?
Comment 18 Alexander Burmashev 2013-02-06 03:06:33 MSK
just a guess - do you have root password set up or you use root without password ?
Comment 19 Vladimir Potapov 2013-02-06 03:18:44 MSK
I have a root password. System before the action asks him.
Comment 20 Vladimir Testov 2013-02-06 10:48:36 MSK
I need a step-by-step concequence of actions to create a system where that bug appears. In that case I need "step-by-step" to create analog of yours testing system - complete and detailed consequence. :)
Comment 21 Vladimir Potapov 2013-02-06 13:38:31 MSK
1) Install ROSA Marathon x32 GNOME
2) Install ROSA Marathon x64 KDE RP1
3) Install ROSA Marathon x32 KDE RP1
4) Install ROSA Server x32
5) Install ROSA Fresh x32 KDE
6) Install ROSA Fresh x64 KDE
7) Reinstall Rosa Marathon x32 KDE after fail (without grub setup)
It may be simpler to send config files of grub2?
Comment 22 Denis Silakov 2013-02-06 13:48:03 MSK
Please show content of the .xsession-errors file in your home directory just after ksm-grub2 failure.

It is also useful to check that everything is ok with dbus - 'systemctl status dbus'.

And btw, does kcm-grub2 work correctly for you without this update? I.e., can you cahnge some parameters and save grub2 config?
Comment 23 Vladimir Testov 2013-02-06 13:53:32 MSK
What are your disc partitions?
(e.g. sda1 - "/" for "ROSA Marathon x32 GNOME" etc)
Which packages are installed additionally?
How did you updated OSes? (reposync, if I'm right)
Comment 24 Vladimir Testov 2013-02-06 14:04:23 MSK
Please include /etc/default/grub (of every system where the bug appears).
Comment 25 Vladimir Potapov 2013-02-06 14:28:19 MSK
$ systemctl status dbus
dbus.service - D-Bus System Message Bus
          Loaded: loaded (/lib/systemd/system/dbus.service; static)
          Active: active (running) since Wed, 06 Feb 2013 19:22:36 +0900; 4min 16s ago
        Main PID: 2091 (dbus-daemon)
          CGroup: name=systemd:/system/dbus.service
                  ├ 2091 /usr/bin/dbus-daemon --system --address=systemd: --nofor...
                  └ 2580 /usr/sbin/modem-manager
Comment 26 Vladimir Potapov 2013-02-06 14:29:32 MSK
Created attachment 1161 [details]
xsession-errors after falure
Comment 27 Vladimir Potapov 2013-02-06 14:33:57 MSK
Created attachment 1162 [details]
grub config
Comment 28 Vladimir Potapov 2013-02-06 14:40:08 MSK
(In reply to comment #22)

> And btw, does kcm-grub2 work correctly for you without this update? I.e.,
> can you cahnge some parameters and save grub2 config?
Oh! the kcm-grub2  don't work correctly without update!
Comment 29 Vladimir Testov 2013-02-06 14:46:52 MSK
Misprint has been found. It has no effect on working status of kcm-grub2, but makes wrong warning log. I will send new links when finished.
Comment 30 Vladimir Testov 2013-02-06 14:47:28 MSK
*when the build will finish
Comment 31 Vladimir Testov 2013-02-06 14:52:05 MSK
Advisory: new option in kcm-grub2: select bootloader language
https://abf.rosalinux.ru/build_lists/942026
https://abf.rosalinux.ru/build_lists/942025
Comment 32 Vladimir Testov 2013-02-06 14:54:07 MSK
So I think we should move the thread to a new bug and try to find "steps to reproduce" for this bug. And maybe approve the update. :) Hmmm?
Comment 33 Vladimir Potapov 2013-02-06 15:05:34 MSK
In the rosa-mandriva was an old error of work with disks, if the number of partitions larger than 15. Perhaps it is this error? This is easy to check.
Comment 34 Vladimir Testov 2013-02-06 16:06:48 MSK
Works O.K. on rosa fresh with 20 partitions.
Comment 35 Vladimir Potapov 2013-02-06 16:14:39 MSK
I gave this update to other QA tester.
Comment 36 Vladimir Testov 2013-02-06 18:04:16 MSK
Advisory: new option in kcm-grub2: select bootloader language
https://abf.rosalinux.ru/build_lists/942026
https://abf.rosalinux.ru/build_lists/942025

Renewed the advisory, so it is the last message.
Comment 37 Alexander Petryakov 2013-02-08 00:22:05 MSK
kcm-grub2-0.5.8-3
************** Advisory **************
new option in kcm-grub2: select bootloader language
**************************************
QA Verified