Bug 1505 - Error mount ntfs partition after "Shutdown" in Windows 8
: Error mount ntfs partition after "Shutdown" in Windows 8
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 13:13 MSK by Postnikov Dmitry
Modified: 2013-11-11 18:49 MSK (History)
2 users (show)

See Also:
RPM Package: ntfs-3g-2012.1.15-2-rosa2012.1.x86_64.rpm
ISO-related:
Bad POT generating:
Upstream: unknown


Attachments
Win8-ntfs (114.04 KB, image/png)
2013-01-24 13:13 MSK, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2013-01-24 13:13:41 MSK
Created attachment 1089 [details]
Win8-ntfs

Description of problem:
Error mount ntfs partition after "Shutdown" in Windows 8
If in Windows 8 change "Reboot", then ntfs partition mount is OK.
If plug usb flash with ntfs partition, then mount flash is OK.
Any error in ntfs-3g or Windows 8 is doing something with ntfs partitions after turning off the computer.
Reproduce in 3 computers.

See att.

Version-Release number of selected component (if applicable):
ntfs-3g-2012.1.15-2-rosa2012.1.x86_64.rpm

How reproducible:


Steps to Reproduce:
1. Boot Win8, click "Shutdown"
2. Boot ROSA, in Dolphin click ntfs partition. View Error message.
3. Reboot, boot in Win8, click "Reboot"
4. Boot ROSA, in Dolphin click ntfs partition. All mount OK
Comment 2 Postnikov Dmitry 2013-01-30 22:45:41 MSK
(In reply to comment #1)
> Try this package
> 
> Fresh
> http://abf.rosalinux.ru/downloads/rosa2012.1/container/938002/i586/main/
> release/
> http://abf.rosalinux.ru/downloads/rosa2012.1/container/938004/x86_64/main/
> release/

In x86_64 i tested. But situation is the same.
I reinstalled system and try again...
Comment 3 Aleksandr Kazantcev 2013-01-30 22:47:30 MSK
As error appear in non-patches upstream package this is not our problem - may be Win8 bug, may be in upstream...
Comment 4 Postnikov Dmitry 2013-01-30 22:53:03 MSK
Probably have to wait until a greater number of people will have this problem, maybe in upstream something fixed.

==========
[root@mindlife pastordi]# ntfs-3g /dev/sda1 /media/dd1
Windows is hibernated, refused to mount.
Failed to mount '/dev/sda1': Операция не позволяется
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
[root@mindlife pastordi]# 
[root@mindlife pastordi]# rpm -qa | grep ntfs
ntfs-3g-2013.1.13-1-rosa2012.1.x86_64
[root@mindlife pastordi]# 
[root@mindlife pastordi]#
===========
Comment 5 Aleksandr Kazantcev 2013-01-30 22:57:18 MSK
You not doing full shutdown - only hibernate. It's normal not enabling ntfs partition after hibernate because this may break Windows!

But this is WIN 8 error - for faster boot it was not shutdowned system fully, only hibernate it :(

We may only one way - try mount all ntfs partition as read-only or have this error...
Comment 6 Denis MARCOUREL 2013-07-23 17:51:49 MSD
In searching the web, I found these two possible solutions.

In Windows 8, we can Temporarily or Permanently disabling this "hybrid boot" :

1. Temporarily - Press down and hold the ‘Shift’ key while clicking on the ‘Shut down’ menu item.
2. Permanently - In the "Control panel", search for "change what power buttons do" and click on this. In this configuration page, click on "Change settings that are currently unavailable". Under the sub-heading "Shutdown settings", remove the check mark of the option called "Turn on fast start-up (recommended)".

For Linux users, it is possible to disable this "hybrid boot : in the "mount options", add "remove_hiberfile".

Hoping that my contribution can help...
Comment 7 Postnikov Dmitry 2013-11-11 18:49:43 MSK
(In reply to comment #6)
> In searching the web, I found these two possible solutions.
> 
> In Windows 8, we can Temporarily or Permanently disabling this "hybrid boot"
> :
> 
> 1. Temporarily - Press down and hold the ‘Shift’ key while clicking on the
> ‘Shut down’ menu item.
> 2. Permanently - In the "Control panel", search for "change what power
> buttons do" and click on this. In this configuration page, click on "Change
> settings that are currently unavailable". Under the sub-heading "Shutdown
> settings", remove the check mark of the option called "Turn on fast start-up
> (recommended)".
> 
> For Linux users, it is possible to disable this "hybrid boot : in the "mount
> options", add "remove_hiberfile".
> 
> Hoping that my contribution can help...

Yes. For me help this method.