Bug 1499 - rpmdrake can crash when attempting to flush UI
: rpmdrake can crash when attempting to flush UI
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 11:38 MSK by Denis Silakov
Modified: 2013-01-31 12:01 MSK (History)
2 users (show)

See Also:
RPM Package: rpmdrake
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2013-01-22 11:38:06 MSK
There was a long thread in the MIB forum and other places about rpmdrake crashing in some situations:
http://mib.pianetalinux.org/forum/viewtopic.php?f=54&t=3668&start=20

It turned out that such crashes arise when rpmdrake attempts to flush its UI - a feature that was added very long ago, as a workaround for Gtk deficiency due to which rpmdrake windows were not redrawn automatically in some cases (https://qa.mandriva.com/show_bug.cgi?id=15408).

However, it seems that there is no need in such forced UI flushing with modern GTK. It only introduces problems.

There was also a long discussion in Mageia that led to the same decision:

https://bugs.mageia.org/show_bug.cgi?id=4918
Comment 1 Denis Silakov 2013-01-22 11:41:24 MSK
Advisory:

Disable obsolete UI flushing in rpmdrake that could lead to crashes.

Build lists:
https://abf.rosalinux.ru/build_lists/900614
https://abf.rosalinux.ru/build_lists/900615

Note that it can be hard to reproduce the actual bug (discussed in Mageia bugzilla or MIB forums). Some of us managed to reproduce the bug only when starting rpmdrake from console, others cannot reproduce the bug at all...

Original reporters from MIB say that this fix doea eliminate the problem.

However, it would be nice to additionally test rpmdrake at to check that at least the problem described in https://qa.mandriva.com/show_bug.cgi?id=15408 doesn't appear again.
Comment 2 Denis Silakov 2013-01-24 10:25:45 MSK
(new build lists after ABF update):

Advisory:

Disable obsolete UI flushing in rpmdrake that could lead to crashes.

Build lists:

https://abf.rosalinux.ru/build_lists/900744
https://abf.rosalinux.ru/build_lists/900745
Comment 3 Denis Silakov 2013-01-24 11:28:16 MSK
Brr, wrong lists.

Advisory:

Disable obsolete UI flushing in rpmdrake that could lead to crashes.

Build lists:
https://abf.rosalinux.ru/build_lists/900757
https://abf.rosalinux.ru/build_lists/900762
Comment 4 Vladimir Potapov 2013-01-30 14:36:34 MSK
I reproduce the bug on i586 and x64 ROSA
1) Run rpmdrake from konsole.
2) Install inkscape
3) When installation continue, 3-4 times overlap dpmdrake window by other window and restore it's focus.
Comment 5 Vladimir Potapov 2013-01-30 18:42:24 MSK
rpmdrake-5.26.12-8-rosa2012.1
**************** Advisory ****************
isable obsolete UI flushing in rpmdrake that could lead to crashes.
******************************************
QA Verified