Bug 1491 - Unable to install Avast Antivirus for Linux
: Unable to install Avast Antivirus for Linux
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal trivial
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-21 10:03 MSK by FirstLevel
Modified: 2014-06-09 11:10 MSD (History)
2 users (show)

See Also:
RPM Package: libexpat1-2.1.0-2-rosa2012.1.i586
ISO-related:
Bad POT generating:
Upstream: wontfix


Attachments
installation error (19.85 KB, image/png)
2013-01-21 10:03 MSK, FirstLevel
Details
Avast_Ошибки_после_обновления_баз.png (32.35 KB, image/png)
2013-01-22 09:28 MSK, FirstLevel
Details
avastgui_launch.png (8.47 KB, image/png)
2013-01-22 09:28 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-01-21 10:03:09 MSK
Created attachment 1075 [details]
installation error

Description of problem:
I have installed ROSA 2012.1 Fresh and want to install Avast Antivirus for Linux (http://files.avast.com/files/linux/avast4workstation-1.3.0-1.i586.rpm)
But whan I install this package I get an error about broken dependencies. See attach

For Example in last version of Kubuntu I can to install avast without any problems


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Silakov 2013-01-21 11:13:09 MSK
At the first glance, I don't see any binary files inside that rpm that really require libexpat. Likely this is a packaging problem; I would suggest to either install the rpm ignoring the error message or download .tar.gz archive from avast site and unpack it to the root filesystem.
Comment 2 FirstLevel 2013-01-22 09:28:10 MSK
(In reply to comment #1)
> At the first glance, I don't see any binary files inside that rpm that
> really require libexpat. Likely this is a packaging problem; I would suggest
> to either install the rpm ignoring the error message or download .tar.gz
> archive from avast site and unpack it to the root filesystem.

rpm -ihv --nodeps avast4workstation-1.3.0-1.i586.rpm  does not work
Avast was installed but has errors.
When it was updated Avast_Ошибки_после_обновления_баз.png
After usuccessfull update avastgui can't start avastgui_launch.png
Comment 3 FirstLevel 2013-01-22 09:28:23 MSK
Created attachment 1083 [details]
Avast_Ошибки_после_обновления_баз.png
Comment 4 FirstLevel 2013-01-22 09:28:35 MSK
Created attachment 1084 [details]
avastgui_launch.png
Comment 5 Denis Silakov 2013-01-23 15:09:55 MSK
This doesn't seem to be caused by missing dependencies.

Try to run this command in console with root privileges:

sysctl -w kernel.shmmax=128000000

And then start avast again.
Comment 6 FirstLevel 2013-01-24 09:52:23 MSK
(In reply to comment #5)
> This doesn't seem to be caused by missing dependencies.
> 
> Try to run this command in console with root privileges:
> 
> sysctl -w kernel.shmmax=128000000
> 
> And then start avast again.
Yes it works.
Comment 7 Denis Silakov 2013-01-24 10:40:18 MSK
It's a known issue with Avast requiring too large value of shmmax:

http://forum.avast.com/index.php?topic=57775.0

They think it's ok and the old limit is "artificial and conservative". However, I don't know any other desktop application that requires so large kernel.shmmax.

In order to constantly set kernel.shmmax to necessary value, add corresponding string (kernel.shmmax = 128000000) to the /etc/sysctl.conf.
Comment 8 FirstLevel 2014-06-09 11:10:12 MSD
Use