Bug 1483 - Could not insert text from clipboard to LibreOffice Writer
: Could not insert text from clipboard to LibreOffice Writer
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-18 09:51 MSK by FirstLevel
Modified: 2015-04-20 11:46 MSD (History)
3 users (show)

See Also:
RPM Package: libreoffice-writer-3.6.2-1-rosa2012.1.i586
ISO-related:
Bad POT generating:
Upstream: known


Attachments
Copied URL (122.34 KB, image/jpeg)
2013-01-18 09:51 MSK, FirstLevel
Details
writer error (89.16 KB, image/jpeg)
2013-01-18 09:51 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-01-18 09:51:27 MSK
Created attachment 1071 [details]
Copied URL

Description of problem:
1. Open speedtest.net in firefox.
2. Choose server and launch test
3. After ending click Share Results and copy URL in the appropriate field
4. You can paste this text into kwrite
5. But if You try paste this text to LibreOffice Writer You get an error (screenshot is attached)
6. You can paste the text only using Klipper


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-01-18 09:51:38 MSK
Created attachment 1072 [details]
writer error
Comment 2 Denis Silakov 2013-09-18 14:47:32 MSD
This is a well-known issue that exists for a long time. Sometimes LibreOffice can't treat the clipboard data correctly.

As a workaround, you can insert the text using "Edit->Paste special" (choose "Unformattes text" there).
Comment 3 Denis Silakov 2013-09-18 14:58:30 MSD
https://bugs.freedesktop.org/show_bug.cgi?id=40176
Comment 4 FirstLevel 2014-06-03 14:56:44 MSD
checking the relevance
Comment 5 FirstLevel 2014-06-06 08:31:10 MSD
Case is actual for Firefox+LibreOfficeWriter.
If I use chromium+LOWriter the results is copied well.
I think it is not problem of Libreffice, but Firefox.
Comment 6 Denis Silakov 2014-06-06 09:34:32 MSD
As freedesktop bug states, this is a problem of Libreffice which sometimes cannot treat clipboard data corectly. Firefox works fine, it puts the data to clipboard as expected, but LibreOffice sometimes can insert it only using "Edit->Paste special" menu item as "Unformatted text". Otherwise it tries to format that data and fails.

It looks like LO guys don't know how to resolve this issue completely.
Comment 7 FirstLevel 2014-10-08 17:29:10 MSD
Please check the problem for our new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 8 FirstLevel 2014-10-08 17:38:06 MSD
Case is actual for 2014.1
Comment 9 FirstLevel 2015-04-20 11:43:50 MSD
Solved for Fresh R5
Comment 10 FirstLevel 2015-04-20 11:46:46 MSD
oooooooooops.
Sorry. For firefox bug is still valid