Bug 1469 - Openshot causes error while starting
: Openshot causes error while starting
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-16 13:32 MSK by FirstLevel
Modified: 2013-01-30 15:40 MSK (History)
4 users (show)

See Also:
RPM Package: frei0r-plugins-1.3-3-rosa2012.1.i586
ISO-related:
Bad POT generating:
Upstream:
alex.burmashev: published+


Attachments
openshot error while starting (94.92 KB, image/jpeg)
2013-01-16 13:32 MSK, FirstLevel
Details
some diagnostic information (15.34 KB, text/plain)
2013-01-16 13:32 MSK, FirstLevel
Details
openshot.txt (2.82 KB, text/plain)
2013-01-29 17:18 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-01-16 13:32:16 MSK
Created attachment 1059 [details]
openshot error while starting

Description of problem:
I have installed ROSA 2012.1 Fresh i586. I have installed openshot without errors. But when I launch Openshot I get an error about unable to load plugin frei0r-plugins
I have attached urpmi output when I have installed openshot and output from konsole when I have launched openshot. I have attached screenshot of error too.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-01-16 13:32:31 MSK
Created attachment 1060 [details]
some diagnostic information
Comment 2 Denis Silakov 2013-01-28 10:20:27 MSK
symbianflo, do you have any ideas about this bug? It was present in Marathon, and seems to be still valid in Desktop Fresh...
Comment 3 symbianflo 2013-01-28 21:14:46 MSK
(In reply to comment #2)
> symbianflo, do you have any ideas about this bug? It was present in
> Marathon, and seems to be still valid in Desktop Fresh...

I'll check it out for 2012.1, 
and in 2012lts AFIC I fixed it , add MRB or my_personal
to have a working app .
At the time I didn't have the credentials to build/publish  in contrib.
(BTW not even now I can not publish in LTS ) 

Keep in touch.
Comment 4 symbianflo 2013-01-29 02:51:56 MSK
Ok I've checked and fix it , but , ( there is a "but" always) 
Can you checked out from my personal , you'll need  the new py-mlt/mlt and the new openshot.
 
Long story short , please try the openshot /mlt from here:
http://abf.rosalinux.ru/downloads/symbianflo_personal/repository/rosa2012.1/
If works fine for you , then you can imported  in main/contrib.
Now just a thought , mlt does not seems to me so important to be in main , 
so I think that it can be maintained better if we have mlt in contrib, but 
of course is just my opinion.


Greetings
Comment 5 Denis Silakov 2013-01-29 13:09:52 MSK
Thanks, this really helps!

Let's update mlt first and then I'll create a separate request for openshot update.

Advisory:

Updated mlt to fix issue with openshot and frei0r plugins

Build lists:
https://abf.rosalinux.ru/build_lists/937456
https://abf.rosalinux.ru/build_lists/937457
Comment 6 Denis Silakov 2013-01-29 13:17:46 MSK
Oops, the bug was filed against contributed packages, so the updated package has been already published, though mlt itself is in main...
Comment 7 symbianflo 2013-01-29 15:50:22 MSK
(In reply to comment #6)
> Oops, the bug was filed against contributed packages, so the updated package
> has been already published, though mlt itself is in main...

Just saying , like before .. ;D 
This bug report is wrong, openshot is not to blame , is mlt... at least AFIC
mlt +kdenlive+openshot would be awesome in contrib... but  in this way it's a mess  
to maintain those, (BTW kdelive new bugfix release with more then 120 bugs fixed, and whole the dvd generating part re-written any volunteer ?.. :D  )
And please don't tell me that is not realted to this bug... all are only
 GUI's  for mlt ... so to update all mlt-stack you'll need one month 
QA for mlt , QA for kdenlive, build and fix...a.s.o , when you'll finished  with this , then you have to start all over again  because of the new mlt that came out in the meanwhile :D
Let's just forget it , and keep/fix/patch the old stuff , it's easier :D
Comment 8 FirstLevel 2013-01-29 17:18:35 MSK
(In reply to comment #4)
> Ok I've checked and fix it , but , ( there is a "but" always) 
> Can you checked out from my personal , you'll need  the new py-mlt/mlt and
> the new openshot.
>  
> Long story short , please try the openshot /mlt from here:
> http://abf.rosalinux.ru/downloads/symbianflo_personal/repository/rosa2012.1/
> If works fine for you , then you can imported  in main/contrib.
> Now just a thought , mlt does not seems to me so important to be in main , 
> so I think that it can be maintained better if we have mlt in contrib, but 
> of course is just my opinion.
> 
> 
> Greetings

User that has problem could not launch openshot after installing it from http://abf.rosalinux.ru/downloads/symbianflo_personal/repository/rosa2012.1/ with error in openshot.txt
Comment 9 FirstLevel 2013-01-29 17:18:47 MSK
Created attachment 1098 [details]
openshot.txt
Comment 10 Denis Silakov 2013-01-29 17:20:54 MSK
It seems he hasn't update libmlt++
Comment 11 FirstLevel 2013-01-29 17:33:09 MSK
(In reply to comment #10)
> It seems he hasn't update libmlt++

What package should he install?
Comment 12 Denis Silakov 2013-01-29 17:47:17 MSK
libmlt++3 (32bit) or lib64mlt++3 (64bit)
Comment 13 symbianflo 2013-01-29 21:51:40 MSK
If I gave the repo should be a reason , and he had to force --nodeps the install because :
Requires:   python-mlt >= 0.8.8


my build  ask for py-mlt >= 0.8.8, so I don't know what testing is this ......
Any way I don't intend to maintain openshot outside  my_personal, gents. I'm sorry , but is to time consuming since depends too much on main .
Comment 14 Denis Silakov 2013-01-30 10:36:04 MSK
(In reply to comment #13)

> Any way I don't intend to maintain openshot outside  my_personal, gents. I'm
> sorry , but is to time consuming since depends too much on main .

No problem with this. I think it's not a good idea to move a package from main to contrib in already released system (and leave users who don't use contrib with semi-broken package), but we will keep this in mind for future releases:)
Comment 15 symbianflo 2013-01-30 15:40:43 MSK
(In reply to comment #14)
> (In reply to comment #13)
> 
> > Any way I don't intend to maintain openshot outside  my_personal, gents. I'm
> > sorry , but is to time consuming since depends too much on main .
> 
> No problem with this. I think it's not a good idea to move a package from
> main to contrib in already released system (and leave users who don't use
> contrib with semi-broken package), but we will keep this in mind for future
> releases:)

I know you will ... also because I'll  be here with my annoying requests :D