Bug 146 - You can not set the address of the network interface without reconnection
: You can not set the address of the network interface without reconnection
Status: RESOLVED DUPLICATE of bug 69
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 13:26 MSD by FirstLevel
Modified: 2012-07-24 14:46 MSD (History)
2 users (show)

See Also:
RPM Package: networkmanager-0.9.2.0-4.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-04-28 13:26:31 MSD
Description of problem:

Suppose the network interface is DHCP address.
1. Open the Network Manager
2. Enter the static address (setting the checkbox System Connection)
3. Click apply, enter the root password
4. Nothing happens and the network interface has the old address.
5. In the networkmanager interface disconnect, connect again.
6. Address changed.
It is essential that the address was changed in step 4.

Version-Release number of selected component (if applicable):

[root@localhost ~]# rpm -qa | grep etworkm
networkmanager-0.9.2.0-4-rosa.lts2012.0.i586
networkmanager-vpnc-0.9.2.0-1-rosa.lts2012.0.i586
networkmanager-pptp-0.9.2.0-1-rosa.lts2012.0.i586
networkmanager-openvpn-0.9.2.0-1-mdv2011.0.i586
knetworkmanager-common-0.9.0-2-rosa.lts2012.0.i586
knetworkmanager-pptp-0.9.0-2-rosa.lts2012.0.i586
plasma-applet-networkmanagement-0.9.0-2-rosa.lts2012.0.i586
[root@localhost ~]# 


[root@localhost ~]# rpm -qi networkmanager-0.9.2.0-4-rosa.lts2012.0.i586
Name        : networkmanager               Relocations: (not relocatable)
Version     : 0.9.2.0                           Vendor: Mandriva
Release     : 4                             Build Date: Thu 29 Mar 2012 01:16:57 MSK
Install Date: Tue 03 Apr 2012 20:01:52 MS   Build Host: build-client_i586-1.rosalab.ru
Group       : System/Base                   Source RPM: networkmanager-0.9.2.0-4.src.rpm
Size        : 6780778                          License: GPLv2+
Signature   : DSA/SHA1, Thu 29 Mar 2012 01:16:57 MSK, Key ID ebb1c12f91bc1cc4
URL         : http://www.gnome.org/projects/NetworkManager/
Summary     : Network connection manager and user applications
Architecture: i586
Description :
NetworkManager attempts to keep an active network connection available at all
times.  It is intended only for the desktop use-case, and is not intended for
usage on servers.   The point of NetworkManager is to make networking
configuration and setup as painless and automatic as possible.  If using DHCP,
NetworkManager is _intended_ to replace default routes, obtain IP addresses
from a DHCP server, and change nameservers whenever it sees fit.
[root@localhost ~]# 


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-07-12 08:23:05 MSD
Is there any comments from developers?
Comment 2 alexander barakin 2012-07-24 14:46:44 MSD

*** This bug has been marked as a duplicate of bug 69 ***