Bug 1447 - fbreader - segmentation fault on i586
: fbreader - segmentation fault on i586
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: i586 Linux
: Normal major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-14 11:35 MSK by alexander barakin
Modified: 2013-01-28 10:16 MSK (History)
2 users (show)

See Also:
RPM Package: fbreader
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexander barakin 2013-01-14 11:35:54 MSK
Description of problem:
fbreader crashes at startup with segmentation fault on i586.

Version-Release number of selected component (if applicable):
fbreader-0.12.10-2

How reproducible:
always

Steps to Reproduce:
1. install fbreader
2. run fbreader:
$ FBReader
loading /usr/lib/zlibrary/ui/zlui-active.so
Segmentation fault (core dumped)

backtrace (also see http://paste.ubuntu.com/1530209/):
#0  0x47c4a04e in ftell () from /lib/i686/libc.so.6
#1  0xb7f60f86 in ZLUnixFileInputStream::offset() const ()
   from /usr/lib/libzlcore.so.0.13
#2  0xb7f0541f in ZLInputStreamDecorator::open() ()
   from /usr/lib/libzlcore.so.0.13
#3  0xb7f059d0 in ZLGzipInputStream::open() () from /usr/lib/libzlcore.so.0.13
#4  0xb7f396e0 in ZLXMLReader::readDocument(shared_ptr<ZLInputStream>) ()
   from /usr/lib/libzlcore.so.0.13
#5  0xb7f399e5 in ZLXMLReader::readDocument(std::string const&) ()
   from /usr/lib/libzlcore.so.0.13
#6  0xb7efdd9f in ?? () from /usr/lib/libzlcore.so.0.13
#7  0xb7efe969 in ZLUnicodeUtil::toLower(unsigned int) ()
   from /usr/lib/libzlcore.so.0.13
#8  0xb7efe9da in ZLUnicodeUtil::toLower(std::vector<unsigned int, std::allocator<unsigned int> >&) () from /usr/lib/libzlcore.so.0.13
#9  0xb7eff1ae in ZLUnicodeUtil::toLower(std::string const&) ()
   from /usr/lib/libzlcore.so.0.13
#10 0xb7f01cde in ZLFile::ZLFile(std::string const&) ()
   from /usr/lib/libzlcore.so.0.13
#11 0x082278d0 in ZLOption::FULL_KEYBOARD_CONTROL ()
#12 0xb7f2ca59 in MyEncodingConverterProvider::MyEncodingConverterProvider() ()
   from /usr/lib/libzlcore.so.0.13
#13 0xb7f2dfe1 in ZLEncodingCollection::ZLEncodingCollection() ()
   from /usr/lib/libzlcore.so.0.13
#14 0xb7f2e18e in ZLEncodingCollection::Instance() ()
   from /usr/lib/libzlcore.so.0.13
#15 0xb7ea2a47 in ZLGtkLibraryImplementation::init(int&, char**&) ()
   from /usr/lib/zlibrary/ui/zlui-active.so
#16 0xb7f626b0 in ZLibrary::init(int&, char**&) ()
   from /usr/lib/libzlcore.so.0.13
#17 0x0805af8e in ?? ()
#18 0x47bff7b5 in __libc_start_main () from /lib/i686/libc.so.6
#19 0x0806034d in ?? ()
Backtrace stopped: Not enough registers or memory available to unwind further


additional:
http://ubuntuforums.org/showthread.php?t=1407868
maybe it makes sense to build qt-version.
Comment 1 symbianflo 2013-01-14 15:50:22 MSK
I'll try to investigate , even if I can not reproduce it ...
http://mrb.mandrivausers.ro/MRB/Drop-Here/schermata83.png
 on my 64 bit 2012.1 box run fine.
Comment 2 Denis Silakov 2013-01-14 15:51:22 MSK
This really works fine in 64bit system, but fails in my 32bit VBox.
Comment 3 symbianflo 2013-01-14 16:02:15 MSK
Ok I'll push in cloud a 586 of 2012.1 and try to fix it.

Greetings
Comment 4 symbianflo 2013-01-15 22:09:24 MSK
Can you please try it from my_personal , the release 5?
also qt4-ui should work ( at least on my machines does) 
If is it ok  for you I'll clean the spec and push it .

Thank you for bug report.
Comment 5 Denis Silakov 2013-01-16 15:27:51 MSK
Works fine for me, both Qt and GTK UIs.
Comment 6 alexander barakin 2013-01-16 16:01:14 MSK
(In reply to comment #4)
> Can you please try it from my_personal , the release 5?
> also qt4-ui should work ( at least on my machines does) 
> If is it ok  for you I'll clean the spec and push it .

https://abf.rosalinux.ru/build_lists/897934 ?

yes, fbreader starts normally after upgrading three packages:
fbreader
libzlibrary
libzlibrary-ui-gtk

do i understand correctly that the package libzlibrary-ui-qt is not used?



small hint:
it would be better if you did not publish the build.
then one could attach the container as a repository:
# urpmi.addmedia 897934 http://abf.rosalinux.ru/downloads/symbianflo_personal/container/fbreader-897934/RPMS/
# urpmi --auto-update
it would simplify the testing of the installation process.
Comment 7 symbianflo 2013-01-16 22:08:27 MSK
(In reply to comment #6)
> (In reply to comment #4)
> > Can you please try it from my_personal , the release 5?
> > also qt4-ui should work ( at least on my machines does) 
> > If is it ok  for you I'll clean the spec and push it .
> 
> https://abf.rosalinux.ru/build_lists/897934 ?
> 
> yes, fbreader starts normally after upgrading three packages:
> fbreader
> libzlibrary
> libzlibrary-ui-gtk
> 
> do i understand correctly that the package libzlibrary-ui-qt is not used?
Yes it's used , but since you don't had it before 
won't update , at the new install should ask you 
witch UI do you want .




> 
> 
> 
> small hint:
> it would be better if you did not publish the build.
> then one could attach the container as a repository:
> # urpmi.addmedia 897934
> http://abf.rosalinux.ru/downloads/symbianflo_personal/container/fbreader-
> 897934/RPMS/
> # urpmi --auto-update
> it would simplify the testing of the installation process.

Thx for the hint ...
:D It was told me never -ever go public with my_personal repo on abf

( that's why I didn't publish the link...) 
since I don't have much as a choice I've published it , just to make it usable for 586 users, but is not over yet :D it's just a quick fix .
Comment 8 symbianflo 2013-01-16 22:23:52 MSK
(In reply to comment #6)
> (In reply to comment #4)
> > Can you please try it from my_personal , the release 5?
> > also qt4-ui should work ( at least on my machines does) 
> > If is it ok  for you I'll clean the spec and push it .
> 
> https://abf.rosalinux.ru/build_lists/897934 ?
> 
> yes, fbreader starts normally after upgrading three packages:
> fbreader
> libzlibrary
> libzlibrary-ui-gtk
> 
> do i understand correctly that the package libzlibrary-ui-qt is not used?
> 
something like this:
[root@symbianflo symbianflo]# urpmi fbreader
In order to satisfy the 'fbreader-gui' dependency, one of the following packages is needed:
 1- libzlibrary-ui-gtk-0.12.10-5-rosa2012.1.i586: GTK+ interface module for ZLibrary (to install)
 2- libzlibrary-ui-qt4-0.12.10-5-rosa2012.1.i586: Common files for FBReader (to install)
What is your choice? (1-2) 2
To satisfy dependencies, the following packages are going to be installed:
 Package                        Version      Release       Dist  DEpoch Arch 
(medium "symbianflo")
 fbreader                       0.12.10      5             rosa  2012.1 i586 
 libzlibrary                    0.12.10      5             rosa  2012.1 i586 
 libzlibrary-ui-qt4             0.12.10      5             rosa  2012.1 i586 
6.2MB of additional disk space will be used.
1.8MB of packages will be retrieved.
Proceed with the installation of the 3 packages? 



> 
> 
> small hint:
> it would be better if you did not publish the build.
> then one could attach the container as a repository:
> # urpmi.addmedia 897934
> http://abf.rosalinux.ru/downloads/symbianflo_personal/container/fbreader-
> 897934/RPMS/
> # urpmi --auto-update
> it would simplify the testing of the installation process.
Comment 9 Denis Silakov 2013-01-28 10:16:20 MSK
Closing this bug, since the actual issue is fixed.

2 symbianflo: note that there was a couple of changes in addition to yours made by abondrov in the import group:
https://abf.rosalinux.ru/import/fbreader/commits/rosa2012.1?

Likely you'll want to take that changes back to your personal copy.