Bug 144 - Dropbox not working in Mandriva 2011
: Dropbox not working in Mandriva 2011
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 10:56 MSD by FirstLevel
Modified: 2012-05-04 10:06 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-04-28 10:56:32 MSD
Description of problem:
https://qa.mandriva.com/show_bug.cgi?id=64229

I know there are two ways to make Dropbox work in KDE, installing Kfilebox, or
downloading the daemon and executing it from a terminal.

Neither option is successfull.

At first, I downloaded the daemon, and when I executed it from a terminal, what
was supposed to have happened would occured was open the Dropbox configuration
window to synchronize with my account, but instead, the message in terminal was
the following:

[varyheavy@localhost .dropbox-dist]$ ./dropboxd
This client is not linked to any account...
Please visit
https://www.dropbox.com/cli_link?host_id=79c542ab47682529cce549f9426e7c06&cl=es
to link this computer.

Immediately I clicked on this web-link to link my computer with my Dropbox
account, but... after link the computer by web, and execute the daemon again,
the message in the terminal was the same. There was no synchronization.

After this, I tried installing Kfilebox (which, incidentally, is not in the
repositories, I installed it from its project web). When I executed Kfilebox, a
little window with a progressbar appeared with the message "Downloading
daemon...". When the downloading finished, the little window disappeared, and
nothing else happened. The Dropbox configuration window did not appear and I
cannot synchorize Mandriva 2011 with my Dropbox account.

It's my first time this happens, the first time I have trouble setting up my
Dropbox account. In all other distros, I used Dropbox without problems.


Steps to Reproduce:
WITH THE DAEMON
1. Download the Dropbox daemon from here:
http://www.getdropbox.com/download?plat=lnx.x86_64 (64 bit) -
http://www.getdropbox.com/download?plat=lnx.x86 (32 bit)

2. Decompress the daemon with "tar xf dropbox-lnx*.tar.gz". A new hidden folder
is created with the name ".dropbox-dist".

3. Stand in the directory .dropbox-dist and execute: "./dropboxd".

4. Observe that the message is always the same and never has synchronization.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Alexander Burmashev 2012-04-28 11:33:56 MSD
I am unable to reproduce such behaviour.

I followed the guide at https://www.dropbox.com/install?os=lnx

1) I ran 
cd ~ && wget -O - "http://www.dropbox.com/download?plat=lnx.x86" | tar xzf -
from my user
2) ~/.dropbox-dist/dropboxd

followed the link in browser and logged in with my dropbox account.

It then told me that Client succesfully linked and Dropbox folder appeared in my home dir.
It is working as expected.

!! Please note, common sense told me that it all should be executed from user - and i was right, setup from user is ok.
Comment 2 FirstLevel 2012-04-28 11:43:32 MSD
On other distro (kubuntu, OpenSuse) after "2) ~/.dropbox-dist/dropboxd" You'll see the graphical wizard of installation.
And I'll test it on RC soon
Comment 3 Alexander Burmashev 2012-04-28 11:45:42 MSD
I can't say about other graphical distros, but on ROSA system Dropbox folder in my home dir is created without any graphical interface.
Comment 4 FirstLevel 2012-05-04 10:06:23 MSD
On RC with actual updates dropbox is running correctly