Bug 142 - Changelog is empty for a lot of packages
: Changelog is empty for a lot of packages
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: Alexander Burmashev
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 00:52 MSD by Gaël
Modified: 2012-06-08 16:37 MSD (History)
1 user (show)

See Also:
RPM Package: rpmdrake
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gaël 2012-04-28 00:52:08 MSD
Description of problem:
Changelog for a lot of packages is empty.


Version-Release number of selected component (if applicable):
rpmdrake-5.26.12 / rpm-5.3.12


How reproducible:
Always


Steps to Reproduce with rpm (for example, with "rosa-icons" package)
1. Start "konsole",
2. Write "rpm -q --changelog rosa-icons" and enter,
3. Nothing will be displayed.

Steps to Reproduce with Rpmdrake
1. Search for the package "rosa-icons",
2. Click on the changelog button,
3. There is an empty line below the title "changelog".


I have setup media with "hdlist.cz" and not "synthesis.hdlist.cz" 
("XML meta-data download policy is "Always" in drakrpm-edit-media) :

urpmi.addmedia rosa2012lts-main32 ftp://ftp.yandex.ru/rosa/rosa2012lts/repository/i586/main/release with media_info/hdlist.cz
Comment 1 Denis Silakov 2012-05-10 13:57:52 MSD
Probably the reason is that we don't put changelog.xml into the media_info atm. Neither we put files.xml and info.xml there.
Comment 2 Alexander Burmashev 2012-05-10 14:10:37 MSD
Thanks for the report - i contacted ABF developers and option to generate xml files will be added very soon.
Comment 3 Denis Silakov 2012-06-08 16:37:00 MSD
Changelog.xml is now generated and pushed to media_info, as well as files.xml and info.xml. So changelogs for repositories are available.

There is a separate problem that ABF doesn't generate changelogs automatically from git at the moment, so you will only see the logs explicitly specified in spec files. And in the example with 'rosa-icons' you will still an empty log.

ABF developers have the 'automated changelog generation from git' item in their TODO list, hopefully this will be implemented in the near future.