Bug 1419 - [UPDATE REQUEST] gnome-documents, librest
: [UPDATE REQUEST] gnome-documents, librest
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-10 19:34 MSK by Arkady L. Shane
Modified: 2013-01-21 11:33 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arkady L. Shane 2013-01-10 19:34:00 MSK
Advisory:
Update gnome-documents to 3.6.2. This release needs new librest, so librest was updated to 0.7.90.

Buildlists:
== gnome-documents ==
https://abf.rosalinux.ru/build_lists/872390
https://abf.rosalinux.ru/build_lists/872391

== librest ==
https://abf.rosalinux.ru/build_lists/873222
https://abf.rosalinux.ru/build_lists/873223
Comment 1 Vladimir Potapov 2013-01-15 16:12:54 MSK
1 установочных транзакций не удались

Во время установки возникла ошибка:

файл /usr/lib64/girepository-1.0/Rest-0.7.typelib из устанавливаемого пакета lib64rest0.7_0-0.7.90-1.x86_64 конфликтует с файлом из пакета lib64rest-gir0.7-0.7.12-2.x86_64

файл /usr/lib64/girepository-1.0/RestExtras-0.7.typelib из устанавливаемого пакета lib64rest0.7_0-0.7.90-1.x86_64 конфликтует с файлом из пакета lib64rest-gir0.7-0.7.12-2.x86_64
Comment 2 Arkady L. Shane 2013-01-16 21:25:08 MSK
Так, я ещё раз проверил репозитории. lib64rest-gir0.7 находится в contrib. А в main такого пакета нет. И в main вообще 0.7.10.

./contrib/release/lib64rest0.7_0-0.7.12-2-rosa2012.1.x86_64.rpm
./contrib/release/lib64rest-gir0.7-0.7.12-2-rosa2012.1.x86_64.rpm
./contrib/release/lib64rest-devel-0.7.12-2-rosa2012.1.x86_64.rpm
./main/release/librest-doc-0.7.10-1-rosa2012.1.x86_64.rpm
./main/release/lib64rest0.7_0-0.7.10-1-rosa2012.1.x86_64.rpm
./main/release/lib64rest-devel-0.7.10-1-rosa2012.1.x86_64.rpm
./main/release/librest-debuginfo-0.7.10-1-rosa2012.1.x86_64.rpm

Из contrib мы удалим.

Ещё раз проверьте, пожалуйста.
Comment 3 Vladimir Potapov 2013-01-17 13:13:40 MSK
Perhaps, first remove the library from contrib, and then check it out?
Comment 4 Arkady L. Shane 2013-01-17 13:55:35 MSK
Package has been removed from contrib (from abf repo exactly).
Comment 5 Vladimir Potapov 2013-01-18 07:03:13 MSK
I can't run gnome-documents (before and after update) 
$ gnome-documents
 JS ERROR: !!!   Exception was: Error: Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found
    JS ERROR: !!!     message = '"Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found"'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-documents/js/manager.js"'
    JS ERROR: !!!     lineNumber = '22'
    JS ERROR: !!!     stack = '"@/usr/share/gnome-documents/js/manager.js:22
"'
    JS ERROR: !!!   Exception was: Error: Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found
    JS ERROR: !!!     message = '"Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found"'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-documents/js/manager.js"'
    JS ERROR: !!!     lineNumber = '22'
    JS ERROR: !!!     stack = '"@/usr/share/gnome-documents/js/manager.js:22
"'
    JS ERROR: !!!   Exception was: Error: Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found
    JS ERROR: !!!     message = '"Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found"'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-documents/js/manager.js"'
    JS ERROR: !!!     lineNumber = '22'
    JS ERROR: !!!     stack = '"@/usr/share/gnome-documents/js/manager.js:22
"'
    JS ERROR: !!!   Exception was: Error: Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found
    JS ERROR: !!!     message = '"Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found"'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-documents/js/manager.js"'
    JS ERROR: !!!     lineNumber = '22'
    JS ERROR: !!!     stack = '"@/usr/share/gnome-documents/js/manager.js:22
"'
    JS ERROR: !!!   Exception was: Error: Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found
    JS ERROR: !!!     message = '"Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found"'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-documents/js/manager.js"'
    JS ERROR: !!!     lineNumber = '22'
    JS ERROR: !!!     stack = '"@/usr/share/gnome-documents/js/manager.js:22
"'
    JS ERROR: !!!   Exception was: Error: Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found
    JS ERROR: !!!     message = '"Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found"'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-documents/js/manager.js"'
    JS ERROR: !!!     lineNumber = '22'
    JS ERROR: !!!     stack = '"@/usr/share/gnome-documents/js/manager.js:22
"'
Error: Requiring GdPrivate, version none: Typelib file for namespace 'Soup', version '2.4' not found
Comment 6 Arkady L. Shane 2013-01-18 12:19:22 MSK
Please, install lib64soup-gir2.4

If gnome-document will start, I will add this requirement to its rpm packages.
Comment 7 Arkady L. Shane 2013-01-18 15:37:33 MSK
Please, test this build of gnome-documents:
https://abf.rosalinux.ru/build_lists/899868
https://abf.rosalinux.ru/build_lists/899867
Comment 8 Vladimir Potapov 2013-01-19 08:05:34 MSK
gnome-documents-3.6.2-1-rosa2012.1
librest0.7_0-0.7.90-1-rosa2012.1
******************* Advisory ****************
+ This update fix a gnome-documents start error
+ Update gnome-documents to 3.6.2. This release needs new librest, so librest was updated to 0.7.90.
*********************************************
QA Verified