Bug 1397 - BCM4313 error bug on dmesg
: BCM4313 error bug on dmesg
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-06 02:00 MSK by altadeos
Modified: 2014-01-19 14:59 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description altadeos 2013-01-06 02:00:13 MSK
Description of problem:
I have a bug that sometimes appear when i look at dmesg but nothing special happens

message is this:
[ 1812.857629] ------------[ cut here ]------------
[ 1812.857647] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]()
[ 1812.857649] Hardware name: EasyNote TE11HC
[ 1812.857650] Modules linked in: fuse bnep bluetooth af_packet snd_hda_codec_hdmi snd_hda_codec_realtek arc4 b43 rng_core ssb pcmcia pcmcia_core brcmsmac cordic brcmutil mac80211 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_hda_intel media snd_hda_codec acer_wmi iTCO_wdt snd_pcm sparse_keymap snd_page_alloc snd_hwdep kvm_intel cfg80211 kvm iTCO_vendor_support rfkill snd_timer acpi_cpufreq battery ac mperf processor mei i2c_i801 joydev evdev snd bcma soundcore wmi lpc_ich coretemp binfmt_misc autofs4 ext4 jbd2 crc16 sd_mod sr_mod crc_t10dif ahci libahci libata scsi_mod tg3 sdhci_pci crc32c_intel sdhci mmc_core ehci_hcd usbcore libphy usb_common i915 video button i2c_algo_bit drm_kms_helper drm i2c_core sunrpc ipv6 dm_mirror dm_region_hash dm_log dm_mod [last unloaded: microcode]

[ 1812.857718] Pid: 14704, comm: kworker/u:2 Not tainted 3.6.10-nrj-desktop-1rosa #1
[ 1812.857720] Call Trace:
[ 1812.857728]  [<c013bb62>] warn_slowpath_common+0x72/0xa0
[ 1812.857738]  [<f4ea382a>] ? brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]
[ 1812.857745]  [<f4ea382a>] ? brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]
[ 1812.857749]  [<c013bbb2>] warn_slowpath_null+0x22/0x30
[ 1812.857756]  [<f4ea382a>] brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]
[ 1812.857762]  [<f4e975f0>] brcms_ops_flush+0x30/0x50 [brcmsmac]
[ 1812.857776]  [<f49890bd>] ieee80211_scan_work+0x29d/0x530 [mac80211]
[ 1812.857782]  [<c0156450>] process_one_work+0x120/0x420
[ 1812.857785]  [<c01575c4>] ? manage_workers+0xf4/0x2a0
[ 1812.857789]  [<c0154b50>] ? need_to_create_worker+0x10/0x30
[ 1812.857800]  [<f4988e20>] ? ieee80211_run_deferred_scan+0x70/0x70 [mac80211]
[ 1812.857804]  [<c0157881>] worker_thread+0x111/0x3b0
[ 1812.857809]  [<c04f58ed>] ? _raw_spin_unlock_irqrestore+0x2d/0x40
[ 1812.857863]  [<c016825e>] ? complete+0x4e/0x60
[ 1812.857867]  [<c0157770>] ? manage_workers+0x2a0/0x2a0
[ 1812.857870]  [<c015c352>] kthread+0x72/0x80
[ 1812.857874]  [<c015c2e0>] ? kthread_freezable_should_stop+0x50/0x50
[ 1812.857878]  [<c04fbefe>] kernel_thread_helper+0x6/0x10
[ 1812.857880] ---[ end trace ff1f4c18e8d01f9e ]---

Could someone please correct it?
Best regards.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 altadeos 2013-01-24 00:22:43 MSK
Hello,

Do you have more informations about this message?
I have this sometimes but don't know what is it.
Do you need more informations to help me?

Best regards.
Comment 2 Eugene Shatokhin 2013-01-24 11:00:44 MSK
A kernel warning is usually not a symptom of bugs, but sometimes it may be. Of course, it needs to be analyzed.

1. Could you attach the entire output of dmesg here? If brcmsmac driver had output some diagnostic messages before that warning, they could be helpful.

2. Is it 32-bit or 64-bit system?

3. Any information about what was done when this warning triggered could be valuable here. Did you download files or just browsed the web, or did something else? Or, perhaps this occurs only when the wireless connection is just being started, etc.? Feel free to post here whatever else you think could be relevant.
Comment 3 Eugene Shatokhin 2013-01-24 11:27:01 MSK
It seems, we are not the only ones to encounter this problem:
https://bugzilla.redhat.com/show_bug.cgi?id=799168
Comment 4 Alexander Burmashev 2013-01-30 14:39:27 MSK
New kernel with fix to this issue was pushed to the QA check
http://bugs.rosalinux.ru/show_bug.cgi?id=1543
Comment 5 altadeos 2014-01-19 14:59:13 MSK
Hello, 

since a lot of time i don't see this bug anymore.
I think it can be close.

Best regards