Bug 1394 - broadcom wi-fi flood /var/log/messages
: broadcom wi-fi flood /var/log/messages
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Alexander Burmashev
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-05 14:01 MSK by FirstLevel
Modified: 2013-11-22 00:09 MSK (History)
4 users (show)

See Also:
RPM Package: kernel-nrj-desktop-3.6.10-1rosa-1-1-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
wi-fi.txt (58.38 KB, text/plain)
2013-01-05 14:01 MSK, FirstLevel
Details
diag.txt (5.95 KB, text/plain)
2013-01-05 14:01 MSK, FirstLevel
Details
new-wl.txt (2.32 KB, text/plain)
2013-02-03 15:33 MSK, FirstLevel
Details
new-messages.txt (10.12 KB, text/plain)
2013-02-03 15:33 MSK, FirstLevel
Details
error-while-see-nm.txt (4.19 KB, text/plain)
2013-02-03 15:45 MSK, FirstLevel
Details
error-new.png (390.40 KB, image/png)
2013-02-03 15:45 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-01-05 14:01:06 MSK
Created attachment 1023 [details]
wi-fi.txt

Description of problem:
I have installed  ROSA 2012.1 Fresh x64 on laptop HP ProBook 6465b.
And I see that my wireless Broadcom : ‎BCM4313 802.11b/g/n Wireless LAN Controller flood information to  /var/log/messages/ Example:  wi-fi.txt. Dianostic output in diag.txt.
Also I see that after such message "brcms_c_sendampdu: No fifo space  !!" there are no information transmitted by wireless adapter (wi-fi connection is active and ip configuration ).
Such message is repeated more when I download sme torrent file "brcms_c_sendampdu: No fifo space  !!".
I had no such problem with laptop on ROSA 2012 LTS

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-01-05 14:01:32 MSK
Created attachment 1024 [details]
diag.txt
Comment 2 Alexander Burmashev 2013-01-09 12:47:48 MSK
i can confirm that this problem really exist.
As a temporary workaround - can you try using broadcom-wl driver ?
Comment 3 FirstLevel 2013-01-09 13:14:47 MSK
(In reply to comment #2)
> i can confirm that this problem really exist.
> As a temporary workaround - can you try using broadcom-wl driver ?

Can You give me more detailed recommendations?
Comment 4 Eugene Shatokhin 2013-01-09 14:11:38 MSK
(In reply to comment #3)
> Can You give me more detailed recommendations?

The proprietary driver is in 'dkms-broadcom-wl' package available in the official "non-free" repository.

The easiest way is if the laptop also has a wired network connection. Then:

1. Unload the currently used drivers for the WiFi adapter as they may interfere with the installation, (as root):

 # modprobe -r brcmsmac b43 bcma

If modprobe complains about missing modules, just ignore it.

2. Install the driver:

 # urpmi dkms-broadcom-wl

3. Reboot (or restart NetworkManager service) and then check if WiFi is working.

If the laptop has no other network adapter or it is not possible to use other adapters, one can download the RPM package (dkms-broadcom-wl-<...>-rosa2012.1.x86_64.rpm) from the repository first:
http://abf.rosalinux.ru/downloads/rosa2012.1/repository/x86_64/non-free/updates/

Then do the same steps as above.
Comment 5 FirstLevel 2013-01-09 21:07:54 MSK
(In reply to comment #4)
> (In reply to comment #3)
> > Can You give me more detailed recommendations?
> 
> The proprietary driver is in 'dkms-broadcom-wl' package available in the
> official "non-free" repository.
> 
> The easiest way is if the laptop also has a wired network connection. Then:
> 
> 1. Unload the currently used drivers for the WiFi adapter as they may
> interfere with the installation, (as root):
> 
>  # modprobe -r brcmsmac b43 bcma
> 
> If modprobe complains about missing modules, just ignore it.
> 
> 2. Install the driver:
> 
>  # urpmi dkms-broadcom-wl
> 
> 3. Reboot (or restart NetworkManager service) and then check if WiFi is
> working.
> 
> If the laptop has no other network adapter or it is not possible to use
> other adapters, one can download the RPM package
> (dkms-broadcom-wl-<...>-rosa2012.1.x86_64.rpm) from the repository first:
> http://abf.rosalinux.ru/downloads/rosa2012.1/repository/x86_64/non-free/
> updates/
> 
> Then do the same steps as above.

Thanks I did it. I'll test such configurations for few days
Comment 6 FirstLevel 2013-01-11 13:45:27 MSK
After I have changed the driver I had not situation when transmission is stopped. It is good. But I have another repeated error in /var/log/messages
Jan 11 13:37:13 freshx32 kernel: [  613.386398] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:13 freshx32 kernel: [  613.386406] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:13 freshx32 kernel: [  613.386604] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:13 freshx32 kernel: [  613.386609] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:15 freshx32 kernel: [  615.383834] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:15 freshx32 kernel: [  615.383843] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:17 freshx32 kernel: [  617.382289] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:17 freshx32 kernel: [  617.382293] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:19 freshx32 kernel: [  619.379837] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:19 freshx32 kernel: [  619.379842] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:19 freshx32 kernel: [  619.380371] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:19 freshx32 kernel: [  619.380374] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:21 freshx32 kernel: [  621.378014] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:21 freshx32 kernel: [  621.378018] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:23 freshx32 kernel: [  623.376126] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:23 freshx32 kernel: [  623.376136] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:25 freshx32 kernel: [  625.373952] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:25 freshx32 kernel: [  625.373960] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:25 freshx32 kernel: [  625.374198] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:25 freshx32 kernel: [  625.374203] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:27 freshx32 kernel: [  627.371332] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:27 freshx32 kernel: [  627.371361] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:29 freshx32 kernel: [  629.369160] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:29 freshx32 kernel: [  629.369164] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:31 freshx32 kernel: [  631.367314] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:31 freshx32 kernel: [  631.367318] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:31 freshx32 kernel: [  631.367393] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:31 freshx32 kernel: [  631.367394] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:33 freshx32 kernel: [  633.365598] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:33 freshx32 kernel: [  633.365602] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:35 freshx32 kernel: [  635.362963] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:35 freshx32 kernel: [  635.362968] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:37 freshx32 kernel: [  637.361600] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:37 freshx32 kernel: [  637.361608] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Jan 11 13:37:37 freshx32 kernel: [  637.361793] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
Jan 11 13:37:37 freshx32 kernel: [  637.361798] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
Comment 7 Alexander Burmashev 2013-01-11 14:26:58 MSK
First bug should be fixed by new  brcmsmac patch that i ported recently. Kernel with patched driver should be ready soon.

Second bug is a separate problem in broadcom-wl.
Comment 8 Alexander Burmashev 2013-01-14 18:11:42 MSK
Concerning the first bug and patched brcmsmac driver:
try this patched kernel 
x86_64
https://abf.rosalinux.ru/build_lists/873515
i586
https://abf.rosalinux.ru/build_lists/873514

Notice please that it does not fix second bug with broadcom-wl. To test that bug is fixed i guess you will need to remove broadcom-wl after kernel update.
Comment 9 Alexander Burmashev 2013-01-29 13:07:37 MSK
I built broadcom-wl with new ioctl patch, that may fix the problem.
After the install reboot the system to ensure that new, fixed driver is loaded

http://abf.rosalinux.ru/downloads/rosa2012.1/container/937460/i586/non-free/release/

http://abf.rosalinux.ru/downloads/rosa2012.1/container/937461/x86_64/non-free/release/
Comment 10 Alexander Burmashev 2013-01-31 14:27:42 MSK
ping
Comment 11 FirstLevel 2013-02-01 09:31:29 MSK
(In reply to comment #10)
> ping

Sorry, I have no time for testing now. But I'll try to test for two weeks.
Sorry again
Comment 12 FirstLevel 2013-02-03 15:33:02 MSK
(In reply to comment #10)
> ping
I have installed dkms-broadcom-wl-5.100.82.112-8-rosa2012.1.x86_64.rpm
Some diagnostic information is attached in new-wl.txt
I have many strings from wi-fi in /var/log/messages too new-messages.txt
I'll analyze the disconnect of wireless connection with new module...
Comment 13 FirstLevel 2013-02-03 15:33:22 MSK
Created attachment 1136 [details]
new-wl.txt
Comment 14 FirstLevel 2013-02-03 15:33:37 MSK
Created attachment 1137 [details]
new-messages.txt
Comment 15 Alexander Burmashev 2013-02-03 15:43:06 MSK
yep, that broadcom-wl is faulty, i already created a separate bug request with the correct one.
Comment 16 FirstLevel 2013-02-03 15:44:56 MSK
I have discovered such thing.
While I see on the status of wireless adapter in NetworkManager (see error-new.png) I have error error-while-see-nm.txt in /var/log/messages
As I stop see in NetworkManager - such error strings is not appeared in messages file.
Comment 17 FirstLevel 2013-02-03 15:45:14 MSK
Created attachment 1138 [details]
error-while-see-nm.txt
Comment 18 FirstLevel 2013-02-03 15:45:48 MSK
Created attachment 1139 [details]
error-new.png
Comment 19 FirstLevel 2013-02-03 15:47:21 MSK
(In reply to comment #15)
> yep, that broadcom-wl is faulty, i already created a separate bug request
> with the correct one.

Hmm.. What module should I use now? Could You write number of Your new bug?
Comment 20 Postnikov Dmitry 2013-02-03 15:58:11 MSK
(In reply to comment #19)
> (In reply to comment #15)
> > yep, that broadcom-wl is faulty, i already created a separate bug request
> > with the correct one.
> 
> Hmm.. What module should I use now? Could You write number of Your new bug?

Try the latest package from Bug 1542. There all fix.
Comment 21 FirstLevel 2013-02-04 10:06:30 MSK
(In reply to comment #20)
> (In reply to comment #19)
> > (In reply to comment #15)
> > > yep, that broadcom-wl is faulty, i already created a separate bug request
> > > with the correct one.
> > 
> > Hmm.. What module should I use now? Could You write number of Your new bug?
> 
> Try the latest package from Bug 1542. There all fix.

By Your words "At the moment, everything is clean in syslog. But connection to wifi networks is not stable. Connects with 3-5 times only. And in work process no comments, works good."
I think I am waiting for stable driver or go to proprietary solution
Comment 22 Denis Silakov 2013-11-22 00:09:11 MSK
*** Bug 1455 has been marked as a duplicate of this bug. ***