Bug 139 - warnings when installing a rpm-build package
: warnings when installing a rpm-build package
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 17:13 MSD by Denis Koryavov
Modified: 2012-06-09 19:10 MSD (History)
2 users (show)

See Also:
RPM Package: rpm-build-5.3.12-0.20110712.4-rosa.lts2012.0.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Koryavov 2012-04-27 17:13:33 MSD
Description of problem:

While installing a rpm-build package I saw the next errors:

    13/16: rpm-build             warning: пользователь rpm не существует - используется root
warning: группа rpm не существует - используется root
warning: пользователь rpm не существует - используется root
warning: группа rpm не существует - используется root
warning: пользователь rpm не существует - используется root
warning: группа rpm не существует - используется root
##warning: пользователь rpm не существует - используется root



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. # urpmi rpm-build
2.
3.
Comment 1 Denis Koryavov 2012-06-08 23:45:50 MSD
up
Comment 2 Denis Silakov 2012-06-09 19:06:37 MSD
It seems that this problem existed in some preliminary ISO images, but was fixed in the release one.

Now the system on livecd already has the 'rpm' group and installation of rpm-build in a freshly installed system goes without any warnings.
Comment 3 Alexander Burmashev 2012-06-09 19:10:50 MSD
This problem still may persist while building iso images ( or generating a clean chroot ).
This happens because of incorrect handling of requires(pre)/(post) in some cases which may lead to rpm-build installing before the rpm. Similar problems happened with avahi package and some others.

Generally user will not notice it, it is more a reminder for people, who build iso images or work in self made chroot.