Bug 1387 - No sound with HDMI port on my Radeon HD3650 mobility (with free drivers because Kernel>3.2)
: No sound with HDMI port on my Radeon HD3650 mobility (with free drivers becau...
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-02 13:19 MSK by mtzseb
Modified: 2013-01-16 01:33 MSK (History)
0 users

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mtzseb 2013-01-02 13:19:24 MSK
Description of problem:
I have no sound with my HDMI port, however the image is OK.
I use it for the VLC player with HDMI audio output alsa, because the reader does not allow ROSA. The output analog audio is OK. With smplayer, videos scroll too quickly and without sound.
With Kernels <= 3.2, I used the fglrx catalyst drivers, that worked perfectly.
I tested the solution for adding the entry "radeon.audio = 1" in Grub2 but without success.
With rosa-mediaplayer or smplayer, Video scrolls too quickly, but still no sound.
With vlc, I receive an error message, also without sound.
"The audio output failed:
Audio device 'hdmi: CARD = HDMI, DEV = 0 "can not be used:
Device or resource busy. "
Finally, the process systemd and systemd-journald me take 100% of CPU time. So, I quickly turned the grub entry, and my problem is its over!


Version-Release number of selected component (if applicable):
Rosa Desktop 2012 "fresh", lib64drm_radeon1 2.4.40, radeon-firmware 20120322, Kernel 3.6.10, alsa 1.0.26, pulseaudio 2.1, rosa mediaplayer 1.5.1, smplayer 0.8.3, vlc 2.0.4

How reproducible:
-

Steps to Reproduce:
1.-
2.-
3.-
Comment 1 mtzseb 2013-01-10 13:19:02 MSK
Is it possible to package a version of fglrx which retrogress x-server to the latest version compatible with Catalyst 12.6 (1.12.4) as does the repository for Kubuntu ? (https://launchpad.net/~makson96/+archive/fglrx)
It should solve my sound problem with HDMI port.
Comment 2 mtzseb 2013-01-15 11:53:51 MSK
When I try to play a video with the HDMI sound output, VLC tells me that the device is busy, smplayer reads me my videos without sound, but too fast (very strange!)
I don't know what to do ... only using analog output and a simple converter jack / rca ... Good Bye Dolby Digital !
Comment 3 mtzseb 2013-01-16 01:33:33 MSK
Everything works fine now on Rosa. Certainly an update yesterday and today (because I've had several) that resolved a conflict. So, this system approaches perfection. My best linux distro I installed on my PC! Bug solved!