Bug 1385 - Unable to see any image by webcam or microscope
: Unable to see any image by webcam or microscope
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Arkady L. Shane
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-01 14:34 MSK by Davide Garatti
Modified: 2013-01-15 14:47 MSK (History)
2 users (show)

See Also:
RPM Package: cheese-3.6.2-1-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
cheese image problem (11.42 KB, image/png)
2013-01-01 14:34 MSK, Davide Garatti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Davide Garatti 2013-01-01 14:34:38 MSK
Created attachment 1016 [details]
cheese image problem

Description of problem:
As you can see in attached image, cheese windows is not able to show any image by webcam and microscope, please note that both device are OK and it is possible to use them with Kamoso, VLC.

I tried cheese on Rosa Marathon with the same hardware and all seems to be OK.
but I noted who Cheese version on Rosa Marathon is 2.32 while on Desktop 2012 is 3.6.2.


Starting cheese in terminal we find the following warning and errors

--------------------------------------
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

(cheese:5256): GStreamer-CRITICAL **: gst_preset_load_preset: assertion `GST_IS_PRESET (preset)' failed

(cheese:5256): cheese-WARNING **: Can't find vp8enc preset: "Profile Realtime", using alternate preset: "Cheese Realtime". If you see this, make a bug report!

(cheese:5256): GStreamer-CRITICAL **: gst_preset_load_preset: assertion `GST_IS_PRESET (preset)' failed

(cheese:5256): cheese-WARNING **: Can't find vp8enc preset: "Cheese Realtime", creating new userspace preset.

(cheese:5256): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(cheese:5256): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(cheese:5256): GStreamer-CRITICAL **: gst_preset_save_preset: assertion `GST_IS_PRESET (preset)' failed

(cheese:5256): GStreamer-CRITICAL **: gst_object_unref: assertion `object != NULL' failed

(cheese:5256): cheese-WARNING **: Nell'installazione di GStreamer in uso manca un plugin.

-----------------------------------

How reproducible:
I think should be sufficient to try with any device.
Comment 1 Arkady L. Shane 2013-01-10 19:25:47 MSK
OK. The problem was in gstreamer1.0-plugins-good. It was built without vp8 plugin.

Please see http://bugs.rosalinux.ru/show_bug.cgi?id=1418 to quick fix problem.
Comment 2 Davide Garatti 2013-01-11 01:05:22 MSK
Hi, 
I have updated the package:
gstreamer1.0-plugins-good-1.0.3-2-rosa2012.1.x86_64.rpm
and installed
streamer1.0-vp8-1.0.3-2-rosa2012.1.x86_64.rpm

now the program works correctly with both devices

Thanks a lot