Bug 138 - Wrong right for file ~/.face.icon
: Wrong right for file ~/.face.icon
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal major
: 2012 Marathon Final
Assigned To: Konstantin Vlasov
: ROSA Linux Bugs
https://abf.rosalinux.ru/import/drakx...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 15:49 MSD by Denis Koryavov
Modified: 2012-06-19 21:49 MSD (History)
3 users (show)

See Also:
RPM Package: drakxtools-backend
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Koryavov 2012-04-27 15:49:56 MSD
Description of problem:
This is our old bug. File ~/.face.icon has wrong access right (root:root) after install. It is not good. This file should have the same rights as other files in user home directory.

How reproducible:

Always.

Steps to Reproduce:
1. Install RM2012 RC1. Look at file ~/.face.icon.
Comment 1 Aleksandr Kazantcev 2012-04-27 16:01:42 MSD
Yeh. We missed some patch.
Comment 2 Aleksandr Kazantcev 2012-04-27 16:14:11 MSD
But no - all patch is implеment. If you use clear install?
Comment 3 Denis Koryavov 2012-04-27 16:24:31 MSD
Yes. This problem appears when we applied the patch that created by our devs. :)
Comment 4 Denis Koryavov 2012-05-04 11:47:47 MSD
What about this bug?
Comment 5 Konstantin Vlasov 2012-05-15 20:11:41 MSD
https://abf.rosalinux.ru/build_lists/548922
https://abf.rosalinux.ru/build_lists/548921

advisory: Fixed setting owner for ~/.face.icon when creating new user.

At the moment, there was a temporary and not very nice solution for the bug which just set permissions to the file as 0666 (the owner of the file however remained root:root). Though it does allow to access the file to the user, it also allows to do the same to everyone else in the system. I implemented a fix where the correct owner is set instead of giving permissions to everyone.

The fix can be tested via /usr/sbin/adduserdrake.
Comment 6 Vladimir Potapov 2012-05-18 17:30:36 MSD
I don't see this problem in release (x64 EE). It`s fixed?
Comment 7 Konstantin Vlasov 2012-05-18 20:03:07 MSD
(In reply to comment #6)
> I don't see this problem in release (x64 EE). It`s fixed?

No, it's not. Well, I mean it is, but the fix is still waiting for approval.

You can see it when you install EE from disk: the first user (that is created by the installer) will have .face.icon owned by root:root. For other users (created from the running system via RCC -> Manage users) a different method is used, so this problem will not appear. However, you can also create new users via adduserdrake which calls the same functions the installer does, so in this case .face.icon will be owned by root too.
Comment 8 Vladimir Potapov 2012-05-19 17:39:38 MSD
Ok, I reproduced this bug.
Please: 
1) Write full package name for tesing (in comments or in RPM Package field)
2) Create packages for all tested supported architectures (x86 and x64)
3) In the packages must be filled all user-visible fields (for example: files, changelog etc)
Comment 9 Alexander Burmashev 2012-05-21 15:29:48 MSD
Vladimir please provide more details about #3, what details do you need and where should they be filled ?
Comment 10 Vladimir Potapov 2012-05-21 16:15:41 MSD
Details sent by mail
Comment 11 Alexander Burmashev 2012-05-21 16:16:38 MSD
I got it, the problem is that there is currently no xml metadata in containers.
For now you should test packages without it, it should be fixed a bit later.
Comment 12 Konstantin Vlasov 2012-05-21 16:20:03 MSD
(In reply to comment #8)
> Ok, I reproduced this bug.
> Please: 
> 1) Write full package name for tesing (in comments or in RPM Package field)

drakxtools-backend

> 2) Create packages for all tested supported architectures (x86 and x64)

I've built packages for both architectures from the beginning. Now, according to the updated policy, I rebuilt the packages in the 'import' instead of the private repo:
https://abf.rosalinux.ru/build_lists/549609 - i586
https://abf.rosalinux.ru/build_lists/549610 - x86_64
Comment 13 Vladimir Potapov 2012-05-22 16:49:50 MSD
drakxtools-backend  version 13.61-9
******** Advisory *********
Fixed setting owner for ~/.face.icon when creating new user.
**************************
QA Verified

WBR Vladimir Potapov
QA Team
Comment 14 Pavel Shved 2012-06-19 21:49:01 MSD
Massively change status of published updates.  From now on, the status for published update requests will be VERIFIED.