Bug 1372 - Cpupower.service fails to start
: Cpupower.service fails to start
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-29 19:16 MSK by Giovanni Mariani
Modified: 2013-04-26 12:37 MSD (History)
2 users (show)

See Also:
RPM Package: cpupower-3.6.10-1-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2012-12-29 19:16:16 MSK
Description of problem:
A default install of Fresh 2012.1 includes the cpupower package; however it does not work out-of-box because we don't pass any command line to the program binary...

The cpupower.service file shows that cpupower is called with the command line options contained in two env variables: CPUPOWER_START_OPTS and CPUPOWER_STOP_OPTS. Those should be defined in /etc/sysconfig/cpupower but actually they aren't (they are commented out in that file), so we end up passing to the program binary an empty command line both at the start and the stop of the cpupower.service and then the program then simply prints a message about the its usage and does nothing, hence making the systemd service to fail
(you cant also directly test this in a root console: you just launch cpupower without arguments and look...).

We need to make sure that /etc/sysconfig/cpupower contains some valid option when installing the cpupower package.

Version-Release number of selected component (if applicable):
3.6.10-1-rosa2012.1

How reproducible:
Always

Steps to Reproduce:
1. Do a fresh install
2. Reboot
3. Look at the output of "systemctl --failed"
Comment 1 Aleksandr Kazantcev 2012-12-29 19:20:12 MSK
It's not a bug - only trash output.

We don't disable cpupower service because it's need to default ondemand profile in kernel.

But for default we don't use cpupower config file - if you need another governor you may simple uncoment it line. Systemd not support this state (config file not present but service did).

In future we go output in syslog only