Bug 1371 - Please build fglrx-legacy package for the ROSA Desktop.Fresh 2012
: Please build fglrx-legacy package for the ROSA Desktop.Fresh 2012
Status: RESOLVED WONTFIX
Product: Desktop Features
Classification: ROSA Desktop
Component: All
: unspecified
: All Linux
: Normal enhancement
: ---
Assigned To: Eugene Shatokhin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-29 15:24 MSK by Denis Koryavov
Modified: 2015-04-03 10:10 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
make.log (1.44 KB, text/x-log)
2012-12-29 15:24 MSK, Denis Koryavov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Koryavov 2012-12-29 15:24:38 MSK
Created attachment 1011 [details]
make.log

I have Radeon HD3200 videocard in my desktop. This card is not supported by AMD anymore and new fglrx packages in the RD2012.Fresh repositories do not have drivers for this card. 

As far as I know a driver for the my video card can be found in fglrx-legacy package. I ve tried to install this package from here

https://abf.rosalinux.ru/build_lists/871404
https://abf.rosalinux.ru/build_lists/871405


but got an error:

# urpmi dkms-fglrx-legacy

    http://abf.rosalinux.ru/downloads/import_personal/container/fglrx-legacy-871405/RPMS/dkms-fglrx-legacy-8.97.100.3-1-rosa2012.1.x86_64.rpm
устанавливается dkms-fglrx-legacy-8.97.100.3-1-rosa2012.1.x86_64.rpm из /var/cache/urpmi/rpms                                                                                                                     
Подготовка...                    ################################################################################################################################################################################
      1/1: dkms-fglrx-legacy     ################################################################################################################################################################################

Creating symlink /var/lib/dkms/fglrx-legacy/8.97.100.3-1/source ->
                 /usr/src/fglrx-legacy-8.97.100.3-1

DKMS: add Completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
sh make.sh --uname_r=3.6.10-nrj-desktop-1rosa --uname_v=none --kernel-dir=/lib/modules/3.6.10-nrj-desktop-1rosa/build --no-proc-probe --norootcheck.....(bad exit status: 1)

Error! Bad return status for module build on kernel: 3.6.10-nrj-desktop-1rosa (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/fglrx-legacy/8.97.100.3-1/build/ for more information.
Comment 1 Aleksandr Kazantcev 2012-12-29 15:28:49 MSK
fglrx-legacy work only with X-Server 12 max. Not possible using it with X-Server > 12... We disable autodetect it in XFdrake and set it for free driver only...

May be AMD build update driver in future - but now it not works..
Comment 2 Denis Koryavov 2013-02-13 00:14:21 MSK
Why this bug was closed as "WONTFIX" without any explanation?
Comment 3 Aleksandr Kazantcev 2013-02-13 00:17:31 MSK
AMD released 'X-Server 13 compartible driver', but it not work anymore :(
We did not has right information when AMD released working driver...
Comment 4 Aleksandr Kazantcev 2013-02-13 00:18:32 MSK
See bug http://bugs.rosalinux.ru/show_bug.cgi?id=1532
Comment 5 Denis Koryavov 2013-02-13 00:23:46 MSK
OK, I understand the reason, but how we can be sure that guys from AMD will not release a new version of fglrx-legacy driver with support of X Server 1.13?
Comment 6 Denis Silakov 2015-04-02 22:20:02 MSD
Do we have any need in building fglrx-legacy now? Or can we just close this bug as "wontfix"?
Comment 7 Eugene Shatokhin 2015-04-03 10:10:04 MSD
Even if fglrx-legacy was needed, it would be very difficult to build and maintain it for the current versions of ROSA.

Kernels 3.10+ and Xorg 1.15+ are still not supported there. AMD seems to have no plans of providing such support.

We could try to patch the driver manually but it would be too time consuming and error-prone, esp. future maintenance. Hardly worth the effort.