Bug 137 - Emergency mode at startup
: Emergency mode at startup
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: i586 Linux
: High major
: 2012 Marathon RP1
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 23:08 MSD by Postnikov Dmitry
Modified: 2012-12-25 15:11 MSK (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Emergency mode (2.39 MB, image/jpeg)
2012-04-26 23:08 MSD, Postnikov Dmitry
Details
att1 (43.48 KB, image/png)
2012-04-27 00:19 MSD, Postnikov Dmitry
Details
att2 (52.83 KB, image/png)
2012-04-27 00:20 MSD, Postnikov Dmitry
Details
att3 (16.31 KB, image/png)
2012-04-27 00:20 MSD, Postnikov Dmitry
Details
att4 (52.93 KB, image/png)
2012-04-27 00:20 MSD, Postnikov Dmitry
Details
att5 (61.14 KB, image/png)
2012-04-27 00:20 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2012-04-26 23:08:08 MSD
Created attachment 71 [details]
Emergency mode

Description of problem:
EN:
In 183, 190, 193, 211, 218, 225, 240, 248, 250th iso image. If you are installing the system, when the leaves form a hard disk partitioning, select the "manual mode". And specify which mount the hard drive. Next, after the first phase of installation, after reboot the message goes: "Welcome emergency mode. Use @systemctl default" or ^D...". If you are installing the system, when the leaves form a hard disk partitioning, select "Use existing partitions". Next, after the first phase of installation, after reboot everything is fine and the system then install and run.
See attachment

RU:
В 183, 190, 193, 211, 218, 225, 240, 248, 250ом образах ISO. Если при установке системы, когда выходит форма разбивки жесткого диска, выбрать "ручной режим". И указать куда монтировать разделы винчестера. Дальше, после первой фазы установки, после перезагрузки выходит сообщение: "Welcome emergency mode. Use @systemctl default" or ^D...". Если при установке системы, когда выходит форма разбивки жесткого диска, выбрать "использовать существующие разделы". Дальше, после первой фазы установки, после перезагрузки все хорошо и система дальше устанавливается и работает.
(См.скрин)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Alexander Burmashev 2012-04-26 23:20:57 MSD
checking it right now, thanks for the report.
Comment 2 Postnikov Dmitry 2012-04-26 23:23:28 MSD
I tested today on 250th iso from 24apr2012.
Comment 3 Alexander Burmashev 2012-04-26 23:27:23 MSD
ACtually i have a guess why it could happen.
If you chose already created partitions and did not format it new files were written on the previous.
I find this appropriate and expected.
Comment 4 Alexander Burmashev 2012-04-26 23:31:41 MSD
The main question is - while installing did you uncheck the "format drive" checkbox after checking the mount points ?
Comment 5 Alexander Burmashev 2012-04-26 23:43:27 MSD
2 installs:

1) Manual partitioning. Removed all the partitions, created new 2 partitions swap + /, formatted them = installs ok, boots ok

2) Manual partitioning. Did not touch the partitions, next window - formatting is checked, installs ok, boots ok.
Please provide a detailed instruction of reproducing.
Comment 6 Postnikov Dmitry 2012-04-27 00:19:12 MSD
EN:
1. I choose "Manual partitioning"
2. Choose the mode "Toggle to expert mode"
3. Opt (blue) ntfs partition with the label Disk1
4. Opt for a "mount point", put /media/win-a
5. Choose the "Options", put a "tick" in front of "user"
6. Similarly, another ntfs partition
7. Well, as usual, and Linux swap + /
8. Click "Finish."
No part of ntfs not formatted. Only partitions for Linux formats.
Next comes the installation of the first phase. And after re loading the output

If you select "Use existing partitions" and click "Next." Then the system will swap + / and format. And after the first phase of installation, after reboot everything will be OK.
(see attachment: att1, att2, att3, att4, att5 - Photos old, but the partitions have not changed since)

RU:
1. Выбираю "Ручная разметка"
2. Выбираю режим "Переключиться в режим эксперта"
3. Выбираю (голубой) раздел ntfs с меткой DISK1
4. Выбираю "Точка монтирования", ставлю /media/win-c
5. Выбираю "Параметры", ставлю "галочку" напротив user
6. Аналогично с другим ntfs разделом
7. Ну и линукс как обычно swap + /
8. Нажимаю "Готово".
Никакой раздел ntfs НЕ форматирую. Только разделы для линукс форматирую.
Далее идет установка первой фазы. И после пере загрузки выходит данное сообщение о emergency mode.

Если выбрать "Использовать существующие разделы" и нажать "Далее". То система найдет swap + / и отформатирует. И после первой фазы установки, после перезагрузки будет все ОК.

(Смотри скрины: att1, att2, att3, att4, att5 - скрины старые, но разметка диска с тех пор НЕ менялась)
Comment 7 Postnikov Dmitry 2012-04-27 00:19:46 MSD
Created attachment 72 [details]
att1
Comment 8 Postnikov Dmitry 2012-04-27 00:20:01 MSD
Created attachment 73 [details]
att2
Comment 9 Postnikov Dmitry 2012-04-27 00:20:13 MSD
Created attachment 74 [details]
att3
Comment 10 Postnikov Dmitry 2012-04-27 00:20:27 MSD
Created attachment 75 [details]
att4
Comment 11 Postnikov Dmitry 2012-04-27 00:20:40 MSD
Created attachment 76 [details]
att5
Comment 12 Alexander Burmashev 2012-04-27 00:34:20 MSD
The source of the problem is that mtab is not copied during the install.
It is not a bug, but expected behaviour.
I am marking this as wontfix, but you may report it as a feature request.
Comment 13 Postnikov Dmitry 2012-04-27 01:09:59 MSD
EN:
Why a future request???????? In the past images of works in 2011 ROSA, but in ROSA 2012 was somehow "asking functional." It is strange!
This is an obvious bug, but it seems no one wants to admit.
This function (method) should work perfectly. Otherwise, why form a disk partitioning?

RU:
Почему "Запрос функционала"???? На прошлых образах РОСА 2011 работает, а в РОСА 2012 почему-то стало "запросом функционала". Странно!
Это явный баг, но похоже его никто не хочет признать.
Эта функция (метод) должна работать идеально. Иначе, зачем форма для разметки диска существует?
Comment 14 Alexander Burmashev 2012-04-27 04:53:14 MSD
I will look at it tomorrow and will try to find a proper solution, so you can do what you want.
Comment 15 Postnikov Dmitry 2012-04-27 14:07:37 MSD
EN:
In 252th iso image. If you select "Use existing partitions" and click "Next." Then the system will swap + / and format. And after the first phase of installation, again a message of Emergency mode.
I quote:
Dependency failed. Aborted start of /media/hd
Dependency failed. Aborted start of Setup links in /boot for running kernel
Dependency failed. Aborted start of Relabel all filesystems, if necessary
Welcome emergency mode....

RU:
При установке 252го образа. Если выбрать "Использовать существующие разделы" и нажать "Далее". То система найдет swap + / и отформатирует. И после первой фазы установки, опять выдается сообщение о Emergency mode.
Цитирую:
Dependency failed. Aborted start of /media/hd
Dependency failed. Aborted start of Setup links in /boot for running kernel
Dependency failed. Aborted start of Relabel all filesystems, if necessary
Welcome emergency mode....
Comment 16 Alexander Burmashev 2012-04-27 17:18:33 MSD
Aborted start of /media/hd seems that some/media/hd hard drive was mounted at system install, is that really possible ?
Comment 17 Alexander Burmashev 2012-04-27 17:36:35 MSD
I am unable to reproduce this bug on my windows PC's, but i believe there are some cases that may lead to such behaviour.

Actually i will need a detailed instruction on reproducing this bug, so we can try to fix it.
Comment 18 Postnikov Dmitry 2012-04-27 18:01:40 MSD
EN:
Install 252th iso - error. Install 250th - NO error.When the form is to stake out the hard drive, I select "Use existing partitions" and click "Next." After installing the first phase, there is a reboot. And after a reboot, this error comes out. The partition of the hard disk the same as in the screenshots, but other dimensions.


RU:
Ставлю 252й образ - возникает эта ошибка, ставлю 250й образ - этой ошибки НЕТ, все ОК. Когда выходит форма для разбивки жесткого диска, я выбираю "Использовать существующие разделы" и нажимаю "Далее". После установки первой фазы, идет перезагрузка. И после перезагрузки выходит эта ошибка.
Состав раздело жесткого диска аналогичный как в скриншотах, только размеры другие.
Comment 19 FirstLevel 2012-05-01 12:55:59 MSD
I approve that on my laptop with manual mode of disk partitioning a have similar error.
I have tested on RC.
This error is occured if I leave existing partitions (in manual mode) or if I delete existing partitions and create new partitions (in manual mode).
I think it is very urgent error.
Comment 20 Aleksandr Kazantcev 2012-05-01 13:07:27 MSD
Manual partitioning - is add windows partition manually for install process? It's not be done!!! If you doing this, you fsck add mtab part and system give error (such with error like /media/hd).

One solutions is dropped all this change from fstab...
Comment 21 FirstLevel 2012-05-01 13:11:44 MSD
No. Manual partitioning is the one case of partitioning with wizard. If I remember it is last on the screen of partitioning wizard.
Comment 22 Aleksandr Kazantcev 2012-05-01 13:15:36 MSD
We not confirmed error from manual partitioning - only if
а) you install from USB and them out it (error from /media record in fstab, now is fix and soon in test ISO's)
b) you have badly ntfs partition and not scandisk it with try use free space
c) you manually try add win_c, win_d and other nowere in /mtab record to fstab.

As i say, one solution is drop all /media record from fstab. Only this (absent recorded partition) give this error.
Comment 23 FirstLevel 2012-05-01 13:28:22 MSD
Alex, I have installed many previous iso-images of Marathon (on same hardware and  disk configuration) and never met this error.
But when I have installed RC - an error occured.
This is my partition table


Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, всего 1465149168 секторов

Units = секторы of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disk identifier: 0x2601495c


Устр-во Загр     Начало       Конец       Блоки   Id
/dev/sda1            2048  1239541759   619769856    7  HPFS/NTFS/exFAT

/dev/sda2   *  1239541760  1240156159      307200    7  HPFS/NTFS/exFAT

/dev/sda3      1240158150  1465144064   112492957+   5  Расширенный
Partition 3 does not start on physical sector boundary.

/dev/sda5      1240158208  1461690089   110765941   83  Linux

/dev/sda6      1461692416  1465144064     1725824+  82  Linux своп / Solaris
Comment 24 Postnikov Dmitry 2012-05-01 13:43:25 MSD
We looked with Burmashev this error, because I, too, on two computers the same.
Outcome: delete the line containing the /media/hd from fstab and reboot.
Comment 25 Aleksandr Kazantcev 2012-05-01 13:46:01 MSD
For test problem pleas doing this. Setup manually partition from RC, that create error, start install and then Ctrl+F1 to console, root, and give me output

cat /etc/fstab
cat /etc/mtab

then go to Grub stage (not install) and give

cat /mnt/install/etc/fstab
cat /mnt/install/etc/mtab

problem appear after implement mtab exclude path and if today created ISO not solve it (on evening it will create), that we need drop this patch.
Comment 26 FirstLevel 2012-05-01 13:49:19 MSD
I have seen You report on rosalab forum and already tested it.
It works, but this error on the second stage of installation is very significant
Comment 27 FirstLevel 2012-05-01 13:50:46 MSD
(In reply to comment #25)
> For test problem pleas doing this. Setup manually partition from RC, that
> create error, start install and then Ctrl+F1 to console, root, and give me
> output
> 
> cat /etc/fstab
> cat /etc/mtab
> 
> then go to Grub stage (not install) and give
> 
> cat /mnt/install/etc/fstab
> cat /mnt/install/etc/mtab
> 
> problem appear after implement mtab exclude path and if today created ISO
> not solve it (on evening it will create), that we need drop this patch.

I will give You answer only tommorow
Comment 28 Postnikov Dmitry 2012-05-01 13:57:25 MSD
(In reply to comment #25)
> For test problem pleas doing this. Setup manually partition from RC, that
> create error, start install and then Ctrl+F1 to console, root, and give me
> output
> 
> cat /etc/fstab
> cat /etc/mtab
> 
> then go to Grub stage (not install) and give
> 
> cat /mnt/install/etc/fstab
> cat /mnt/install/etc/mtab
> 
> problem appear after implement mtab exclude path and if today created ISO
> not solve it (on evening it will create), that we need drop this patch.

If the question to me, all the files I gave Burmashev 3 days ago.
Comment 29 Postnikov Dmitry 2012-05-01 19:45:49 MSD
In 263th iso image this problem - no. All OK.
Comment 30 Aleksandr Kazantcev 2012-05-01 19:49:34 MSD
Thanks - i'm write now for test it in various situation - this ISO will fix also another bug and has libalsa and ktorrent + missing pt_BR lang.
Comment 31 Postnikov Dmitry 2012-05-01 19:55:41 MSD
1. I tested the 263th under the same conditions of installation. Now try to mount ntfs partition manually verified.
2. I wrote two bug 83 and 84 for Ktorrent. There were still new? (I have not found)
Comment 32 Aleksandr Kazantcev 2012-05-01 19:59:27 MSD
Ktorrent is old :( We update it as soon, as possible.

For manual ntfs mount try install and use ntfs-config. I'm will plan add it to ISO to if it properly work.
Comment 33 Postnikov Dmitry 2012-05-06 11:25:56 MSD
In 269th iso.
For installation choose "Manual partitioning" drive. To mount the linux partition and ntfs partitions. After installing ntfs partition is not mounted. In fstab is just a comment to mount ntfs partitions and mount command itself is not written.

RU:
При инсталяции выбрал "Ручная разметка" диска. Указал точки монтирования линукс раздела и ntfs разделов. После установки, ntfs разделы не примонтировались. В fstab стоит только комментарий к монтированию ntfs разделов, а самой команды монтирования НЕ написано.
-------------
[root@mindlife2 etc]# cat fstab
# Entry for /dev/sda2 :
UUID=3ead1656-d306-a408-5b48-6cec27fdb575 / ext4 defaults 1 1
# Entry for /dev/sda1 :
# Entry for /dev/sda4 :
none /proc proc defaults 0 0
# Entry for /dev/sda3 :
UUID=f51f73c6-00b0-4665-a643-20b4d8705278 swap swap defaults 0 0
[root@mindlife2 etc]#
--------------
/dev/sda1 and /dev/sda4 - my ntfs partitions.

--------------
[root@mindlife2 etc]# fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, всего 156301488 секторов
Units = секторы of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x29f629f6

Устр-во Загр     Начало       Конец       Блоки   Id  Система
/dev/sda1   *          63    40965749    20482843+   7  HPFS/NTFS/exFAT
/dev/sda2        40965750    81931499    20482875   83  Linux
/dev/sda3        81931500    83987819     1028160   82  Linux своп / Solaris
/dev/sda4        83987820   156296384    36154282+   7  HPFS/NTFS/exFAT
[root@mindlife2 etc]#
--------------
Comment 34 Aleksandr Kazantcev 2012-05-06 11:38:32 MSD
NTFS partitions now will be NOT MOUNT IN FSTAB, because it's found in temporary /media path. With install we delete ALL /media partitions - another it broke loading.

If you need use static mount - do it manually with UUID.

I'l later try fix ntfs config or create udev rules for fix it. But now DON'T manually mount NTFS partitions in install!
Comment 35 Denis Silakov 2012-12-25 15:11:39 MSK
The core issue reported here has been resolved quite long ago.

Notes about fstab records that can break the boot are still valid, but we have a separate bug #302 to discuss this.