Bug 1360 - avahi-0.6.31 occasionally crashing and not deleting own pid file
: avahi-0.6.31 occasionally crashing and not deleting own pid file
Status: RESOLVED DUPLICATE of bug 1317
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-27 18:40 MSK by Eugene Budanov
Modified: 2013-01-03 21:15 MSK (History)
2 users (show)

See Also:
RPM Package: avahi-dnsconfd-0.6.31-6-rosa2012.1.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Budanov 2012-12-27 18:40:35 MSK
Description of problem:

Sometimes Avahi crashed and began to spam journald messsages like that:

Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Dec 27 16:43:40 naglfar systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.

This problem leads to the fact that increased CPU and RAM usage. 

Problem partially fixed by deleting /var/run/avahi-daemon/pid. But that is not solution of problem. Because this situalion may repeat again.
Comment 1 FirstLevel 2012-12-28 09:37:20 MSK
I have such feedback from another user too.
Comment 2 Denis Koryavov 2013-01-03 21:15:20 MSK

*** This bug has been marked as a duplicate of bug 1317 ***