Bug 1355 - Unknown program is starting after beginning of ssh session
: Unknown program is starting after beginning of ssh session
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: Dmitry Mikhirev
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-27 14:57 MSK by FirstLevel
Modified: 2015-03-16 17:10 MSK (History)
6 users (show)

See Also:
RPM Package: initscripts-9.25-11.src.rpm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-12-27 14:57:11 MSK
Description of problem:
If user "fyr" connects to ROSA 2012.1 Fresh by ssh after login strange message is appeared:
-bash: [General]: команда не найдена
No modification for default  .bashrc and .bash_profile

# .bash_profile

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
        . ~/.bashrc
fi

# User specific environment and startup programs

PATH=$PATH:$HOME/bin

export PATH

and

# .bashrc

# User specific aliases and functions

# Source global definitions
if [ -f /etc/bashrc ]; then
        . /etc/bashrc
fi


Listing of home dir
[fyr@comp ~]$ ls -al
итого 736
drwxr-xr-x 28 fyr  fyr    4096 дек.  27 16:42 ./
drwxr-xr-x  5 root root   4096 дек.  27 16:05 ../
-rw-r--r--  1 fyr  fyr     387 окт.  18 00:33 .bash_completion
-rw-------  1 fyr  fyr     426 дек.  27 16:42 .bash_history
-rw-r--r--  1 fyr  fyr      24 окт.  17 19:15 .bash_logout
-rw-r--r--  1 fyr  fyr     191 окт.  17 19:15 .bash_profile
-rw-r--r--  1 fyr  fyr     124 окт.  17 19:15 .bashrc
drwx------  3 fyr  fyr    4096 дек.  25 19:16 .cache/
drwxr-xr-x  8 fyr  fyr    4096 дек.  25 19:16 .config/
drwx------  3 fyr  fyr    4096 дек.  24 20:18 .dbus/
-rw-------  1 fyr  fyr      26 дек.  24 20:18 .dmrc
-rw-------  1 fyr  fyr      16 дек.  24 20:18 .esd_auth
-rw-rw-rw-  1 fyr  fyr   84568 дек.  24 20:52 .face.icon
-rw-rw-r--  1 fyr  fyr     610 дек.  24 20:58 .fonts.conf
drwx------  2 fyr  fyr    4096 дек.  24 21:09 .gconf/
drwx------  3 fyr  fyr    4096 дек.  24 20:20 .gnome2/
drwx------  2 fyr  fyr    4096 дек.  24 20:20 .gnome2_private/
drwx------  2 fyr  fyr    4096 дек.  27 16:42 .gnupg/
drwxrwxr-x  2 fyr  fyr    4096 дек.  24 20:19 .gstreamer-0.10/
-rw-rw-r--  1 fyr  fyr     324 дек.  24 21:09 .gtk-bookmarks
-rw-rw-r--  1 fyr  fyr     188 дек.  24 20:18 .gtkrc-2.0-kde4
-rw-rw-r--  1 fyr  fyr     308 дек.  24 20:24 .i18n
drwxr-xr-x  6 fyr  fyr    4096 дек.  24 21:00 .kde4/
-rw-------  1 fyr  fyr     353 дек.  24 20:58 .kderc
drwx------  2 fyr  fyr    4096 дек.  24 21:03 .links/
drwxr-xr-x  3 fyr  fyr    4096 дек.  18 19:12 .local/
drwxr-xr-x  2 fyr  fyr    4096 дек.  24 20:19 .MdkOnline/
drwx------  4 fyr  fyr    4096 дек.  24 20:20 .mozilla/
drwx------ 18 fyr  fyr    4096 дек.  24 21:20 .opera/
drwxr-xr-x  2 fyr  fyr    4096 дек.  24 21:09 .psyncclient/
drwx------  2 fyr  fyr    4096 дек.  24 21:09 .pulse/
-rw-------  1 fyr  fyr     256 дек.  24 20:18 .pulse-cookie
drwxr-xr-x  3 fyr  fyr    4096 дек.  24 20:19 .rcc/
drwx------  2 fyr  fyr    4096 дек.  24 20:53 .ssh/
drwx------  3 fyr  fyr    4096 дек.  24 20:19 .thumbnails/
-rw-------  1 fyr  fyr      50 дек.  27 16:42 .Xauthority
-rw-------  1 fyr  fyr  491757 дек.  27 17:11 .xsession-errors
drwxr-xr-x  2 fyr  fyr    4096 дек.  27 00:28 Видео/
drwxr-xr-x  2 fyr  fyr    4096 дек.  24 20:18 Документы/
drwxr-xr-x  2 fyr  fyr    4096 дек.  24 20:18 Загрузки/
drwxr-xr-x  2 fyr  fyr    4096 дек.  24 20:18 Изображения/
drwxr-xr-x  2 fyr  fyr    4096 дек.  24 20:18 Музыка/
drwxr-xr-x  2 fyr  fyr    4096 дек.  24 20:19 Рабочий стол/
drwxr-xr-x  2 fyr  fyr    4096 дек.  24 20:18 Шаблоны/
[fyr@comp ~]$

Other user connected without any errors. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Aleksandr Kazantcev 2012-12-27 23:48:52 MSK
What mean 'another users connect without error'?

If create new user, bug is appear? If not this is problem not in ssh...
Comment 2 FirstLevel 2012-12-28 09:23:27 MSK
(In reply to comment #1)
> What mean 'another users connect without error'?
> 
> If create new user, bug is appear? If not this is problem not in ssh...

Yes. another user has no any error after login.
Comment 3 Dmitry Mikhirev 2012-12-28 16:59:02 MSK
The problem is that ~/.i18n file generated by KDE locale settings manager has ini syntax. I've fixed /etc/profile.d/10lang.sh to properly handle ini files instead of sourcing them directly.

Buildlists:
https://abf.rosalinux.ru/build_lists/871142
https://abf.rosalinux.ru/build_lists/871143

Advisory:
The error handling $HOME/.i18n file with ini syntax was fixed.
Comment 4 Vladimir Potapov 2013-01-09 11:05:12 MSK
initscripts-9.25-12.1-rosa.lts2012.0
***************** Advisory ********************
The error handling $HOME/.i18n file with ini syntax was fixed.
***********************************************
Comment 5 FirstLevel 2013-01-10 10:30:57 MSK
oops. It is some mistake. The bug was for 2012.1 Fresh system, but update issued for LTS release.
Comment 6 Vladimir Potapov 2013-01-10 14:46:12 MSK
The error present in  Marathon too.
http://bugs.rosalinux.ru/show_bug.cgi?id=1365
Comment 7 a.lahin 2015-03-16 17:10:29 MSK
To make sure that the patch is still needed, I've just installed ROSA.Desktop.Fresh.2012.i586 and changed locale (to get ~/.i18n config file) by using LocaleDrake (is this 'KDE locale settings manager'?).
Having done that I got no '[General]' string in the config.
So it seems that we can rid of the initscripts patch at least for newer releases.