Bug 1352 - Could not print web pages. Print jobs are suspended
: Could not print web pages. Print jobs are suspended
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-27 10:23 MSK by FirstLevel
Modified: 2013-06-06 09:57 MSD (History)
2 users (show)

See Also:
RPM Package: firefox-17.0-2-rosa2012.1.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments
diag.txt (2.16 KB, text/plain)
2012-12-27 10:23 MSK, FirstLevel
Details
ppd-file (19.87 KB, application/octet-stream)
2012-12-27 10:24 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-12-27 10:23:53 MSK
Created attachment 997 [details]
diag.txt

Description of problem:
I want to print web-page. Open it prn-01.jpg. See preview prn-02.jpg. Click PRINT, for example first page prn-03.jpg. Print job is beginning but suspended at once - prn-03.jpg
Other job (for example, from kwrite is successfull)
I have attached some diagnostic information and my ppd file

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-12-27 10:24:23 MSK
Created attachment 998 [details]
ppd-file
Comment 2 Denis Silakov 2013-04-16 20:32:13 MSD
Looks similar to bug #1865 and bug #1866.

In that bugs, it was suggested to try newer poppler.
Comment 3 FirstLevel 2013-04-17 09:11:29 MSD
(In reply to comment #2)
> Looks similar to bug #1865 and bug #1866.
> 
> In that bugs, it was suggested to try newer poppler.

And where is it?
Comment 4 Denis Silakov 2013-04-17 10:11:13 MSD
In djam_personal repos:

64bit:
http://abf.rosalinux.ru/downloads/djam_personal/repository/rosa2012.1/x86_64/main/release/

32bit:
http://abf.rosalinux.ru/downloads/djam_personal/repository/rosa2012.1/i586/main/release/

Remember that this new poppler should be used only as experiment now, some programs that depend on current poppler library may stop working after update to newer version.
Comment 5 FirstLevel 2013-04-17 14:38:37 MSD
(In reply to comment #4)
> In djam_personal repos:
> 
> 64bit:
> http://abf.rosalinux.ru/downloads/djam_personal/repository/rosa2012.1/x86_64/
> main/release/
> 
> 32bit:
> http://abf.rosalinux.ru/downloads/djam_personal/repository/rosa2012.1/i586/
> main/release/
> 
> Remember that this new poppler should be used only as experiment now, some
> programs that depend on current poppler library may stop working after
> update to newer version.

But if it so experimental should I recomend to use package from third-party repo?
Comment 6 Denis Silakov 2013-04-17 14:50:29 MSD
For us it would be useful to check if this package really fixes the problem, since we don't have a reproducer at our side. So I think we shouldn't recommend this as a general solution, but we need a volunteer to try the new packages.
Comment 7 FirstLevel 2013-04-18 09:38:53 MSD
(In reply to comment #6)
> For us it would be useful to check if this package really fixes the problem,
> since we don't have a reproducer at our side. So I think we shouldn't
> recommend this as a general solution, but we need a volunteer to try the new
> packages.

User has told that new poppler version fix his problem.
Is there any activity for updating poppler in official repo?
Comment 8 Denis Silakov 2013-04-18 10:01:20 MSD
Uh, there is a problematic thing called 'libreoffice' (more particular - libreoffice-pdfimport) that depends on old libpoppler.

So rebuild of packages with newer poppler requires some time (and there is no guarantee that everything will rebuild successfully). We'll try to do this, but I can't give any time estimation.
Comment 9 Denis Silakov 2013-04-21 10:06:10 MSD
I've pushed a request for poppler update - bug #1942.

As an experiment, you can install packages from containers mentioned in that bug.
Comment 10 Denis Silakov 2013-06-05 13:42:01 MSD
Updated poppler is in repositores now, can you check if this issue is still valid?
Comment 11 FirstLevel 2013-06-06 09:57:12 MSD
Problem is solved by new poppler package