Bug 1345 - Could not create route for network interface with eth0-route
: Could not create route for network interface with eth0-route
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-26 13:13 MSK by FirstLevel
Modified: 2013-01-09 19:41 MSK (History)
2 users (show)

See Also:
RPM Package: net-tools-1.60-37.20120702git.1-rosa2012.1.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-12-26 13:13:11 MSK
Description of problem:
I want to create additional persistent route to network interface. For example, for eth0 with such configuration
# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.128.75
NETMASK=255.255.255.192
ONBOOT=yes
METRIC=10
MII_NOT_SUPPORTED=no
USERCTL=yes
DNS1=192.168.128.65
RESOLV_MODS=no
LINK_DETECTION_DELAY=6
IPV6INIT=no
IPV6TO4INIT=no

I have created file /etc/sysconfig/network-scripts/route-eth0
# cat /etc/sysconfig/network-scripts/route-eth0 
192.168.192.0/18 via 192.168.128.65 eth0
but this route do not apply after reboot to routing table.
And I have only default routes
# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0
172.17.1.2      0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.128.64  0.0.0.0         255.255.255.192 U     0      0        0 eth0

How sgould I create additional route for network interface?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Dmitry Mikhirev 2012-12-28 17:08:53 MSK
Probably the root of problem is the same as in http://bugs.rosalinux.ru/show_bug.cgi?id=1339. Try adding

NM_CONTROLLED=no

to ifcfg-eth0.
Comment 2 FirstLevel 2012-12-29 15:31:20 MSK
(In reply to comment #1)
> Probably the root of problem is the same as in
> http://bugs.rosalinux.ru/show_bug.cgi?id=1339. Try adding
> 
> NM_CONTROLLED=no
> 
> to ifcfg-eth0.

Ok. It helps.