Bug 1340 - Please add description for bootloader location
: Please add description for bootloader location
Status: RESOLVED FIXED
Product: Desktop Features
Classification: ROSA Desktop
Component: All
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-25 15:31 MSK by FirstLevel
Modified: 2014-05-26 14:31 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-12-25 15:31:32 MSK
I have PC with many hardrives of one vendor.
When I install ROSA 2012.1 Fresh  I should to choose where to place the bootloader.
But at this window I see only: 
/dev/sda Seagate Techno...
/dev/sdb Seagate Techno...
/dev/sdc Seagate Techno...
/dev/sdd Seagate Techno...
/dev/sde Seagate Techno...
Please could You add some description for every item?
Maybe it could be hint with Full descripttion of harddrive?
Comment 1 Ben Bullard 2013-01-02 02:21:40 MSK
I have a computer that is a Linux multiboot with many partitions and multiple drives. I need to be able to select to install bootloader to root partition. This is done in all other Linux/Grub2 operating systems that I have used recently. This includes Fedora, openSUSE, and Ubuntu/Kubuntu.
Comment 2 Konstantin Vlasov 2013-01-07 19:04:47 MSK
(In reply to comment #0)
> ...
> Please could You add some description for every item?
> Maybe it could be hint with Full descripttion of harddrive?

I'll look what could be done here.


2 Ben Bullard:
Please, don't mix different bug reports together but file them separately.
Comment 3 Konstantin Vlasov 2013-01-10 17:39:25 MSK
(In reply to comment #0)
> Maybe it could be hint with Full descripttion of harddrive?

I investigated this issue and unfortunately there is no simple way to do that. It is impossible in GTK to display tooltips for individual lines of the drop-down listbox (which is implemented as GtkComboBox). Therefore, the only way to show any additional information would be typing the text directly within the dialog, but it would look ugly.

I can rearrange the HDD description text so that their sizes will be displayed before names (instead of after them), so you would see something like:
/dev/sda (500 Gb, Seagate Tech...
/dev/sdb (2 Tb, Seagate Techno...
At least, there will be some information to distinguish devices. Does that sound good for you?
Comment 4 FirstLevel 2013-01-10 17:52:34 MSK
(In reply to comment #3)
> (In reply to comment #0)
> > Maybe it could be hint with Full descripttion of harddrive?
> 
> I investigated this issue and unfortunately there is no simple way to do
> that. It is impossible in GTK to display tooltips for individual lines of
> the drop-down listbox (which is implemented as GtkComboBox). Therefore, the
> only way to show any additional information would be typing the text
> directly within the dialog, but it would look ugly.
> 
> I can rearrange the HDD description text so that their sizes will be
> displayed before names (instead of after them), so you would see something
> like:
> /dev/sda (500 Gb, Seagate Tech...
> /dev/sdb (2 Tb, Seagate Techno...
> At least, there will be some information to distinguish devices. Does that
> sound good for you?

It is looking better than nothing :)
Comment 5 Konstantin Vlasov 2014-05-14 19:35:55 MSD
This has been implemented in draklive-install-1.45-3 (see bug #4028).
Comment 6 Konstantin Vlasov 2014-05-26 13:15:18 MSD
*** Bug 4056 has been marked as a duplicate of this bug. ***
Comment 7 Evgeniy 2014-05-26 13:27:55 MSD
I don't know the rules, but why it's marked as solved? Three bugs were reported on different systems and none of them is fixed. However, all of them are marked as "solved".

I put forward the idea of modifying completely the installer to reduce time of user involvement (http://bugs.rosalinux.ru/show_bug.cgi?id=4058).

If we have so many troubles with the installer, maybe it's time to replace it with something?
Comment 8 Konstantin Vlasov 2014-05-26 13:37:30 MSD
(In reply to comment #7)
> If we have so many troubles with the installer, maybe it's time to replace
> it with something?

Each "something" is bound very tightly to the distribution it was developed for. It's a VERY hard and resource-demanding task to detach an installer from some other Linux and re-attach it to our system. Believe us, we tried. Maybe, eventually we will end up with something different, but it will take lots of time and effort.
Comment 9 Evgeniy 2014-05-26 13:55:34 MSD
Ok, could you answer one more question.

The process of Linux installation is a live medium that runs, detects devices, then starts the installer. When you install Ubuntu, you start Ubuntu, a full distro, then you start the installer. During the installation you can start Firefox or read books. openSUSE's installer is the same, but the installer expanded fullscreen, so you can't start a browser or do anything else.

Why does the ROSA installer not run instance of the distro? It runs a minimal system, that can't even change screen resolution, without command-line mode to solve some troubles, like short combobox.

Talking about Bug No 4058 (Boring installation), the installer positively asked me in the beginning, middle, and in the ending, instead of asking me only in the beginning.
Comment 10 Konstantin Vlasov 2014-05-26 14:08:34 MSD
(In reply to comment #9)
> Why does the ROSA installer not run instance of the distro?

But it does! Just boot Live mode instead of installation (choose "Start ROSA Desktop..." item in the DVD boot menu).

> Talking about Bug No 4058 (Boring installation), the installer positively
> asked me in the beginning, middle, and in the ending, instead of asking me
> only in the beginning.

Then, please, give us more details. We definitely don't see any such behavior here. Here is the full list of steps:
1st stage: Language, license, keyboard layout, timezone, some short waiting while partitions are analyzed (normally, just a couple of seconds), partitioning. Then installation itself starts and does not ask anything until it finishes.
2nd stage: Bootloader configuration (will take a couple of seconds to read the list of installed systems and generate proper grub menu and initrd), root password, creating new user, network hostname, startup services.
Comment 11 Evgeniy 2014-05-26 14:23:41 MSD
Yes, this is a full description:

> Then, please, give us more details. We definitely don't see any such
> behavior here. Here is the full list of steps:
> 1st stage: Language, license, keyboard layout, timezone, some short waiting
> while partitions are analyzed (normally, just a couple of seconds),
> partitioning. Then installation itself starts and does not ask anything
> until it finishes.
> 2nd stage: Bootloader configuration (will take a couple of seconds to read
> the list of installed systems and generate proper grub menu and initrd),
> root password, creating new user, network hostname, startup services.

All these questions can be asked in the beginning, so a user won't be bothered all the time.
Comment 12 Konstantin Vlasov 2014-05-26 14:31:28 MSD
(In reply to comment #11)
> All these questions can be asked in the beginning, so a user won't be
> bothered all the time.

It's in our todo-list, but since it's not a critical task we have to solve more prioritized problems first.