Bug 1339 - Configuration for alias of network interface does not work
: Configuration for alias of network interface does not work
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-25 14:03 MSK by FirstLevel
Modified: 2013-01-09 19:42 MSK (History)
3 users (show)

See Also:
RPM Package: net-tools-1.60-37.20120702git.1-rosa2012.1.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments
ifconfig -a (1.33 KB, text/plain)
2012-12-25 14:03 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-12-25 14:03:28 MSK
Created attachment 994 [details]
ifconfig -a

Description of problem:
I have ROSA Fresh 2012.1 installed. But I could not configure alias for my network interface.
I have such configuration (it is work in ROSA 2012 LTS):
# cat /etc/sysconfig/network-scripts/ifcfg-eth0:1
DEVICE=eth0:1
BOOTPROTO=static
IPADDR=192.168.13.75
NETMASK=255.255.255.0
ONBOOT=yes
METRIC=10
MII_NOT_SUPPORTED=no
USERCTL=yes
DNS1=192.168.128.65
RESOLV_MODS=no
LINK_DETECTION_DELAY=6
IPV6INIT=no
IPV6TO4INIT=no


# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.128.75
NETMASK=255.255.255.192
ONBOOT=yes
METRIC=10
MII_NOT_SUPPORTED=no
USERCTL=yes
DNS1=192.168.128.65
RESOLV_MODS=no
LINK_DETECTION_DELAY=6
IPV6INIT=no
IPV6TO4INIT=no

But I have not found information about eth0:1 in ifconfig -a output (I hsve attached this output). In ROSA 2012 LTS this configuration work well and I see interface eth0:1 in ifconfig -a output
How should I configure alias eth0:1?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-12-25 14:07:10 MSK
In ROSA 2012 LTS when I have configured text file ifcfg-eth0 I have seen that on the networkmanager icon in the tray red brick is appear immediately after this.

But in ROSA 2012.1 Fresh I see it looks like networkmanager manage my network connections even when I configure ifcfg-eth0 manually.
Comment 2 Alexander Burmashev 2012-12-25 14:08:09 MSK
In case you do now want to use networkmanager at all, did you try disabling and stopping it ?
systemctl disable networkmanager
systemctl stop networkmanager
Comment 3 FirstLevel 2012-12-25 15:17:11 MSK
(In reply to comment #2)
> In case you do now want to use networkmanager at all, did you try disabling
> and stopping it ?
> systemctl disable networkmanager
> systemctl stop networkmanager

I have done:
# systemctl disable networkmanager.service
networkmanager.service is not a native service, redirecting to /sbin/chkconfig.
Executing /sbin/chkconfig networkmanager off
# systemctl stop networkmanager.service

But it did not solve my problem.
Comment 4 Dmitry Mikhirev 2012-12-27 19:56:48 MSK
Please provide an output of following commands:

# ifup eth0:1
# ip addr
Comment 5 FirstLevel 2012-12-28 13:20:16 MSK
(In reply to comment #4)
> Please provide an output of following commands:
> 
> # ifup eth0:1
> # ip addr

# ifup eth0:1
/sbin/ifup: interface eth0:1 is controlled by NetworkManager; skipping.

#ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1f:d0:5a:7c:65 brd ff:ff:ff:ff:ff:ff
    inet 192.168.128.75/26 brd 192.168.128.127 scope global eth0
    inet6 fe80::21f:d0ff:fe5a:7c65/64 scope link 
       valid_lft forever preferred_lft forever
21: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc pfifo_fast state UNKNOWN qlen 3
    link/ppp 
    inet 192.168.1.75 peer 172.17.1.3/32 scope global ppp0
Comment 6 Dmitry Mikhirev 2012-12-28 17:05:56 MSK
(In reply to comment #5)

> /sbin/ifup: interface eth0:1 is controlled by NetworkManager; skipping.

You have to disable NetworkManager for this interfaces by adding

NM_CONTROLLED=no

to ifcfg-eth0 and ifcfg-eth0:1.
Comment 7 FirstLevel 2012-12-29 15:32:36 MSK
(In reply to comment #6)
> (In reply to comment #5)
> 
> > /sbin/ifup: interface eth0:1 is controlled by NetworkManager; skipping.
> 
> You have to disable NetworkManager for this interfaces by adding
> 
> NM_CONTROLLED=no
> 
> to ifcfg-eth0 and ifcfg-eth0:1.

Yes. it helps